summaryrefslogtreecommitdiff
path: root/dev-python/emcee/emcee-3.1.6.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2024-04-20 12:05:24 +0100
committerV3n3RiX <venerix@koprulu.sector>2024-04-20 12:05:24 +0100
commitda7ae1dd1fccb6b3c0e4763ab983ad96d57bf463 (patch)
tree0a7a1b7b3ad60c3b21c697e75908b256fc9ed6b1 /dev-python/emcee/emcee-3.1.6.ebuild
parentb6cfc0c19effe2d9f7b8ab303cd00636f16da253 (diff)
gentoo auto-resync : 20:04:2024 - 12:05:23
Diffstat (limited to 'dev-python/emcee/emcee-3.1.6.ebuild')
-rw-r--r--dev-python/emcee/emcee-3.1.6.ebuild50
1 files changed, 50 insertions, 0 deletions
diff --git a/dev-python/emcee/emcee-3.1.6.ebuild b/dev-python/emcee/emcee-3.1.6.ebuild
new file mode 100644
index 000000000000..4af1b70ed9fc
--- /dev/null
+++ b/dev-python/emcee/emcee-3.1.6.ebuild
@@ -0,0 +1,50 @@
+# Copyright 1999-2024 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=setuptools
+PYTHON_COMPAT=( python3_{10..12} )
+
+inherit distutils-r1 multiprocessing pypi
+
+DESCRIPTION="Python ensemble sampling toolkit for affine-invariant MCMC"
+HOMEPAGE="
+ https://emcee.readthedocs.io/en/stable/
+ https://github.com/dfm/emcee/
+ https://pypi.org/project/emcee/
+"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~x86 ~amd64-linux ~x86-linux"
+
+DEPEND="
+ dev-python/h5py[${PYTHON_USEDEP}]
+ dev-python/numpy[${PYTHON_USEDEP}]
+"
+RDEPEND="
+ ${DEPEND}
+"
+BDEPEND="
+ dev-python/setuptools-scm[${PYTHON_USEDEP}]
+ test? (
+ dev-python/pytest-xdist[${PYTHON_USEDEP}]
+ dev-python/scipy[${PYTHON_USEDEP}]
+ )
+"
+
+distutils_enable_tests pytest
+
+DOCS=( AUTHORS.rst README.rst )
+
+src_prepare() {
+ # unnecessary dep
+ sed -i -e '/wheel/d' setup.py || die
+ distutils-r1_src_prepare
+}
+
+python_test() {
+ local -x PYTEST_DISABLE_PLUGIN_AUTOLOAD=1
+ epytest -p xdist -n "$(makeopts_jobs)" --dist=worksteal
+}