summaryrefslogtreecommitdiff
path: root/dev-python/elementpath/elementpath-1.3.1.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2019-12-15 18:09:03 +0000
committerV3n3RiX <venerix@redcorelinux.org>2019-12-15 18:09:03 +0000
commit7bc9c63c9da678a7e6fceb095d56c634afd22c56 (patch)
tree4a67d50a439e9af63947e5f8b6ba3719af98b6c9 /dev-python/elementpath/elementpath-1.3.1.ebuild
parentb284a3168fa91a038925d2ecf5e4791011ea5e7d (diff)
gentoo resync : 15.12.2019
Diffstat (limited to 'dev-python/elementpath/elementpath-1.3.1.ebuild')
-rw-r--r--dev-python/elementpath/elementpath-1.3.1.ebuild36
1 files changed, 36 insertions, 0 deletions
diff --git a/dev-python/elementpath/elementpath-1.3.1.ebuild b/dev-python/elementpath/elementpath-1.3.1.ebuild
new file mode 100644
index 000000000000..4884138e8842
--- /dev/null
+++ b/dev-python/elementpath/elementpath-1.3.1.ebuild
@@ -0,0 +1,36 @@
+# Copyright 2019 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+PYTHON_COMPAT=( python2_7 python3_{5,6,7,8} )
+inherit distutils-r1
+
+DESCRIPTION="XPath 1.0/2.0 parsers and selectors for ElementTree and lxml"
+HOMEPAGE="https://github.com/sissaschool/elementpath
+ https://pypi.org/project/elementpath/"
+SRC_URI="mirror://pypi/${PN::1}/${PN}/${P}.tar.gz"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="test"
+RESTRICT="!test? ( test )"
+
+BDEPEND="
+ dev-python/setuptools[${PYTHON_USEDEP}]
+ test? (
+ dev-python/lxml[${PYTHON_USEDEP}]
+ dev-python/xmlschema[${PYTHON_USEDEP}]
+ )"
+
+distutils_enable_tests unittest
+
+src_prepare() {
+ distutils-r1_src_prepare
+
+ # this test fails depending on system locale + requires some random
+ # locales being installed
+ sed -e 's:test_compare_strings_function:_&:' \
+ -i tests/test_xpath2_parser.py || die
+}