summaryrefslogtreecommitdiff
path: root/dev-python/elasticsearch
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2023-07-25 05:42:53 +0100
committerV3n3RiX <venerix@koprulu.sector>2023-07-25 05:42:53 +0100
commit5c636a121a9064a4373d06b60d49a6f5d67c0e2f (patch)
tree8e5c8c582e12cb579ac94bdaafcd00282252a50d /dev-python/elasticsearch
parentb83b16e0f6c963583f6323fe1bb12ecbd11d6f81 (diff)
gentoo auto-resync : 25:07:2023 - 05:42:52
Diffstat (limited to 'dev-python/elasticsearch')
-rw-r--r--dev-python/elasticsearch/Manifest7
-rw-r--r--dev-python/elasticsearch/elasticsearch-8.7.0.ebuild66
-rw-r--r--dev-python/elasticsearch/elasticsearch-8.8.0.ebuild66
-rw-r--r--dev-python/elasticsearch/elasticsearch-8.8.2.ebuild66
-rw-r--r--dev-python/elasticsearch/metadata.xml17
5 files changed, 222 insertions, 0 deletions
diff --git a/dev-python/elasticsearch/Manifest b/dev-python/elasticsearch/Manifest
new file mode 100644
index 000000000000..7e645af9e3ea
--- /dev/null
+++ b/dev-python/elasticsearch/Manifest
@@ -0,0 +1,7 @@
+DIST elasticsearch-py-8.7.0.gh.tar.gz 523141 BLAKE2B bbc6c59e921c5e8db3b7815a3086abe42690733d6719dcf3e167a521b1e7b38e68bf29ff2b1e0e48839be36c11feb9cb5bd9da507c35f508063ccfe9f3c24c59 SHA512 8f28d51cde600069692c8bef810e7949165a5f7a3ec440513a5f69e5c392ecb928dbd0317a9424d1845f523230a421e7d53db41a03b1bd3cc232c4b04ee0c894
+DIST elasticsearch-py-8.8.0.gh.tar.gz 526860 BLAKE2B 81d747c6ff3a552bcb279bc6ae4ede6a20c9516610f375dc11183eb38b759b4a8b4a9d0af9747300f483f3df403d918d938e50ae8bec91d09b67b7e81b11a114 SHA512 8bbbbfdcb658b648f2b3c7bd41c0d83cc66385eb8e5a118714c146c7ee8fb247f606098cc3ddacb679e009495dc8dbc0e3159fb0cae38ee49399e27c868940f1
+DIST elasticsearch-py-8.8.2.gh.tar.gz 527409 BLAKE2B e7768150e22995b4ae4a5b0898a252c46e90b224e8c4132a7035d726db9367facfe2cd006c0d319454c61c075d180776f567e45791d731bf1fc1d40a78d284a2 SHA512 5e5610425fe3727b817fbeafb411fa3e455a1f08c4992774c95c93c5b0d01880198d39febb18baee7a1da85bd126d9679fb6a2aac4602df8ec49cfff0b5bd3be
+EBUILD elasticsearch-8.7.0.ebuild 2213 BLAKE2B 8811ef9b3746a919461c1823075ad4178cee49e1f3e3747d6edf2ebc4ad5acefb107a3d7fe54712c2f920e5795f75a3c08da01f0256f5090d5cfb6765f8eaed6 SHA512 481f736f689759e95de72454afe40017d3d0830d5429e1f34cf3a34df7724bf3c4881be99d7d61cec75212b048e7cdc1b562df05221065843539e4024489fa48
+EBUILD elasticsearch-8.8.0.ebuild 2198 BLAKE2B 8bf971267df280c9cb1f920ef15b35c0bd5301d92f5a87f4eae7c2da97e1afbdd9b78582dfc6ee7d16a680ed52b579463cba4a2b704c582684a94c75a34efcf4 SHA512 64e055a4c067f882b6b8886c3d41b3f92bd30b5028ffba2b5df5bcab932d774b85b1b6b0c5b654858311becda01d6b31f81248d8c8e3636d1e9cc7db055bd909
+EBUILD elasticsearch-8.8.2.ebuild 2198 BLAKE2B 8edc328f49a751bd705a2281786e20be795b306add4da75d397e6ef72907c7f663171c315e48cd05994bd9b7679d2e58c61982917c068922c16562b767ab4304 SHA512 99f486c5e00ed9b4a91b7a2f8528d83d910a00a6ff66fc535e8855e3043bee46ff854c2ff6480620180ea2958a52b6597ad491754635ae2fa9676a33482c0151
+MISC metadata.xml 563 BLAKE2B 55aa4f1e346ef660c4c8c5bf53518685e68fea80787d4a4175405e67c2b6e9c31d14fd48577c48c82ed59651c32110d4dbbd907ce29b599ca3bddddd1b5e808a SHA512 142657aca39d615755acb7cd6bdaa920935640ce1e3f00a241bb2a41ce2745fd73e341b80edf3fd830e9c9796285df1d69e62b868252602b6ff9e1ff6a2be599
diff --git a/dev-python/elasticsearch/elasticsearch-8.7.0.ebuild b/dev-python/elasticsearch/elasticsearch-8.7.0.ebuild
new file mode 100644
index 000000000000..ad2335144a0b
--- /dev/null
+++ b/dev-python/elasticsearch/elasticsearch-8.7.0.ebuild
@@ -0,0 +1,66 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=setuptools
+PYTHON_COMPAT=( python3_{9..11} )
+inherit distutils-r1
+
+MY_P="elasticsearch-py-${PV}"
+
+DESCRIPTION="Official Elasticsearch client library for Python"
+HOMEPAGE="
+ https://ela.st/es-python
+ https://github.com/elastic/elasticsearch-py
+ https://pypi.org/project/elasticsearch/
+"
+SRC_URI="https://github.com/elastic/elasticsearch-py/archive/refs/tags/v${PV}.tar.gz -> ${MY_P}.gh.tar.gz"
+S="${WORKDIR}/${MY_P}"
+
+LICENSE="Apache-2.0"
+SLOT="0/$(ver_cut 1)"
+KEYWORDS="amd64 ~x86"
+
+RESTRICT="!test? ( test )"
+
+RDEPEND="
+ >=dev-python/aiohttp-3[${PYTHON_USEDEP}] <dev-python/aiohttp-4[${PYTHON_USEDEP}]
+ >=dev-python/elastic-transport-8[${PYTHON_USEDEP}] <dev-python/elastic-transport-9[${PYTHON_USEDEP}]
+ >=dev-python/requests-2.4[${PYTHON_USEDEP}] <dev-python/requests-3[${PYTHON_USEDEP}]
+"
+BDEPEND="
+ test? (
+ ${RDEPEND}
+ dev-python/mapbox-vector-tile[${PYTHON_USEDEP}]
+ dev-python/numpy[${PYTHON_USEDEP}]
+ dev-python/pandas[${PYTHON_USEDEP}]
+ dev-python/pytest-asyncio[${PYTHON_USEDEP}]
+ dev-python/python-dateutil[${PYTHON_USEDEP}]
+ >=dev-python/pyyaml-5.4[${PYTHON_USEDEP}]
+ dev-python/unasync[${PYTHON_USEDEP}]
+ )
+"
+
+EPYTEST_IGNORE=(
+ # REST api tests are a black hole for effort. It downloads the tests so its an ever moving target
+ # It also requires effort to blacklist tests for apis which are license restricted.
+ "test_elasticsearch/test_server/test_rest_api_spec.py"
+ # Counting deprecation warnings from python is bound to fail even if all are fixed in this package
+ # Not worth it
+ "test_elasticsearch/test_client/test_deprecated_options.py"
+ # Running daemon for tests is finicky and upstream CI fails at it as well
+ "test_elasticsearch/test_server/"
+ "test_elasticsearch/test_async/test_server/"
+)
+
+distutils_enable_sphinx docs/sphinx dev-python/sphinx-rtd-theme
+distutils_enable_tests pytest
+
+src_prepare() {
+ # Replace added pytest options with setting asyncio_mode to auto.
+ # Test suite hasnt set asyncio parameters so its needed here.
+ sed -i '/[tool:pytest]/,/^$/ { s/addopts.*/asyncio_mode = auto/ }' setup.cfg || die
+
+ default
+}
diff --git a/dev-python/elasticsearch/elasticsearch-8.8.0.ebuild b/dev-python/elasticsearch/elasticsearch-8.8.0.ebuild
new file mode 100644
index 000000000000..458d7cf0a7a8
--- /dev/null
+++ b/dev-python/elasticsearch/elasticsearch-8.8.0.ebuild
@@ -0,0 +1,66 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=setuptools
+PYTHON_COMPAT=( python3_{9..11} )
+inherit distutils-r1
+
+MY_P="elasticsearch-py-${PV}"
+
+DESCRIPTION="Official Elasticsearch client library for Python"
+HOMEPAGE="
+ https://ela.st/es-python
+ https://github.com/elastic/elasticsearch-py
+ https://pypi.org/project/elasticsearch/
+"
+SRC_URI="https://github.com/elastic/elasticsearch-py/archive/refs/tags/v${PV}.tar.gz -> ${MY_P}.gh.tar.gz"
+S="${WORKDIR}/${MY_P}"
+
+LICENSE="Apache-2.0"
+SLOT="0/$(ver_cut 1)"
+KEYWORDS="~amd64 ~x86"
+
+RESTRICT="!test? ( test )"
+
+RDEPEND="
+ >=dev-python/aiohttp-3[${PYTHON_USEDEP}] <dev-python/aiohttp-4[${PYTHON_USEDEP}]
+ >=dev-python/elastic-transport-8[${PYTHON_USEDEP}] <dev-python/elastic-transport-9[${PYTHON_USEDEP}]
+ >=dev-python/requests-2.4[${PYTHON_USEDEP}] <dev-python/requests-3[${PYTHON_USEDEP}]
+"
+BDEPEND="
+ test? (
+ ${RDEPEND}
+ dev-python/mapbox-vector-tile[${PYTHON_USEDEP}]
+ dev-python/numpy[${PYTHON_USEDEP}]
+ dev-python/pandas[${PYTHON_USEDEP}]
+ dev-python/pytest-asyncio[${PYTHON_USEDEP}]
+ dev-python/python-dateutil[${PYTHON_USEDEP}]
+ >=dev-python/pyyaml-5.4[${PYTHON_USEDEP}]
+ dev-python/unasync[${PYTHON_USEDEP}]
+ )
+"
+
+EPYTEST_IGNORE=(
+ # REST api tests are a black hole for effort. It downloads the tests so its an ever moving target
+ # It also requires effort to blacklist tests for apis which are license restricted.
+ "test_elasticsearch/test_server/test_rest_api_spec.py"
+ # Counting deprecation warnings from python is bound to fail even if all are fixed in this package
+ # Not worth it
+ "test_elasticsearch/test_client/test_deprecated_options.py"
+ # Running daemon for tests is finicky and upstream CI fails at it as well
+ "test_elasticsearch/test_server/"
+ "test_elasticsearch/test_async/test_server/"
+)
+
+distutils_enable_sphinx docs/sphinx dev-python/sphinx-rtd-theme
+distutils_enable_tests pytest
+
+src_prepare() {
+ # Replace added pytest options with setting asyncio_mode to auto.
+ # Test suite hasnt set asyncio parameters so its needed here.
+ sed -i '/[tool:pytest]/,/^$/ { s/addopts.*/asyncio_mode = auto/ }' setup.cfg || die
+
+ default
+}
diff --git a/dev-python/elasticsearch/elasticsearch-8.8.2.ebuild b/dev-python/elasticsearch/elasticsearch-8.8.2.ebuild
new file mode 100644
index 000000000000..d80ae90d4ca1
--- /dev/null
+++ b/dev-python/elasticsearch/elasticsearch-8.8.2.ebuild
@@ -0,0 +1,66 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=setuptools
+PYTHON_COMPAT=( python3_{10..11} )
+inherit distutils-r1
+
+MY_P="elasticsearch-py-${PV}"
+
+DESCRIPTION="Official Elasticsearch client library for Python"
+HOMEPAGE="
+ https://ela.st/es-python
+ https://github.com/elastic/elasticsearch-py
+ https://pypi.org/project/elasticsearch/
+"
+SRC_URI="https://github.com/elastic/elasticsearch-py/archive/refs/tags/v${PV}.tar.gz -> ${MY_P}.gh.tar.gz"
+S="${WORKDIR}/${MY_P}"
+
+LICENSE="Apache-2.0"
+SLOT="0/$(ver_cut 1)"
+KEYWORDS="amd64 ~x86"
+
+RESTRICT="!test? ( test )"
+
+RDEPEND="
+ >=dev-python/aiohttp-3[${PYTHON_USEDEP}] <dev-python/aiohttp-4[${PYTHON_USEDEP}]
+ >=dev-python/elastic-transport-8[${PYTHON_USEDEP}] <dev-python/elastic-transport-9[${PYTHON_USEDEP}]
+ >=dev-python/requests-2.4[${PYTHON_USEDEP}] <dev-python/requests-3[${PYTHON_USEDEP}]
+"
+BDEPEND="
+ test? (
+ ${RDEPEND}
+ dev-python/mapbox-vector-tile[${PYTHON_USEDEP}]
+ dev-python/numpy[${PYTHON_USEDEP}]
+ dev-python/pandas[${PYTHON_USEDEP}]
+ dev-python/pytest-asyncio[${PYTHON_USEDEP}]
+ dev-python/python-dateutil[${PYTHON_USEDEP}]
+ >=dev-python/pyyaml-5.4[${PYTHON_USEDEP}]
+ dev-python/unasync[${PYTHON_USEDEP}]
+ )
+"
+
+EPYTEST_IGNORE=(
+ # REST api tests are a black hole for effort. It downloads the tests so its an ever moving target
+ # It also requires effort to blacklist tests for apis which are license restricted.
+ "test_elasticsearch/test_server/test_rest_api_spec.py"
+ # Counting deprecation warnings from python is bound to fail even if all are fixed in this package
+ # Not worth it
+ "test_elasticsearch/test_client/test_deprecated_options.py"
+ # Running daemon for tests is finicky and upstream CI fails at it as well
+ "test_elasticsearch/test_server/"
+ "test_elasticsearch/test_async/test_server/"
+)
+
+distutils_enable_sphinx docs/sphinx dev-python/sphinx-rtd-theme
+distutils_enable_tests pytest
+
+src_prepare() {
+ # Replace added pytest options with setting asyncio_mode to auto.
+ # Test suite hasnt set asyncio parameters so its needed here.
+ sed -i '/[tool:pytest]/,/^$/ { s/addopts.*/asyncio_mode = auto/ }' setup.cfg || die
+
+ default
+}
diff --git a/dev-python/elasticsearch/metadata.xml b/dev-python/elasticsearch/metadata.xml
new file mode 100644
index 000000000000..2edf51fc8139
--- /dev/null
+++ b/dev-python/elasticsearch/metadata.xml
@@ -0,0 +1,17 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "https://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <maintainer type="person" proxied="yes">
+ <email>parona@protonmail.com</email>
+ <name>Alfred Wingate</name>
+ </maintainer>
+ <maintainer type="project" proxied="proxy">
+ <email>proxy-maint@gentoo.org</email>
+ <name>Proxy Maintainers</name>
+ </maintainer>
+ <upstream>
+ <remote-id type="github">elastic/elasticsearch-py</remote-id>
+ <remote-id type="pypi">elasticsearch</remote-id>
+ </upstream>
+ <stabilize-allarches/>
+</pkgmetadata>