summaryrefslogtreecommitdiff
path: root/dev-python/elastic-transport
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2024-02-03 17:44:31 +0000
committerV3n3RiX <venerix@koprulu.sector>2024-02-03 17:44:31 +0000
commitc44123f79f40edf5fe3d4b0d211d6aa68542abd2 (patch)
tree838edea4b7f78b425eacf44f29775ffd0bc671e3 /dev-python/elastic-transport
parent79e5685b8db7602719212510574962664af2b036 (diff)
gentoo auto-resync : 03:02:2024 - 17:44:31
Diffstat (limited to 'dev-python/elastic-transport')
-rw-r--r--dev-python/elastic-transport/Manifest2
-rw-r--r--dev-python/elastic-transport/elastic-transport-8.11.0.ebuild64
2 files changed, 0 insertions, 66 deletions
diff --git a/dev-python/elastic-transport/Manifest b/dev-python/elastic-transport/Manifest
index 2ec588f82ce4..2dd24ba4315c 100644
--- a/dev-python/elastic-transport/Manifest
+++ b/dev-python/elastic-transport/Manifest
@@ -1,5 +1,3 @@
-DIST elastic-transport-python-8.11.0.gh.tar.gz 71944 BLAKE2B 9f5199b171f57169e2ca9d77f225a7ad1d67cc28550a41648f37305342f2cddb2c570e0b314057e49d4a5948ceacdbfbe3d928a456ef47fd334abebbf8c6c718 SHA512 b2ab09c63e5824d8cb59ed78728e4670115eee56bb07310e4d8a083b86eace4bc2dfc0dbefc4346906338acf195b193c0f2fc99a0dc1190ac30950fbe6fbcc70
DIST elastic-transport-python-8.12.0.gh.tar.gz 72207 BLAKE2B 7777484c965eb893cd7d2cba1d39c2b33a005e7f6d6b3c12dd1cd0fb4e5c396abf36686421817ba1272e814ffef299453c885a6dcc3efe5cacd753bcd621384e SHA512 45834ccb4793d7aa7c7d1774ef26381b7ff0cf69221cc628efeb63a7ff8b163a68ff7f0ef4fa3a2b5ffd45e9374441d8b61b8a9b900f9055ddd67425cf0d727a
-EBUILD elastic-transport-8.11.0.ebuild 1598 BLAKE2B ce65e15c415baaf9260b6600e57fee9257ffb94ae913377ea3ff38c151fb8fddb7c61516e1ecc4b6b5274e155744819384a7957db427fb413b239d3d6bbc9a5f SHA512 9f667bc6ee65560e1c80e89995efb0222a5fd8453a1994d2d191c6931ce4a1605f24116d7a1a1d79ffd9ea5b4104e2fb726a1f3194282b7e549e5a2b7f4dca3f
EBUILD elastic-transport-8.12.0.ebuild 1603 BLAKE2B 95871fe70ab33e20550de8a46d4aac28f638b583f3f781653930b49d3ecd1d51ae6430de7a92e1a1bf558ea12be8c66b92447e21701077687832b64f2c4475ff SHA512 2537e2e34fc88ffd49a96e02057b2cb9a118e2e4a1d02a71e78efddcab45ba8e96b08674bb1166af282fb5fe1ca575837bc7981327a2be4fc6f73f69e45e8c01
MISC metadata.xml 658 BLAKE2B 7ba1da27d590421cdd7a24d01d38771b27ae65f09521e39bc84e691f3e587a3bccabcdd297350166e00324ca482dd0459e8213ed578d81f9e93469fd3efec48d SHA512 c39cf837ff098fb09c25d1933f43c0f20e1b2b5ae4e1bb5aa172aac43f8f36ea80437e3e59909b0c51d0f8301853bdb6b5dbd7f3498502baa8936939bc0210d8
diff --git a/dev-python/elastic-transport/elastic-transport-8.11.0.ebuild b/dev-python/elastic-transport/elastic-transport-8.11.0.ebuild
deleted file mode 100644
index 9f2dbfa5496e..000000000000
--- a/dev-python/elastic-transport/elastic-transport-8.11.0.ebuild
+++ /dev/null
@@ -1,64 +0,0 @@
-# Copyright 2023 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=8
-
-DISTUTILS_USE_PEP517=setuptools
-PYTHON_COMPAT=( python3_{10..12} )
-
-inherit distutils-r1
-
-MY_P=elastic-transport-python-${PV}
-DESCRIPTION="Transport classes and utilities shared among Python Elastic client libraries"
-HOMEPAGE="
- https://github.com/elastic/elastic-transport-python/
- https://pypi.org/project/elastic-transport/
-"
-SRC_URI="
- https://github.com/elastic/elastic-transport-python/archive/v${PV}.tar.gz
- -> ${MY_P}.gh.tar.gz
-"
-S=${WORKDIR}/${MY_P}
-
-LICENSE="Apache-2.0"
-SLOT="0"
-KEYWORDS="amd64 arm64 x86"
-PROPERTIES="test_network"
-RESTRICT="test"
-
-RDEPEND="
- dev-python/certifi[${PYTHON_USEDEP}]
- >=dev-python/urllib3-1.26.2[${PYTHON_USEDEP}]
-"
-BDEPEND="
- test? (
- dev-python/aiohttp[${PYTHON_USEDEP}]
- dev-python/mock[${PYTHON_USEDEP}]
- dev-python/pytest-asyncio[${PYTHON_USEDEP}]
- dev-python/pytest-httpserver[${PYTHON_USEDEP}]
- dev-python/requests[${PYTHON_USEDEP}]
- dev-python/trustme[${PYTHON_USEDEP}]
- )
-"
-
-distutils_enable_sphinx docs/sphinx \
- dev-python/furo \
- dev-python/sphinx-autodoc-typehints
-distutils_enable_tests pytest
-
-src_prepare() {
- # unpin deps
- sed -i -e 's:, *<[0-9.]*::' setup.py || die
- distutils-r1_src_prepare
-}
-
-python_test() {
- local EPYTEST_DESELECT=(
- # fragile to random warnings
- tests/node/test_http_aiohttp.py::TestAiohttpHttpNode::test_uses_https_if_verify_certs_is_off
- tests/node/test_urllib3_chain_certs.py::test_assert_fingerprint_in_cert_chain
- )
-
- local -x PYTEST_DISABLE_PLUGIN_AUTOLOAD=1
- epytest -p asyncio -o addopts=
-}