summaryrefslogtreecommitdiff
path: root/dev-python/elastic-transport
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2023-09-26 11:27:54 +0100
committerV3n3RiX <venerix@koprulu.sector>2023-09-26 11:27:54 +0100
commit25e2c97a4a6f12a367115508fc86d34fe76a6f5e (patch)
tree68acc191d796190f572dc374002717fec321e616 /dev-python/elastic-transport
parent1aa38370b2506ce90ad64cd4e18968d6612ebea5 (diff)
gentoo auto-resync : 26:09:2023 - 11:27:54
Diffstat (limited to 'dev-python/elastic-transport')
-rw-r--r--dev-python/elastic-transport/Manifest2
-rw-r--r--dev-python/elastic-transport/elastic-transport-8.4.1.ebuild59
2 files changed, 61 insertions, 0 deletions
diff --git a/dev-python/elastic-transport/Manifest b/dev-python/elastic-transport/Manifest
index e67d5bb13b1a..1c0af41196da 100644
--- a/dev-python/elastic-transport/Manifest
+++ b/dev-python/elastic-transport/Manifest
@@ -1,3 +1,5 @@
DIST elastic-transport-8.4.0.gh.tar.gz 70975 BLAKE2B cec717606a55906da9157a0aaa3c656041201c2b62c77d42a67aabaad387c2e9f139dd1bd39e31b15f51fa2ac1b605d9f98b540000ee03d8aecf118cf972048a SHA512 82d0e0af3992335ce17bdc2a74f80fbf98bc9873d798be65f30d59fa55cb3bf50b55821133ea01d2ced9c27bf4019bac19e76e6853c29b87762ae0a9b593c3f5
+DIST elastic-transport-python-8.4.1.gh.tar.gz 71404 BLAKE2B 9d923362a6880685c6280aa9308089157c82ee570c2b608f2ed1398fec1e7946bad159a9bc74c1369a5042a30885948748014b0f5ee2362da83780b1a42d7f22 SHA512 50a3d60c00307659f51468e648a0c2cc7aa9be0b84df8fb2bbfea8c9f2d31fe568cbd9d4040c1aa174acc5d9902f45631a8a55e7950a7cf05fa26e0eef8bbd0e
EBUILD elastic-transport-8.4.0.ebuild 1763 BLAKE2B 8d58726109a7098f7a1f9ccc43a3fd4ac756d02371a6da9e952d311a0bd443b47b0ca3c9281bc0230461c9a7e014151d51f50ad63ab9e0b0200d539b7d75cc7e SHA512 b982365c1326222c1878394132eb3b33bf5a56e493b33161920e482d84ebb20270a663df32b2678aa0c645db91439ee1a78f05fd3cdd59e90dc9b9f2d55b3c6b
+EBUILD elastic-transport-8.4.1.ebuild 1506 BLAKE2B 76dd517d1a851f3e06d3acacb2e080864cc0f81f52f695c5bae209e1606757095c7bc9cb4172ef981dde55c0a89b352954a841ae1da760cc352ada7a2822d532 SHA512 1e05d08d0d8bea76972d3e9211108825d78d020fc98d121a0fd69a9a1ad910216c81eac0f26cabcdb495bbdc187e507b9df20bfdf2b7ca35082dd20441db7b99
MISC metadata.xml 569 BLAKE2B 82c4abea94dfb42f0da4cb2958207a35c7d5372e9810c031adcb53e49a0528f9b9fd48043d5d20cfd5a7e8046ea79bb9a6e48fe09948232fc641936bbee96738 SHA512 194ca8b79d33888cc404a5809a6ff43b2c2bef8b108cadce46393bd698b4d30124f6b6fd6732b2a905a2ec492169889f3042fd09d9577d28fa6a0921d88b56e2
diff --git a/dev-python/elastic-transport/elastic-transport-8.4.1.ebuild b/dev-python/elastic-transport/elastic-transport-8.4.1.ebuild
new file mode 100644
index 000000000000..4fc66262c545
--- /dev/null
+++ b/dev-python/elastic-transport/elastic-transport-8.4.1.ebuild
@@ -0,0 +1,59 @@
+# Copyright 2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=setuptools
+PYTHON_COMPAT=( python3_{10..11} )
+
+inherit distutils-r1
+
+MY_P=elastic-transport-python-${PV}
+DESCRIPTION="Transport classes and utilities shared among Python Elastic client libraries"
+HOMEPAGE="
+ https://github.com/elastic/elastic-transport-python/
+ https://pypi.org/project/elastic-transport/
+"
+SRC_URI="
+ https://github.com/elastic/elastic-transport-python/archive/v${PV}.tar.gz
+ -> ${MY_P}.gh.tar.gz
+"
+S=${WORKDIR}/${MY_P}
+
+LICENSE="Apache-2.0"
+SLOT="0"
+KEYWORDS="~amd64 ~arm64 ~x86"
+PROPERTIES="test_network"
+RESTRICT="test"
+
+RDEPEND="
+ dev-python/certifi[${PYTHON_USEDEP}]
+ >=dev-python/urllib3-1.26.2[${PYTHON_USEDEP}]
+"
+DEPEND="${RDEPEND}"
+BDEPEND="
+ test? (
+ dev-python/aiohttp[${PYTHON_USEDEP}]
+ dev-python/mock[${PYTHON_USEDEP}]
+ dev-python/pytest-asyncio[${PYTHON_USEDEP}]
+ dev-python/pytest-httpserver[${PYTHON_USEDEP}]
+ dev-python/pytest-mock[${PYTHON_USEDEP}]
+ dev-python/requests[${PYTHON_USEDEP}]
+ dev-python/trustme[${PYTHON_USEDEP}]
+ )
+"
+
+distutils_enable_sphinx docs/sphinx \
+ dev-python/furo \
+ dev-python/sphinx-autodoc-typehints
+distutils_enable_tests pytest
+
+python_test() {
+ local EPYTEST_DESELECT=(
+ # fragile to random warnings
+ tests/node/test_http_aiohttp.py::TestAiohttpHttpNode::test_uses_https_if_verify_certs_is_off
+ tests/node/test_urllib3_chain_certs.py::test_assert_fingerprint_in_cert_chain
+ )
+
+ epytest -o addopts=
+}