summaryrefslogtreecommitdiff
path: root/dev-python/egg-python/egg-python-2.25.3-r1.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2018-07-14 21:03:06 +0100
committerV3n3RiX <venerix@redcorelinux.org>2018-07-14 21:03:06 +0100
commit8376ef56580626e9c0f796d5b85b53a0a1c7d5f5 (patch)
tree7681bbd4e8b05407772df40a4bf04cbbc8afc3fa /dev-python/egg-python/egg-python-2.25.3-r1.ebuild
parent30a9caf154332f12ca60756e1b75d2f0e3e1822d (diff)
gentoo resync : 14.07.2018
Diffstat (limited to 'dev-python/egg-python/egg-python-2.25.3-r1.ebuild')
-rw-r--r--dev-python/egg-python/egg-python-2.25.3-r1.ebuild34
1 files changed, 34 insertions, 0 deletions
diff --git a/dev-python/egg-python/egg-python-2.25.3-r1.ebuild b/dev-python/egg-python/egg-python-2.25.3-r1.ebuild
new file mode 100644
index 000000000000..03a9cdf3f499
--- /dev/null
+++ b/dev-python/egg-python/egg-python-2.25.3-r1.ebuild
@@ -0,0 +1,34 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI="5"
+
+# We don't support the egg.recent bindings that are also provided - they are
+# deprecated, have deps we don't really want and there are no users in-tree.
+GNOME_ORG_MODULE="gnome-python-extras"
+G_PY_BINDINGS="eggtray"
+PYTHON_COMPAT=( python2_7 )
+
+inherit autotools eutils gnome-python-common-r1
+
+DESCRIPTION="EggTrayIcon bindings for Python"
+LICENSE="LGPL-2.1"
+SLOT="0"
+KEYWORDS="alpha amd64 ~arm ia64 ppc ppc64 sparc x86 ~x86-fbsd"
+IUSE="examples"
+
+RDEPEND=">=dev-python/libbonobo-python-2.22.1[${PYTHON_USEDEP}]
+ >=dev-python/libgnome-python-2.22.1[${PYTHON_USEDEP}]"
+DEPEND="${RDEPEND}
+ virtual/pkgconfig
+ gnome-base/gnome-common"
+# eautoreconf needs gnome-base/gnome-common
+
+EXAMPLES=( examples/egg/trayicon.py )
+
+src_prepare() {
+ epatch "${FILESDIR}/${P}-python-libs.patch" #344231
+ sed -i 's/AM_CONFIG_HEADER/AC_CONFIG_HEADERS/g' configure.ac || die
+ eautoreconf
+ gnome-python-common-r1_src_prepare
+}