summaryrefslogtreecommitdiff
path: root/dev-python/editorconfig-core-py
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2018-07-14 21:03:06 +0100
committerV3n3RiX <venerix@redcorelinux.org>2018-07-14 21:03:06 +0100
commit8376ef56580626e9c0f796d5b85b53a0a1c7d5f5 (patch)
tree7681bbd4e8b05407772df40a4bf04cbbc8afc3fa /dev-python/editorconfig-core-py
parent30a9caf154332f12ca60756e1b75d2f0e3e1822d (diff)
gentoo resync : 14.07.2018
Diffstat (limited to 'dev-python/editorconfig-core-py')
-rw-r--r--dev-python/editorconfig-core-py/Manifest5
-rw-r--r--dev-python/editorconfig-core-py/editorconfig-core-py-0.12.0.ebuild52
-rw-r--r--dev-python/editorconfig-core-py/files/editorconfig-core-py-0.12.0-no-cli.patch16
-rw-r--r--dev-python/editorconfig-core-py/metadata.xml19
4 files changed, 92 insertions, 0 deletions
diff --git a/dev-python/editorconfig-core-py/Manifest b/dev-python/editorconfig-core-py/Manifest
new file mode 100644
index 000000000000..38aa42f247a0
--- /dev/null
+++ b/dev-python/editorconfig-core-py/Manifest
@@ -0,0 +1,5 @@
+AUX editorconfig-core-py-0.12.0-no-cli.patch 503 BLAKE2B 98c71ac5fba08ee58d83dba92c37ce4a1d232d96b5f0648102da5b749f382af93b45a59b73d7a81c322937dfc94566f45b6203bea3b286ed49e81b69fa590667 SHA512 3c8802b4df1799c5456e30cf2f62d8c7d5b939a935bd511e2b1dc4ee681131ea7da114038e67efc1938b2c4c110c11dd4cbee0b77024d311e9b50585c364b591
+DIST editorconfig-core-py-0.12.0.tar.gz 24801 BLAKE2B 10901b1595965139dbc3aa3227f335c2128b2ea83204ed88b0e799021f7c215fd13c3e2246cb9197ecb7c918aca2d6e9269d94298aa0665432ab091630a29dd6 SHA512 29c5f58bd7293052e4b1fbfbadcf4a148eb939558494d599bafd46151a4fb5af9cd07dcef477db9a709a0ea63dec0dd7e9d4071779f8ca6e3bd137268cc22f72
+DIST editorconfig-core-test-abb579e00f2deeede91cb485e53512efab9c6474.tar.gz 7900 BLAKE2B 9ebdb5e522948bc9e86ea84435ccaa11585a8a12f4cd6fe54c64d78917281c913568351767d8077623b1196d84206d1c2d0126a0510f70df484c1b55d829028b SHA512 ae5424b4926d6cb127cb3da473400ced4f7ccf224f7baa8bc5bde0317cc045bb7b99738a56efe5fd0e5a0fbe39b997b9fb1739d24713e7f83b58e987c5e56a32
+EBUILD editorconfig-core-py-0.12.0.ebuild 1369 BLAKE2B 546d62f81580076ac5f4fef30cb90e05aabdf24c90ab5673d4063305fc0da07e93bcceef9dc6f798f5794d644b5cc7132d81b7cb36c51ffa49a25a43d954b28b SHA512 651ec6fa90f76add1965343b16270fc139ddcdc3062290fd0e3eefd2698580c1da87237df40a8f625b99e13c99436803373424db1e18ffa9571e47316782f3e0
+MISC metadata.xml 679 BLAKE2B e9d5e33c647f61258a1d8a691f98716030cf425e1b4279a6b05a0151dfc7ec4298ae2070f60316a983618eb9628b5e3c8e1149783cd7768547f8624cec504a87 SHA512 ebac6fb7f09e22832a5436aba0b445775800d377a794c0a5b32302f2d3baf0c6c09d70685bcd12f21e084b290915a43d729cd94b8e92246259446aa17548710b
diff --git a/dev-python/editorconfig-core-py/editorconfig-core-py-0.12.0.ebuild b/dev-python/editorconfig-core-py/editorconfig-core-py-0.12.0.ebuild
new file mode 100644
index 000000000000..5ab67d6e6f40
--- /dev/null
+++ b/dev-python/editorconfig-core-py/editorconfig-core-py-0.12.0.ebuild
@@ -0,0 +1,52 @@
+# Copyright 1999-2018 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+TESTVER="abb579e00f2deeede91cb485e53512efab9c6474"
+PYTHON_COMPAT=( python2_7 python3_4 python3_5 python3_6 )
+inherit distutils-r1
+
+DESCRIPTION="Clone of EditorConfig core written in Python"
+HOMEPAGE="https://editorconfig.org/"
+SRC_URI="https://github.com/${PN%-core-py}/${PN}/archive/v${PV}.tar.gz -> ${P}.tar.gz
+ test? (
+ https://github.com/${PN%-core-py}/${PN%-core-py}-core-test/archive/${TESTVER}.tar.gz -> ${PN%-core-py}-core-test-${TESTVER}.tar.gz
+ )"
+
+LICENSE="PYTHON BSD-4"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="test cli"
+
+RDEPEND="dev-python/setuptools[${PYTHON_USEDEP}]"
+DEPEND="${RDEPEND}
+ test? (
+ >dev-util/cmake-3.0
+ )
+ !<app-vim/editorconfig-vim-0.3.3-r1"
+
+src_prepare() {
+ if use test; then
+ mv "${WORKDIR}"/${PN%-core-py}-core-test-${TESTVER}/* "${S}"/tests || die
+ fi
+
+ use cli || eapply "${FILESDIR}"/${PN}-0.12.0-no-cli.patch
+
+ default
+ distutils-r1_src_prepare
+}
+
+python_install() {
+ distutils-r1_python_install
+ #use cli || rm -f "${D}/${EPREFIX}"/usr/bin
+}
+
+src_test() {
+ __src_test_run_python_impl() {
+ cmake -DPYTHON_EXECUTABLE="${PYTHON}" . || die "tests failed to build with ${EPYTHON}"
+ ctest . || die "tests failed with ${EPYTHON}"
+ }
+ python_foreach_impl __src_test_run_python_impl
+ unset __src_test_run_python_impl
+}
diff --git a/dev-python/editorconfig-core-py/files/editorconfig-core-py-0.12.0-no-cli.patch b/dev-python/editorconfig-core-py/files/editorconfig-core-py-0.12.0-no-cli.patch
new file mode 100644
index 000000000000..7d6fd31c3cc8
--- /dev/null
+++ b/dev-python/editorconfig-core-py/files/editorconfig-core-py-0.12.0-no-cli.patch
@@ -0,0 +1,16 @@
+diff --git a/setup.py b/setup.py
+index 297e9cf..9702911 100644
+--- a/setup.py
++++ b/setup.py
+@@ -10,11 +10,6 @@ setup(
+ license='LICENSE.txt',
+ description='EditorConfig File Locator and Interpreter for Python',
+ long_description=open('README.rst').read(),
+- entry_points = {
+- 'console_scripts': [
+- 'editorconfig = editorconfig.main:main',
+- ]
+- },
+ classifiers=[
+ 'Operating System :: OS Independent',
+ 'Programming Language :: Python',
diff --git a/dev-python/editorconfig-core-py/metadata.xml b/dev-python/editorconfig-core-py/metadata.xml
new file mode 100644
index 000000000000..53919fa69295
--- /dev/null
+++ b/dev-python/editorconfig-core-py/metadata.xml
@@ -0,0 +1,19 @@
+<?xml version='1.0' encoding='UTF-8'?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <maintainer type="person">
+ <email>chutzpah@gentoo.org</email>
+ <name>Patrick McLean</name>
+ </maintainer>
+ <use>
+ <flag name="cli">Install command line interface as well as python library</flag>
+ </use>
+ <longdescription lang="en">
+ EditorConfig Python Core provides the same functionality as the
+ EditorConfig C Core. EditorConfig Python core can be used as a
+ command line program or as an importable library.
+ </longdescription>
+ <upstream>
+ <remote-id type="github">editorconfig/editorconfig-core-test</remote-id>
+ </upstream>
+</pkgmetadata>