summaryrefslogtreecommitdiff
path: root/dev-python/editobj/editobj-0.5.7-r2.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2017-10-09 18:53:29 +0100
committerV3n3RiX <venerix@redcorelinux.org>2017-10-09 18:53:29 +0100
commit4f2d7949f03e1c198bc888f2d05f421d35c57e21 (patch)
treeba5f07bf3f9d22d82e54a462313f5d244036c768 /dev-python/editobj/editobj-0.5.7-r2.ebuild
reinit the tree, so we can have metadata
Diffstat (limited to 'dev-python/editobj/editobj-0.5.7-r2.ebuild')
-rw-r--r--dev-python/editobj/editobj-0.5.7-r2.ebuild29
1 files changed, 29 insertions, 0 deletions
diff --git a/dev-python/editobj/editobj-0.5.7-r2.ebuild b/dev-python/editobj/editobj-0.5.7-r2.ebuild
new file mode 100644
index 000000000000..631be827e83b
--- /dev/null
+++ b/dev-python/editobj/editobj-0.5.7-r2.ebuild
@@ -0,0 +1,29 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=5
+PYTHON_COMPAT=( python2_7 )
+PYTHON_REQ_USE="tk"
+
+inherit distutils-r1
+
+MY_P="${P/editobj/EditObj}"
+
+DESCRIPTION="EditObj can create a dialog box to edit ANY Python object"
+SRC_URI="http://download.gna.org/songwrite/${MY_P}.tar.gz"
+HOMEPAGE="http://home.gna.org/oomadness/en/editobj/index.html"
+
+LICENSE="GPL-2"
+KEYWORDS="amd64 ia64 ppc x86"
+SLOT="0"
+IUSE="+examples"
+
+DEPEND=""
+RDEPEND=""
+
+S="${WORKDIR}/${MY_P}"
+
+python_install_all() {
+ use examples && local EXAMPLES=( demo/. )
+ distutils-r1_python_install_all
+}