summaryrefslogtreecommitdiff
path: root/dev-python/editdistance-s
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2021-04-28 20:21:43 +0100
committerV3n3RiX <venerix@redcorelinux.org>2021-04-28 20:21:43 +0100
commit40aaaa64e86ba6710bbeb31c4615a6ce80e75e11 (patch)
tree758c221bad35c9288d0bd6df9c7dfc226728e52c /dev-python/editdistance-s
parent8d5dbd847cbc704a6a06405856e94b461011afe3 (diff)
gentoo resync : 28.04.2021
Diffstat (limited to 'dev-python/editdistance-s')
-rw-r--r--dev-python/editdistance-s/Manifest3
-rw-r--r--dev-python/editdistance-s/editdistance-s-1.0.0.ebuild21
-rw-r--r--dev-python/editdistance-s/metadata.xml20
3 files changed, 44 insertions, 0 deletions
diff --git a/dev-python/editdistance-s/Manifest b/dev-python/editdistance-s/Manifest
new file mode 100644
index 000000000000..8b61be401a2e
--- /dev/null
+++ b/dev-python/editdistance-s/Manifest
@@ -0,0 +1,3 @@
+DIST editdistance-s-1.0.0.tar.gz 5408 BLAKE2B 5420dff814de4d61f7c36c88113c568562a174205d8a4ff2b52b60e797f7459d95fd2a909b70911cfd7d0d67096a3844888bb88866980a2c43f8967a96ef4c55 SHA512 148234a38f54f70a2d6bc64f6a166a8954c79fb89d5f5c0bf3f041fe60056332901484a0626e218a72ae992f476305cbb662dfa0acdda794727fc682c569d718
+EBUILD editdistance-s-1.0.0.ebuild 521 BLAKE2B 6db01eaa94e8b9494554cfbd39e2347206a7b30623f518d737156f2a86f6689ba998aec1e0153980994ac32506086a67230d810ad0835abc27d297eda525c9e6 SHA512 5106cf5283e44524553a57bbe668017a6be066bf3728c39dd0a70adcf480f9cd78fd1cb2c1cc304f65b7566f6b23fa109635253340df3f25a3b1b50a41c189f5
+MISC metadata.xml 769 BLAKE2B 385d6e712da66dfd89e385bc712157b3861c0238d2fd807755d636feb4625782e76e1f5272c4efe758cf0de14fa5bd63d519ddd04ff9c4fb4528566c5620f419 SHA512 df3869e4c09d072ab860470f74958a25a446e0c71c7529f13e85b3f82f8c18245aa1dd7e4594e1add53675f3b87da9726260a367c6c9cee17ea758b0bfe99b99
diff --git a/dev-python/editdistance-s/editdistance-s-1.0.0.ebuild b/dev-python/editdistance-s/editdistance-s-1.0.0.ebuild
new file mode 100644
index 000000000000..bdbb49dbf8ef
--- /dev/null
+++ b/dev-python/editdistance-s/editdistance-s-1.0.0.ebuild
@@ -0,0 +1,21 @@
+# Copyright 1999-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+PYTHON_COMPAT=( python3_{8..9} )
+
+inherit distutils-r1
+
+DESCRIPTION="Fast implementation of edit (Levenshtein) distance"
+HOMEPAGE="https://github.com/asottile/editdistance-s"
+SRC_URI="https://github.com/asottile/${PN}/archive/refs/tags/v${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64"
+
+RDEPEND="virtual/python-cffi[${PYTHON_USEDEP}]"
+DEPEND="${RDEPEND}"
+
+distutils_enable_tests pytest
diff --git a/dev-python/editdistance-s/metadata.xml b/dev-python/editdistance-s/metadata.xml
new file mode 100644
index 000000000000..4bb618ca7155
--- /dev/null
+++ b/dev-python/editdistance-s/metadata.xml
@@ -0,0 +1,20 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <maintainer type="person">
+ <email>marecki@gentoo.org</email>
+ <name>Marek Szuba</name>
+ </maintainer>
+ <longdescription>
+ This is a fork of "editdistance" with the following changes:
+ * __hash__ based support is removed as it makes incorrect assumptions
+ * only strings (type str) are supported
+ * cffi replaces cython (so abi3 wheels can be produced)
+ * the module is renamed to editdistance_s
+ * the public api does not contain eval() (only distance())
+ </longdescription>
+ <upstream>
+ <remote-id type="github">asottile/editdistance-s</remote-id>
+ <remote-id type="pypi">editdistance-s</remote-id>
+ </upstream>
+</pkgmetadata>