summaryrefslogtreecommitdiff
path: root/dev-python/ebuildtester/ebuildtester-0.1.12.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2018-09-30 11:19:18 +0100
committerV3n3RiX <venerix@redcorelinux.org>2018-09-30 11:19:18 +0100
commit62f67115b5c46134c34f88f4b1cbdacc19384c0a (patch)
tree0a76b14de203a4c23040e5665e39df8de9867745 /dev-python/ebuildtester/ebuildtester-0.1.12.ebuild
parent265dbe5dbc14c199299496c6db8fce3f76647015 (diff)
gentoo resync : 30.09.2018
Diffstat (limited to 'dev-python/ebuildtester/ebuildtester-0.1.12.ebuild')
-rw-r--r--dev-python/ebuildtester/ebuildtester-0.1.12.ebuild31
1 files changed, 31 insertions, 0 deletions
diff --git a/dev-python/ebuildtester/ebuildtester-0.1.12.ebuild b/dev-python/ebuildtester/ebuildtester-0.1.12.ebuild
new file mode 100644
index 000000000000..3f9b13bcc09d
--- /dev/null
+++ b/dev-python/ebuildtester/ebuildtester-0.1.12.ebuild
@@ -0,0 +1,31 @@
+# Copyright 1999-2018 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+PYTHON_COMPAT=( python2_7 python3_{3,4,5,6} )
+
+inherit bash-completion-r1 distutils-r1
+
+DESCRIPTION="A dockerized approach to test a Gentoo package within a clean stage3 container"
+HOMEPAGE="http://ebuildtester.readthedocs.io/"
+SRC_URI="mirror://pypi/${P:0:1}/${PN}/${P}.tar.gz"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~amd64"
+IUSE="test"
+
+RDEPEND="
+ app-emulation/docker
+"
+
+DEPEND="
+ dev-python/setuptools[${PYTHON_USEDEP}]
+ dev-python/sphinx[${PYTHON_USEDEP}]
+"
+
+src_install() {
+ distutils-r1_src_install
+ newbashcomp "${FILESDIR}/${PN}.bash-completion" "${PN}"
+}