summaryrefslogtreecommitdiff
path: root/dev-python/e4u/e4u-0.1_rc5-r1.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2018-11-03 08:36:22 +0000
committerV3n3RiX <venerix@redcorelinux.org>2018-11-03 08:36:22 +0000
commitf65628136faa35d0c4d3b5e7332275c7b35fcd96 (patch)
tree021998302365c5652e37824b6c26d4d969a62055 /dev-python/e4u/e4u-0.1_rc5-r1.ebuild
parent70b82ae359a5538711e103b0e8dfb92654296644 (diff)
gentoo resync : 03.11.2018
Diffstat (limited to 'dev-python/e4u/e4u-0.1_rc5-r1.ebuild')
-rw-r--r--dev-python/e4u/e4u-0.1_rc5-r1.ebuild40
1 files changed, 40 insertions, 0 deletions
diff --git a/dev-python/e4u/e4u-0.1_rc5-r1.ebuild b/dev-python/e4u/e4u-0.1_rc5-r1.ebuild
new file mode 100644
index 000000000000..a2a6610f9ab7
--- /dev/null
+++ b/dev-python/e4u/e4u-0.1_rc5-r1.ebuild
@@ -0,0 +1,40 @@
+# Copyright 1999-2018 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI="7"
+
+PYTHON_COMPAT=( python2_7 )
+
+inherit distutils-r1
+
+MY_PV="${PV/_/}"
+
+DESCRIPTION="A library for handling unicode emoji and carrier's emoji"
+HOMEPAGE="https://github.com/lambdalisue/e4u"
+SRC_URI="https://github.com/lambdalisue/e4u/archive/${MY_PV}.tar.gz -> ${PN}-${MY_PV}.tar.gz"
+
+KEYWORDS="~amd64 ~x86"
+LICENSE="BSD"
+SLOT="0"
+
+RDEPEND="dev-python/beautifulsoup:python-2[${PYTHON_USEDEP}]"
+DEPEND="${RDEPEND}"
+BDEPEND="dev-python/setuptools[${PYTHON_USEDEP}]"
+
+S="${WORKDIR}/${PN}-${MY_PV}"
+
+PATCHES=(
+ "${FILESDIR}"/change-emoji4unicode-url.patch
+ "${FILESDIR}"/initialize-e4u-tests.patch
+)
+
+python_test() {
+ esetup.py test
+}
+
+python_install_all() {
+ insinto /usr/share/e4u
+ doins e4u/data/emoji4unicode.xml
+
+ distutils-r1_python_install_all
+}