summaryrefslogtreecommitdiff
path: root/dev-python/drpython
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2017-10-09 18:53:29 +0100
committerV3n3RiX <venerix@redcorelinux.org>2017-10-09 18:53:29 +0100
commit4f2d7949f03e1c198bc888f2d05f421d35c57e21 (patch)
treeba5f07bf3f9d22d82e54a462313f5d244036c768 /dev-python/drpython
reinit the tree, so we can have metadata
Diffstat (limited to 'dev-python/drpython')
-rw-r--r--dev-python/drpython/Manifest6
-rw-r--r--dev-python/drpython/drpython-3.11.4.ebuild46
-rw-r--r--dev-python/drpython/files/drpython-165-wxversion.patch12
-rw-r--r--dev-python/drpython/metadata.xml20
4 files changed, 84 insertions, 0 deletions
diff --git a/dev-python/drpython/Manifest b/dev-python/drpython/Manifest
new file mode 100644
index 000000000000..9a2ec6eb2bb4
--- /dev/null
+++ b/dev-python/drpython/Manifest
@@ -0,0 +1,6 @@
+AUX drpython-165-wxversion.patch 362 SHA256 d72248dad02415adbc54f355c59eef92ef1d4e208081ed327e35113a22dc3601 SHA512 f9b76986a46be5d3671646345b6d48e9dea902065a7ac3724008e5bc742b5962248d1d6806fdd8ab0aad8d6a377e70874b810872b670abd9d5ffda0c60405701 WHIRLPOOL 9e3ae8d6adfaf1cae56bb0051e64db99d8a908c6a7105613d8036ec7a2475f4a59916e752474bae375c6a4656e385edefda1fd5af06e8e62650748d731603460
+DIST DrPython_3.11.4.zip 824982 SHA256 37a2e4873fb6accd1145f89518db101458c2f43fbc3ea7cf3e2de446bf353f42 SHA512 13943eb28d7155e99e0ffb57903ddde25c964c908ac848f14041c456bc6aa71bab7cad1101e489c09ba5efb5af35e33895a518021bb607f5047844927bcebf2b WHIRLPOOL 56fd68e4abda8f39bbd86060eb397d4bd9360547e26cbca875f8256cadc19efd5de4bedb6d61f116cf63b3cd5167bf0dec9e21bddbbd0d75fdb6c246350ba483
+EBUILD drpython-3.11.4.ebuild 1128 SHA256 159673c3c3673b5e742827f91402d4b4fb8c3b08472f6a8313baee4602fcd103 SHA512 dc447cfaf48e7ee23edeac52fcec264b559a898c912530ca19ae26c57d9caf8ee79e3297320d2c09f350451109bb1107bafb94e3b4a2e059d7fa52ac1b48aee9 WHIRLPOOL 5d89cf9ff4f1711fb64a0a88bb27a55adf693002a74788e7e8a0c1d684978812ea9e1f2d4082d6b641067d83f5c95335dc6c3c1976c9b5515482a7f9014b06b1
+MISC ChangeLog 2585 SHA256 e588f53adc20dd249b1bff89b33328d1786e0df879e931c5705158b1b7cffa70 SHA512 7441b2f4b9e770f9a8f0080e50d2892b70f3f02f5c648adf346b2ef82cee8963cc7b7af0bc311c300f3070196e13e854d1eb8d87702da6e987475f6a05974366 WHIRLPOOL 01096fa5b4487fafe95089171bc98ed5886d5f53d2c856fac3a6874291e9fad6682316d174526d95a473cce8e7fd05a3ba7cf02d6f126d9dd41b82725d7fc106
+MISC ChangeLog-2015 4217 SHA256 07a9fef0d95c5428aeb99bb89076f816df47d058bd9f7fdb1734e3e616dbebf0 SHA512 03757eb5af108809583f467fbb1ba208c3024d0356ef51bb8d226e119dabc8caac9bbc5cf62c0b69e1f2f2feaeeb5733f6cd82b15dce79bc0da69b62f2764c0a WHIRLPOOL bd88afdf45c7ad51aa15b2512cfffc28cde2364cd9ea6615c3abe4104a3f8a73a8f1d97b3c8a44e57ad9aab272be66243410f8f95c97b95fb7ba98f140f6d6f6
+MISC metadata.xml 777 SHA256 ccfe92e19b6f898976ca05c00b3efa0be1ff3ea70a039a42d7dd6e43b6ee89d7 SHA512 baf982a19727f07a800dc71741af9ccfa5a3727d9695403bcc99eb8cde1a8ccbc5a704e68f82497eaae5558007985d33cba7f8d70b94700977db8fff99be6f00 WHIRLPOOL c0a519a334079e20078079d0d4463716a4fe57548e9b97c7360a64aac0024ee95b15e8d70f53d45b732d0d5e600ecd0f643bc5f204683df3bf15f30a9861e75a
diff --git a/dev-python/drpython/drpython-3.11.4.ebuild b/dev-python/drpython/drpython-3.11.4.ebuild
new file mode 100644
index 000000000000..f59c877bf5d8
--- /dev/null
+++ b/dev-python/drpython/drpython-3.11.4.ebuild
@@ -0,0 +1,46 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=5
+PYTHON_COMPAT=( python2_7 )
+
+inherit distutils-r1
+
+MY_PN="DrPython"
+MY_P="${MY_PN}_${PV}"
+
+DESCRIPTION="A powerful cross-platform IDE for Python"
+HOMEPAGE="http://drpython.sourceforge.net/"
+SRC_URI="mirror://sourceforge/${PN}/${MY_P}.zip"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="amd64 ia64 ppc x86"
+IUSE=""
+
+RDEPEND=">=dev-python/wxpython-2.6"
+DEPEND="${RDEPEND}
+ app-arch/unzip"
+
+S="${WORKDIR}/${PN}"
+
+PAYTCHES=( "${FILESDIR}/${PN}-165-wxversion.patch" )
+
+python_prepare_all() {
+ sed \
+ -e "/'drpython.pyw', 'drpython.lin'/d" \
+ -e "/scripts=\['postinst.py'\],/d" \
+ -i setup.py || die "sed failed"
+ sed -e "s/arguments)c/arguments)/" -i examples/DrScript/SetTerminalArgs.py || die "sed failed"
+ distutils-r1_python_prepare_all
+}
+
+python_install() {
+ make_wrapper drpython "${PYTHON}" $(python_get_sitedir)/${PN}/drpython.py
+ distutils-r1_python_install
+}
+
+pkg_postinst() {
+ elog "DrPython plugins are available on DrPython homepage:"
+ elog "https://sourceforge.net/projects/drpython/files/DrPython%20Plugins/"
+}
diff --git a/dev-python/drpython/files/drpython-165-wxversion.patch b/dev-python/drpython/files/drpython-165-wxversion.patch
new file mode 100644
index 000000000000..bab247c2110c
--- /dev/null
+++ b/dev-python/drpython/files/drpython-165-wxversion.patch
@@ -0,0 +1,12 @@
+diff -Naur drpython-orig/drpython_wx26.py drpython/drpython_wx26.py
+--- drpython_wx26.py 2007-03-23 19:20:02.000000000 -0600
++++ drpython_wx26.py 2007-12-03 18:36:01.000000000 -0600
+@@ -34,7 +34,7 @@
+
+ ## testfile for older version
+ import wxversion
+-wxversion.select("2.60-msw-ansi")
++wxversion.select("2.6")
+
+ if __name__ == '__main__':
+ import drpython
diff --git a/dev-python/drpython/metadata.xml b/dev-python/drpython/metadata.xml
new file mode 100644
index 000000000000..ac5d572905b7
--- /dev/null
+++ b/dev-python/drpython/metadata.xml
@@ -0,0 +1,20 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <maintainer type="project">
+ <email>python@gentoo.org</email>
+ <name>Python</name>
+ </maintainer>
+ <longdescription>
+DrPython is a highly customizable, simple, and clean
+editing environment for developing Python programs. It
+is intended primarily for use in schools, and is a tribute to
+DrScheme.
+</longdescription>
+ <longdescription lang="ja">
+DrPythonはPython言語プログラム用の、柔軟で、簡単で、安定した開発環境です。DrSchemeに触発され、学校での教材となる事が念頭にあります。
+</longdescription>
+ <upstream>
+ <remote-id type="sourceforge">drpython</remote-id>
+ </upstream>
+</pkgmetadata>