summaryrefslogtreecommitdiff
path: root/dev-python/drpython
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2018-07-14 20:57:42 +0100
committerV3n3RiX <venerix@redcorelinux.org>2018-07-14 20:57:42 +0100
commit1798c4aeca70ac8d0a243684d6a798fbc65735f8 (patch)
treee48e19cb6fa03de18e1c63e1a93371b7ebc4eb56 /dev-python/drpython
parentd87262dd706fec50cd150aab3e93883b6337466d (diff)
gentoo resync : 14.07.2018
Diffstat (limited to 'dev-python/drpython')
-rw-r--r--dev-python/drpython/Manifest4
-rw-r--r--dev-python/drpython/drpython-3.11.4.ebuild46
-rw-r--r--dev-python/drpython/files/drpython-165-wxversion.patch12
-rw-r--r--dev-python/drpython/metadata.xml20
4 files changed, 0 insertions, 82 deletions
diff --git a/dev-python/drpython/Manifest b/dev-python/drpython/Manifest
deleted file mode 100644
index 8300dbd4ea2b..000000000000
--- a/dev-python/drpython/Manifest
+++ /dev/null
@@ -1,4 +0,0 @@
-AUX drpython-165-wxversion.patch 362 BLAKE2B 7e965451cedf27ef0185baaec06ee0bea62c2fc578b3b552ecc43a25e38b58b7e4c9e787e725b0a9f84c3bc33a2c41c23ae46ef837b17265852558f03bcaa066 SHA512 f9b76986a46be5d3671646345b6d48e9dea902065a7ac3724008e5bc742b5962248d1d6806fdd8ab0aad8d6a377e70874b810872b670abd9d5ffda0c60405701
-DIST DrPython_3.11.4.zip 824982 BLAKE2B b160a8c65e8aa0f9a7b2b753fc325456f732d5ed5ea9743e6a5108f5a7c616a2c3af02032716565bb1ef08bc2e28d65492a29fa58a21183fe33f9e1a830d523f SHA512 13943eb28d7155e99e0ffb57903ddde25c964c908ac848f14041c456bc6aa71bab7cad1101e489c09ba5efb5af35e33895a518021bb607f5047844927bcebf2b
-EBUILD drpython-3.11.4.ebuild 1128 BLAKE2B d83d8d19de83ee801f7bb12ab4fa48fd5d4d9d9751561f8726c5bf21477cf04e18465f495665b5e820b777d45eebac1045359736e69443e92509d30514ea1dd4 SHA512 dc447cfaf48e7ee23edeac52fcec264b559a898c912530ca19ae26c57d9caf8ee79e3297320d2c09f350451109bb1107bafb94e3b4a2e059d7fa52ac1b48aee9
-MISC metadata.xml 777 BLAKE2B 77d3a5320dc535fae2c0a0e7411adb09ecd81a27ff89ae970bf083388616f155bed38fb7c18cca9ebd4e1bea3822c5d354add01b0e7c199f2457ca1070a544cd SHA512 baf982a19727f07a800dc71741af9ccfa5a3727d9695403bcc99eb8cde1a8ccbc5a704e68f82497eaae5558007985d33cba7f8d70b94700977db8fff99be6f00
diff --git a/dev-python/drpython/drpython-3.11.4.ebuild b/dev-python/drpython/drpython-3.11.4.ebuild
deleted file mode 100644
index f59c877bf5d8..000000000000
--- a/dev-python/drpython/drpython-3.11.4.ebuild
+++ /dev/null
@@ -1,46 +0,0 @@
-# Copyright 1999-2015 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=5
-PYTHON_COMPAT=( python2_7 )
-
-inherit distutils-r1
-
-MY_PN="DrPython"
-MY_P="${MY_PN}_${PV}"
-
-DESCRIPTION="A powerful cross-platform IDE for Python"
-HOMEPAGE="http://drpython.sourceforge.net/"
-SRC_URI="mirror://sourceforge/${PN}/${MY_P}.zip"
-
-LICENSE="GPL-2"
-SLOT="0"
-KEYWORDS="amd64 ia64 ppc x86"
-IUSE=""
-
-RDEPEND=">=dev-python/wxpython-2.6"
-DEPEND="${RDEPEND}
- app-arch/unzip"
-
-S="${WORKDIR}/${PN}"
-
-PAYTCHES=( "${FILESDIR}/${PN}-165-wxversion.patch" )
-
-python_prepare_all() {
- sed \
- -e "/'drpython.pyw', 'drpython.lin'/d" \
- -e "/scripts=\['postinst.py'\],/d" \
- -i setup.py || die "sed failed"
- sed -e "s/arguments)c/arguments)/" -i examples/DrScript/SetTerminalArgs.py || die "sed failed"
- distutils-r1_python_prepare_all
-}
-
-python_install() {
- make_wrapper drpython "${PYTHON}" $(python_get_sitedir)/${PN}/drpython.py
- distutils-r1_python_install
-}
-
-pkg_postinst() {
- elog "DrPython plugins are available on DrPython homepage:"
- elog "https://sourceforge.net/projects/drpython/files/DrPython%20Plugins/"
-}
diff --git a/dev-python/drpython/files/drpython-165-wxversion.patch b/dev-python/drpython/files/drpython-165-wxversion.patch
deleted file mode 100644
index bab247c2110c..000000000000
--- a/dev-python/drpython/files/drpython-165-wxversion.patch
+++ /dev/null
@@ -1,12 +0,0 @@
-diff -Naur drpython-orig/drpython_wx26.py drpython/drpython_wx26.py
---- drpython_wx26.py 2007-03-23 19:20:02.000000000 -0600
-+++ drpython_wx26.py 2007-12-03 18:36:01.000000000 -0600
-@@ -34,7 +34,7 @@
-
- ## testfile for older version
- import wxversion
--wxversion.select("2.60-msw-ansi")
-+wxversion.select("2.6")
-
- if __name__ == '__main__':
- import drpython
diff --git a/dev-python/drpython/metadata.xml b/dev-python/drpython/metadata.xml
deleted file mode 100644
index ac5d572905b7..000000000000
--- a/dev-python/drpython/metadata.xml
+++ /dev/null
@@ -1,20 +0,0 @@
-<?xml version="1.0" encoding="UTF-8"?>
-<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
-<pkgmetadata>
- <maintainer type="project">
- <email>python@gentoo.org</email>
- <name>Python</name>
- </maintainer>
- <longdescription>
-DrPython is a highly customizable, simple, and clean
-editing environment for developing Python programs. It
-is intended primarily for use in schools, and is a tribute to
-DrScheme.
-</longdescription>
- <longdescription lang="ja">
-DrPythonはPython言語プログラム用の、柔軟で、簡単で、安定した開発環境です。DrSchemeに触発され、学校での教材となる事が念頭にあります。
-</longdescription>
- <upstream>
- <remote-id type="sourceforge">drpython</remote-id>
- </upstream>
-</pkgmetadata>