summaryrefslogtreecommitdiff
path: root/dev-python/doublex
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2018-07-14 21:03:06 +0100
committerV3n3RiX <venerix@redcorelinux.org>2018-07-14 21:03:06 +0100
commit8376ef56580626e9c0f796d5b85b53a0a1c7d5f5 (patch)
tree7681bbd4e8b05407772df40a4bf04cbbc8afc3fa /dev-python/doublex
parent30a9caf154332f12ca60756e1b75d2f0e3e1822d (diff)
gentoo resync : 14.07.2018
Diffstat (limited to 'dev-python/doublex')
-rw-r--r--dev-python/doublex/Manifest3
-rw-r--r--dev-python/doublex/doublex-1.8.1.ebuild44
-rw-r--r--dev-python/doublex/metadata.xml8
3 files changed, 55 insertions, 0 deletions
diff --git a/dev-python/doublex/Manifest b/dev-python/doublex/Manifest
new file mode 100644
index 000000000000..35bd98337142
--- /dev/null
+++ b/dev-python/doublex/Manifest
@@ -0,0 +1,3 @@
+DIST doublex-1.8.1.tar.gz 69685 BLAKE2B 38f80ac0cf68dc2401eaa8051542c91d382e9ba22ed229b3c12a192f0b180b33a5660e54f647b2273401500a3292619d918dde9b0f685807217bca40e1aafbfc SHA512 30d2b572862370da8402cc2cfa5481d3278f0fefd2d5b2f5be126a793c8e165df0e2ae6089ba321e71d994f14024b882933c1523f7a0b9e341bf75644b49e073
+EBUILD doublex-1.8.1.ebuild 972 BLAKE2B ba30b38bf434e042a3303d5ef382c93de39a4c2ddb2662f37c01688a688632484c776046f549e4f1d5fb85d7d088af0c443287dab675624627dbcd5387b5bb78 SHA512 bb6d659956f8321b0f9957a2201d6f719de99590ef9f78faa8749e10318a3142bab8c0367acfa728376dd9bed5f58a712875d87cda81c1bce4d2e33ed26a5c11
+MISC metadata.xml 277 BLAKE2B 563ae4ae4ede406674ba1ba83be6202dfdd79a1aaa02ca96cecfd27ef8cdbb35406a27336b7fbb48eb0e216e1b101b83ea04e95f4e9243ce9a755994d41f9e16 SHA512 3cc2947b7aa4a62c02611bb9e7abf2ad9f8ce358e5d8b9aa75be0fdd2ece325e7566716302d53c8ea476c1e3af7397c7e153f7368771fc8cbf87c89959bf858a
diff --git a/dev-python/doublex/doublex-1.8.1.ebuild b/dev-python/doublex/doublex-1.8.1.ebuild
new file mode 100644
index 000000000000..eb25e92c0a75
--- /dev/null
+++ b/dev-python/doublex/doublex-1.8.1.ebuild
@@ -0,0 +1,44 @@
+# Copyright 1999-2018 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=5
+
+PYTHON_COMPAT=( python{2_7,3_4,3_5,3_6} )
+
+inherit distutils-r1 vcs-snapshot
+
+DESCRIPTION="Python test doubles"
+HOMEPAGE="https://bitbucket.org/DavidVilla/python-doublex"
+SRC_URI="https://bitbucket.org/DavidVilla/python-${PN}/get/v${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="GPL-3"
+SLOT="0"
+KEYWORDS="amd64"
+IUSE="doc test"
+
+CDEPEND="dev-python/pyhamcrest[${PYTHON_USEDEP}]"
+DEPEND="
+ ${CDEPEND}
+ doc? ( dev-python/sphinx[${PYTHON_USEDEP}] )
+ test? (
+ dev-python/nose[${PYTHON_USEDEP}]
+ $(python_gen_cond_dep 'dev-python/unittest2[${PYTHON_USEDEP}]' 'python2*')
+ )
+"
+RDEPEND="${CDEPEND}"
+
+python_compile_all() {
+ use doc && emake -C docs
+}
+
+python_test() {
+ esetup.py test
+}
+
+python_install_all() {
+ use doc && local HTML_DOCS=( docs/_build/html/. )
+
+ distutils-r1_python_install_all
+
+ rm "${ED}"/usr/README.rst || die "Couldn't remove spurious README.rst"
+}
diff --git a/dev-python/doublex/metadata.xml b/dev-python/doublex/metadata.xml
new file mode 100644
index 000000000000..5b9f3b2a2fbb
--- /dev/null
+++ b/dev-python/doublex/metadata.xml
@@ -0,0 +1,8 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <upstream>
+ <remote-id type="pypi">doublex</remote-id>
+ <remote-id type="bitbucket">DavidVilla/python-doublex</remote-id>
+ </upstream>
+</pkgmetadata>