summaryrefslogtreecommitdiff
path: root/dev-python/doublex/doublex-1.9.6.1.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2023-02-14 19:58:48 +0000
committerV3n3RiX <venerix@koprulu.sector>2023-02-14 19:58:48 +0000
commit330454de22a51b01089472bf131acd28ea0c64ec (patch)
tree2d01a6b9daea431327a6b40431be1a29c6fdf90a /dev-python/doublex/doublex-1.9.6.1.ebuild
parentf3b59a4d34d28f51cc97e3cd2eb23686d61c2002 (diff)
gentoo auto-resync : 14:02:2023 - 19:58:48
Diffstat (limited to 'dev-python/doublex/doublex-1.9.6.1.ebuild')
-rw-r--r--dev-python/doublex/doublex-1.9.6.1.ebuild42
1 files changed, 42 insertions, 0 deletions
diff --git a/dev-python/doublex/doublex-1.9.6.1.ebuild b/dev-python/doublex/doublex-1.9.6.1.ebuild
new file mode 100644
index 000000000000..b3294eb65659
--- /dev/null
+++ b/dev-python/doublex/doublex-1.9.6.1.ebuild
@@ -0,0 +1,42 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=setuptools
+PYTHON_COMPAT=( python3_{9..11} )
+
+inherit distutils-r1
+
+MY_P=python-doublex-${PV}
+DESCRIPTION="Python test doubles"
+HOMEPAGE="
+ https://github.com/davidvilla/python-doublex/
+ https://pypi.org/project/doublex/
+"
+SRC_URI="
+ https://github.com/davidvilla/python-doublex/archive/v${PV}.tar.gz
+ -> ${MY_P}.gh.tar.gz
+"
+S=${WORKDIR}/${MY_P}
+
+LICENSE="GPL-3"
+SLOT="0"
+KEYWORDS="~amd64 ~arm64"
+
+RDEPEND="
+ dev-python/pyhamcrest[${PYTHON_USEDEP}]
+ dev-python/six[${PYTHON_USEDEP}]
+"
+
+distutils_enable_sphinx docs --no-autodoc
+distutils_enable_tests pytest
+
+src_prepare() {
+ sed -i -e '/data_files/d' setup.py || die
+ distutils-r1_src_prepare
+}
+
+python_test() {
+ epytest -o 'python_files=*_tests.py'
+}