summaryrefslogtreecommitdiff
path: root/dev-python/doublex-expects/doublex-expects-0.7.1.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2020-09-16 09:32:48 +0100
committerV3n3RiX <venerix@redcorelinux.org>2020-09-16 09:32:48 +0100
commit9ee6d97c2883d42f204a533a8bc1f4562df778fb (patch)
treeb690ddc0ca30f1472887edbb0b8313629bfcbbb2 /dev-python/doublex-expects/doublex-expects-0.7.1.ebuild
parentb17a3ef12038de50228bade1f05502c74e135321 (diff)
gentoo resync : 16.09.2020
Diffstat (limited to 'dev-python/doublex-expects/doublex-expects-0.7.1.ebuild')
-rw-r--r--dev-python/doublex-expects/doublex-expects-0.7.1.ebuild35
1 files changed, 35 insertions, 0 deletions
diff --git a/dev-python/doublex-expects/doublex-expects-0.7.1.ebuild b/dev-python/doublex-expects/doublex-expects-0.7.1.ebuild
new file mode 100644
index 000000000000..6672dc2eac3d
--- /dev/null
+++ b/dev-python/doublex-expects/doublex-expects-0.7.1.ebuild
@@ -0,0 +1,35 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+PYTHON_COMPAT=( python3_{6,7,8,9} )
+
+inherit distutils-r1
+
+MY_PV=${PV/_/}
+
+DESCRIPTION="Expects matchers for Doublex test doubles assertions"
+HOMEPAGE="https://github.com/jaimegildesagredo/doublex-expects"
+SRC_URI="https://github.com/jaimegildesagredo/${PN}/archive/v${MY_PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="Apache-2.0"
+SLOT="0"
+KEYWORDS="~amd64 ~arm64"
+IUSE="test"
+RESTRICT="!test? ( test )"
+
+RDEPEND="
+ dev-python/doublex[${PYTHON_USEDEP}]
+ >=dev-python/expects-0.8.0_rc1[${PYTHON_USEDEP}]
+"
+BDEPEND="
+ test? (
+ ${RDEPEND}
+ dev-python/mamba[${PYTHON_USEDEP}]
+ )
+"
+
+python_test() {
+ mamba || die "Tests failed under ${EPYTHON}"
+}