summaryrefslogtreecommitdiff
path: root/dev-python/doit-py/doit-py-0.4.0.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2017-10-09 18:53:29 +0100
committerV3n3RiX <venerix@redcorelinux.org>2017-10-09 18:53:29 +0100
commit4f2d7949f03e1c198bc888f2d05f421d35c57e21 (patch)
treeba5f07bf3f9d22d82e54a462313f5d244036c768 /dev-python/doit-py/doit-py-0.4.0.ebuild
reinit the tree, so we can have metadata
Diffstat (limited to 'dev-python/doit-py/doit-py-0.4.0.ebuild')
-rw-r--r--dev-python/doit-py/doit-py-0.4.0.ebuild42
1 files changed, 42 insertions, 0 deletions
diff --git a/dev-python/doit-py/doit-py-0.4.0.ebuild b/dev-python/doit-py/doit-py-0.4.0.ebuild
new file mode 100644
index 000000000000..e9ce37e88770
--- /dev/null
+++ b/dev-python/doit-py/doit-py-0.4.0.ebuild
@@ -0,0 +1,42 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=5
+PYTHON_COMPAT=( python{2_7,3_4,3_5,3_6} pypy )
+
+inherit distutils-r1
+
+DESCRIPTION="doit tasks for python stuff"
+HOMEPAGE="http://pythonhosted.org/doit-py"
+SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="amd64 ~x86"
+IUSE="doc test"
+
+DEPEND="dev-python/setuptools[${PYTHON_USEDEP}]
+ test? (
+ dev-python/pyflakes[${PYTHON_USEDEP}]
+ dev-python/pytest[${PYTHON_USEDEP}]
+ dev-python/coverage[${PYTHON_USEDEP}]
+ virtual/python-singledispatch[${PYTHON_USEDEP}]
+ app-text/hunspell )
+ doc? ( dev-python/sphinx[${PYTHON_USEDEP}] )"
+RDEPEND="
+ virtual/python-pathlib[${PYTHON_USEDEP}]
+ dev-python/doit[${PYTHON_USEDEP}]
+ dev-python/configclass[${PYTHON_USEDEP}]"
+
+python_compile_all() {
+ use doc && emake -C doc html
+}
+
+python_test() {
+ py.test || die "Tests failed under ${EPYTHON}"
+}
+
+python_install_all() {
+ use doc && local HTML_DOCS=( doc/_build/html/. )
+ distutils-r1_python_install_all
+}