summaryrefslogtreecommitdiff
path: root/dev-python/docker-py
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2017-12-23 20:48:53 +0000
committerV3n3RiX <venerix@redcorelinux.org>2017-12-23 20:48:53 +0000
commit51536d2fe4697ba9114d611178bb9e20d3d5b729 (patch)
tree30b91d98e65985a575940ed49e756697c1f049c2 /dev-python/docker-py
parent4ab6db5717ef23f29320d4c6fb9ebdb8dec1f193 (diff)
gentoo resync : 23.12.2017
Diffstat (limited to 'dev-python/docker-py')
-rw-r--r--dev-python/docker-py/Manifest2
-rw-r--r--dev-python/docker-py/docker-py-2.7.0.ebuild55
2 files changed, 57 insertions, 0 deletions
diff --git a/dev-python/docker-py/Manifest b/dev-python/docker-py/Manifest
index e433872bf7f3..ac9d4a4493d2 100644
--- a/dev-python/docker-py/Manifest
+++ b/dev-python/docker-py/Manifest
@@ -1,5 +1,7 @@
DIST docker-py-2.4.2.tar.gz 180890 BLAKE2B 57518a0c8481fde0198100354225cd8a2908af6d3ca2690d98ad80b386ca4c688c7ccd6a34634ce04fb5ab1553b6c0dfbc75d28333a10f28de7188fe2ee7ffde SHA512 3367066b2acd96b85bef28aef00c91d752dc25b3055575b4f2f9c0b981eb4bca81a742bc6da5f97cf039cd9c7d818e3f80101997fe3a2e2c6f3a9c42fd3111c2
DIST docker-py-2.6.1.tar.gz 191919 BLAKE2B e8147d83594138d5456fd75efa776b8c69fbca9f9d3959e1e2318dbdb9ae638ecf483785bbfebf58308d237a7b5d6f1ac885489811094d11e0e7270c0555ec46 SHA512 ee5e646e6b45ed9fafd8bd32c4cdeff565988ff77b21303b0c1b4b1ea56a9d51d04c4f8c9595159efff09cfd8962c1a7060c1910d48cbfb4a2024e90b662ae58
+DIST docker-py-2.7.0.tar.gz 196369 BLAKE2B dd181dbf32f5afda06e748cb49f15d5fc6ff4a579c64b505308ad0d96913ddc8065d165090ec2b20e1f17a4519988a5665dd7a8c7643ca53aaa4385ceecb1341 SHA512 15cf1d8949d71e472f7636ff975cbc4c5f3e18e2d193cb603ade1397a56d0c1ec239167b71be325af99105bc36590a0f0faa1ab010f36fe8baca7807ddfa191b
EBUILD docker-py-2.4.2.ebuild 1585 BLAKE2B bc50c495e887bded0ad49dff9d3cf315eb463986811bf970dc5f1700f090c94507082596348fdd65a16e3bdbe411606f80841f504c82cfd8fbf36002afbaab7d SHA512 c9b91f286226af040062ec2be6d30e2960460b3fcf7d06ab0ce38d6364166477b638d29a3fdbf6f99ccd8085627c7fab318689d74b378c9b6acf45c9bf9071a7
EBUILD docker-py-2.6.1.ebuild 1587 BLAKE2B 3ff41bd27a663fcc91026f847c3210fd23be912bc4081fd35be6ec0707fe582b1673f32a169633c30e6bc09a140d6871faf77db5e7c65eceb92f8f2b64d49fab SHA512 ab178c7cbb9b5266da850c3ea3617bd42e745bbbeda7be70d116ca4c459263b7e38802f30f161eb0e701a5149ab5009dc8f968189f3c23b8b56f8d1e60141175
+EBUILD docker-py-2.7.0.ebuild 1539 BLAKE2B 3b21eaf5ea0aabce9827d91557f387f45607a483102b2a10b9694d3718cfe7eb5ba8d31698bded9463d2875bc7afe6f8065e97e66023af8dc3036489d1cff068 SHA512 bb20cdf4d7a9111b3f12e45888084c189a632a360c71fe36865d50e6f57b1901f6a86d46b19e978e101fad92495d36dadfb1037819a90fce680a61fe07723603
MISC metadata.xml 515 BLAKE2B 4283ac75c4a68d8704d1368b1f6c953beb6cd271cca4620944e6d254e00fddb130efc1b02a707a05b17d927da792a0544d9f9c834789b334beb516a7bba2e1ac SHA512 5bd90d9576f2e9995f6c69c931236ed41deaf9f817137c29c3a7c476d12a68350e8df5f36a4021a1d6f41c534cf737575f462fc09af90ad2cba47fdb4ff0bb8c
diff --git a/dev-python/docker-py/docker-py-2.7.0.ebuild b/dev-python/docker-py/docker-py-2.7.0.ebuild
new file mode 100644
index 000000000000..009498461e88
--- /dev/null
+++ b/dev-python/docker-py/docker-py-2.7.0.ebuild
@@ -0,0 +1,55 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+PYTHON_COMPAT=( python{2_7,3_4,3_5,3_6} )
+
+inherit distutils-r1
+
+DESCRIPTION="Python client for Docker"
+HOMEPAGE="https://github.com/docker/docker-py"
+SRC_URI="https://github.com/docker/${PN}/archive/${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="Apache-2.0"
+SLOT="0"
+KEYWORDS="~amd64 ~arm64 ~x86"
+IUSE="doc test"
+
+RDEPEND="
+ >=dev-python/docker-pycreds-0.2.1[${PYTHON_USEDEP}]
+ !~dev-python/requests-2.18.0[${PYTHON_USEDEP}]
+ >=dev-python/requests-2.14.2[${PYTHON_USEDEP}]
+ >=dev-python/six-1.4.0[${PYTHON_USEDEP}]
+ >=dev-python/websocket-client-0.32.0[${PYTHON_USEDEP}]
+ $(python_gen_cond_dep '>=dev-python/backports-ssl-match-hostname-3.5[${PYTHON_USEDEP}]' 'python2_7' 'python3_4' )
+ $(python_gen_cond_dep '>=dev-python/ipaddress-1.0.16[${PYTHON_USEDEP}]' 'python2_7' )
+"
+DEPEND="
+ dev-python/setuptools[${PYTHON_USEDEP}]
+ test? (
+ ${RDEPEND}
+ >=dev-python/mock-1.0.1[${PYTHON_USEDEP}]
+ dev-python/pytest-runner[${PYTHON_USEDEP}]
+ >=dev-python/pytest-2.9.1[${PYTHON_USEDEP}]
+ )
+ doc? (
+ dev-python/recommonmark[${PYTHON_USEDEP}]
+ >=dev-python/sphinx-1.4.6[${PYTHON_USEDEP}]
+ )
+"
+
+python_prepare_all() {
+ sed -i -e "s/import pip//" -e "s/if 'docker-py'.*/if False:/" setup.py || die
+ distutils-r1_python_prepare_all
+}
+
+python_compile_all() {
+ if use doc; then
+ sphinx-build docs html || die "docs failed to build"
+ HTML_DOCS=( html/. )
+ fi
+}
+
+python_test() {
+ py.test tests/unit/ || die "tests failed under ${EPYTHON}"
+}