summaryrefslogtreecommitdiff
path: root/dev-python/doc8/doc8-1.0.0.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2022-07-29 21:08:17 +0100
committerV3n3RiX <venerix@koprulu.sector>2022-07-29 21:08:17 +0100
commit496936ff0f7db69d1f7317341230acb866e3c330 (patch)
tree1541e919cd45c0ab5bdee8f1ac1344508da3b3af /dev-python/doc8/doc8-1.0.0.ebuild
parentc9ac6938788ee1708e7c900f8f78e9037aea1ca1 (diff)
gentoo auto-resync : 29:07:2022 - 21:08:17
Diffstat (limited to 'dev-python/doc8/doc8-1.0.0.ebuild')
-rw-r--r--dev-python/doc8/doc8-1.0.0.ebuild34
1 files changed, 34 insertions, 0 deletions
diff --git a/dev-python/doc8/doc8-1.0.0.ebuild b/dev-python/doc8/doc8-1.0.0.ebuild
new file mode 100644
index 000000000000..9e86c190ebaa
--- /dev/null
+++ b/dev-python/doc8/doc8-1.0.0.ebuild
@@ -0,0 +1,34 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=setuptools
+PYTHON_COMPAT=( python3_{8..10} )
+
+inherit distutils-r1
+
+DESCRIPTION="Style checker for Sphinx (or other) RST documentation"
+HOMEPAGE="
+ https://pypi.org/project/doc8/
+ https://github.com/pycqa/doc8/
+"
+SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+
+LICENSE="Apache-2.0"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~arm64 ~x86"
+
+RDEPEND="
+ dev-python/docutils[${PYTHON_USEDEP}]
+ dev-python/pygments[${PYTHON_USEDEP}]
+ >=dev-python/restructuredtext-lint-0.7[${PYTHON_USEDEP}]
+ dev-python/stevedore[${PYTHON_USEDEP}]
+ dev-python/tomli[${PYTHON_USEDEP}]
+"
+BDEPEND="
+ dev-python/setuptools_scm[${PYTHON_USEDEP}]
+ dev-python/setuptools_scm_git_archive[${PYTHON_USEDEP}]
+"
+
+distutils_enable_tests pytest