summaryrefslogtreecommitdiff
path: root/dev-python/dnspython
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2020-08-25 10:45:55 +0100
committerV3n3RiX <venerix@redcorelinux.org>2020-08-25 10:45:55 +0100
commit3cf7c3ef441822c889356fd1812ebf2944a59851 (patch)
treec513fe68548b40365c1c2ebfe35c58ad431cdd77 /dev-python/dnspython
parent05b8b0e0af1d72e51a3ee61522941bf7605cd01c (diff)
gentoo resync : 25.08.2020
Diffstat (limited to 'dev-python/dnspython')
-rw-r--r--dev-python/dnspython/Manifest4
-rw-r--r--dev-python/dnspython/dnspython-1.16.0-r1.ebuild4
-rw-r--r--dev-python/dnspython/dnspython-2.0.0.ebuild39
3 files changed, 44 insertions, 3 deletions
diff --git a/dev-python/dnspython/Manifest b/dev-python/dnspython/Manifest
index 0bebf646c353..c2663b5d5f2f 100644
--- a/dev-python/dnspython/Manifest
+++ b/dev-python/dnspython/Manifest
@@ -1,3 +1,5 @@
DIST dnspython-1.16.0.tar.gz 167172 BLAKE2B a246684aae8651d94b4312a4b4cce2236a0c4f2289a8fe8a2bb8e81c6beddf6e81a7d54928bc50f950fde862b27e589e83fa9f7aaff7d263a6442f47fe9bb3bb SHA512 825a1815855e036ea1dfece6ec0d42242f83163960439ecba3da58d9adb85b65dda7e628cf38c386807a6c0c36aa026d5e95f7a1bdc2927aa2f6f042f873c14c
-EBUILD dnspython-1.16.0-r1.ebuild 1220 BLAKE2B 46755a8947a5a498027479a747da4a044256c3a80aae4bb185b44f1c799b52756b4b0de24f98d4b48ad692914386ac90b3dfeea02486f04a2dfe3ae1ca159b12 SHA512 1e7c19fd6f5a2d0a4be0395bbb46c83f570d70e0ad932bd84e5b301f926ee22fab45f12494ae7f6f223b2b314b3515f4c98e07853596d863ce2bdae45e9ea943
+DIST dnspython-2.0.0.tar.gz 221903 BLAKE2B 540fb5fb12791dad6bae4007a77201092c8d5e64b7d82b23d5e3d16f48b49f73c90b85a6c8a83fa056a35cf7975ea2ad4a030f2b1fb1b87948bf1703adabb9d6 SHA512 3b38850fcacb0dd25ac0345201474f297c402617e8d706f3061c42172d697103075098e62ca0ac4e0e29967e00407f32f41789ac7bf070fba5aec0af9882e0fb
+EBUILD dnspython-1.16.0-r1.ebuild 1209 BLAKE2B 2ecc9ef86e9632288441bb4d99e0bcf81ffb4bd60a1ae4aac12dab886e9d59efcefe8d21b0cf1d0c16a0c75d71bc40a0ef78dfb77b2932cacd68ede7151666dd SHA512 cd23c352b897b8e3c39193a9893a5c99ec9987897087ebda8e011e37270a8c1d7cd02dabcd350c9d44080e3714bc8cb2a1ece13ae69f81f47f99b6ca2ccfa80f
+EBUILD dnspython-2.0.0.ebuild 987 BLAKE2B 85b587cffb12cf88c54a1583a4f29c2d6d5346968a8874c8f111ed17d38f93b91848d87b9501a47b78413b6f5bd799b29fba0e7212af764f0825a4a3b58b8cbb SHA512 f82b40f23543a702c7fc42d52ea33a05bcf958f3f4c9a48a567ed722f5cf96244ca735bda5cd866c365e28f1b7a35949d317c584982232e46f16dee5bf89624b
MISC metadata.xml 1482 BLAKE2B ff7895525a5fc62d104bf3039aa4154d0dbd5b097b5ae213c7e34713c968077b914b7a93ea881f43ea604e97b90f68b8f871a301f136de26ef4d98f0167be02c SHA512 63892286866fa85cc0a750157b3a2b98fdf4d3ef6edf61a879548c8e851cbeaa88cbfda52eaf98f1baf80e72a4ea2ffd2ceafe9794bf9a35ef3367ae5d3c2ded
diff --git a/dev-python/dnspython/dnspython-1.16.0-r1.ebuild b/dev-python/dnspython/dnspython-1.16.0-r1.ebuild
index f6749205a505..e0d43deafa96 100644
--- a/dev-python/dnspython/dnspython-1.16.0-r1.ebuild
+++ b/dev-python/dnspython/dnspython-1.16.0-r1.ebuild
@@ -3,7 +3,7 @@
EAPI=7
-PYTHON_COMPAT=( python2_7 python3_{6,7,8,9} pypy3 )
+PYTHON_COMPAT=( python3_{6,7,8,9} pypy3 )
inherit distutils-r1
@@ -13,7 +13,7 @@ SRC_URI="https://github.com/rthalley/dnspython/archive/v${PV}.tar.gz -> ${P}.tar
LICENSE="ISC"
SLOT="0"
-KEYWORDS="~alpha amd64 arm ~arm64 hppa ~ia64 ppc ppc64 ~s390 sparc x86 ~amd64-linux ~x86-linux ~ppc-macos ~x64-macos ~x86-solaris"
+KEYWORDS="~alpha amd64 arm arm64 hppa ~ia64 ppc ppc64 ~s390 sparc x86 ~amd64-linux ~x86-linux ~ppc-macos ~x64-macos ~x86-solaris"
IUSE="examples"
RDEPEND="dev-python/pycryptodome[${PYTHON_USEDEP}]
diff --git a/dev-python/dnspython/dnspython-2.0.0.ebuild b/dev-python/dnspython/dnspython-2.0.0.ebuild
new file mode 100644
index 000000000000..22c1262a3a08
--- /dev/null
+++ b/dev-python/dnspython/dnspython-2.0.0.ebuild
@@ -0,0 +1,39 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+PYTHON_COMPAT=( python3_{6,7,8,9} pypy3 )
+
+inherit distutils-r1
+
+DESCRIPTION="DNS toolkit for Python"
+HOMEPAGE="http://www.dnspython.org/ https://pypi.org/project/dnspython/"
+SRC_URI="https://github.com/rthalley/dnspython/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="ISC"
+SLOT="0"
+KEYWORDS="~alpha amd64 arm arm64 hppa ~ia64 ppc ppc64 ~s390 sparc x86 ~amd64-linux ~x86-linux ~ppc-macos ~x64-macos ~x86-solaris"
+IUSE="examples"
+
+RDEPEND="
+ dev-python/cryptography[${PYTHON_USEDEP}]
+ >=dev-python/idna-2.1[${PYTHON_USEDEP}]
+ !dev-python/dnspython:py2
+ !dev-python/dnspython:py3"
+
+distutils_enable_tests unittest
+
+src_prepare() {
+ sed -i -e '/network_avail/s:True:False:' \
+ tests/*.py || die
+ distutils-r1_src_prepare
+}
+
+python_install_all() {
+ distutils-r1_python_install_all
+ if use examples; then
+ dodoc -r examples
+ docompress -x /usr/share/doc/${PF}/examples
+ fi
+}