summaryrefslogtreecommitdiff
path: root/dev-python/dnspython
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2021-05-22 07:31:18 +0100
committerV3n3RiX <venerix@redcorelinux.org>2021-05-22 07:31:18 +0100
commit908778078736bd36f7a60a2d576d415cb8e000fa (patch)
treec6a4796c48b608c14dc7e9674cdbd38f905e3c15 /dev-python/dnspython
parent185fa19bbf68a4d4dca534d2b46729207a177f16 (diff)
gentoo resync : 22.05.2021
Diffstat (limited to 'dev-python/dnspython')
-rw-r--r--dev-python/dnspython/Manifest3
-rw-r--r--dev-python/dnspython/dnspython-1.16.0-r2.ebuild (renamed from dev-python/dnspython/dnspython-1.16.0-r1.ebuild)9
-rw-r--r--dev-python/dnspython/files/dnspython-1.16.0-py310.patch13
3 files changed, 22 insertions, 3 deletions
diff --git a/dev-python/dnspython/Manifest b/dev-python/dnspython/Manifest
index ded5b926d238..6acd62fd54ef 100644
--- a/dev-python/dnspython/Manifest
+++ b/dev-python/dnspython/Manifest
@@ -1,5 +1,6 @@
+AUX dnspython-1.16.0-py310.patch 408 BLAKE2B 7379d0ea280c9ca07e1d3d47dbb21cf1f1a0752f59ca3f30aaa26ef677d3a041f04b23ac0c244fdbca7661c5bbaf44cd30258410f92ab48330a236d92d78f668 SHA512 9e121f33ed148923a6aec919a8aac1f68e84a007f0ddc7daa550275681b1ecf5a47aca82bbbb7e27ced93752d4e76f4614bb10e379fec482e8f6bd730a5dc2b6
DIST dnspython-1.16.0.tar.gz 167172 BLAKE2B a246684aae8651d94b4312a4b4cce2236a0c4f2289a8fe8a2bb8e81c6beddf6e81a7d54928bc50f950fde862b27e589e83fa9f7aaff7d263a6442f47fe9bb3bb SHA512 825a1815855e036ea1dfece6ec0d42242f83163960439ecba3da58d9adb85b65dda7e628cf38c386807a6c0c36aa026d5e95f7a1bdc2927aa2f6f042f873c14c
DIST dnspython-2.1.0.tar.gz 279625 BLAKE2B ac90f1c9b50a00924326437e08513df04f3cf6dddee8b5ce58e628beab625d00c2dcdcc89e4b4da2c0366e650a5d8e87eb010942303215d3095e35f2010d4928 SHA512 eb3ab812eb8769b4780055b801e4f89beb1cb3d3e5a4855e583dca83b794eb7fca8fc3ef401eea7c16c34452e801dec5a2c59304f4041a68c7214dea6076435a
-EBUILD dnspython-1.16.0-r1.ebuild 1208 BLAKE2B 92504043644a59c6ee6d14b26734b9ad6e3b1f294891c4774f6964081338184ad0316b070a2b9d088a4034581eedb0e2f438556dc9db11d608817462e6bebe0c SHA512 2394781da6a08d92c3f0fc7ae0c4fe8388059ec497dfda522e56e3c36185f45c4300ede46ffaa849f6209883618957e6ee2c3ad126d4a9a7b3ddb57b5a872c25
+EBUILD dnspython-1.16.0-r2.ebuild 1341 BLAKE2B 96974c67109cf7b06cd9266886d12aafc4f2fd562d66de61b7e9eb7500dfea21cbea6d07ada8823eb71e3b916d82bccfe9264891c10153486f0aff48cf63434e SHA512 250253fd84576d2ee6b2d65166e6daec2322867d607336c663d56b474d6657a449718534b8e3916bb5367ddb3c3addbd7c0c2e510810091d43e0736894e4eece
EBUILD dnspython-2.1.0.ebuild 931 BLAKE2B 3e7d0ce8ae971b1825dea9a56dccbbad7206b7457915fbbb20ef0898f539d0405531874a448e223c1063e4ca4293c3f4fa1501d88638b2a1dbd301679df384ec SHA512 fd3ab54001e5b576849c1e12895793e94c1bef9b0bc6ac8a702b988ef8fb54e6945eea4d7eb7a9b96a6896a68ad2329416dd44c72a32f6e546bca3c0baf003f7
MISC metadata.xml 1482 BLAKE2B 52c201915b77d6d2f4379b74b67c8197dcfdc692aa9040a20a1ea4cfdedbb6e953d5764f8b3ef154cc1e899f644fd4e6fc3c8aa1ea5fd6f5d93c334d15f954bd SHA512 01bb39db4729b424742d567550ec05c3093158f12f3b5901029b2b4728220f703b0164d3e8f3469a0fdfd0b9492e85c4ca23a024a85bef37d738c439870ac1b3
diff --git a/dev-python/dnspython/dnspython-1.16.0-r1.ebuild b/dev-python/dnspython/dnspython-1.16.0-r2.ebuild
index 5296e0e643fb..82f4762eb6f5 100644
--- a/dev-python/dnspython/dnspython-1.16.0-r1.ebuild
+++ b/dev-python/dnspython/dnspython-1.16.0-r2.ebuild
@@ -1,9 +1,9 @@
-# Copyright 1999-2020 Gentoo Authors
+# Copyright 1999-2021 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI=7
-PYTHON_COMPAT=( python3_{7,8,9} pypy3 )
+PYTHON_COMPAT=( python3_{7..10} pypy3 )
inherit distutils-r1
@@ -23,6 +23,11 @@ RDEPEND="dev-python/pycryptodome[${PYTHON_USEDEP}]
!dev-python/dnspython:py2
!dev-python/dnspython:py3"
+PATCHES=(
+ # Mutable mapping was moved to a different module in 3.10 and removed from the old one
+ "${FILESDIR}"/${P}-py310.patch
+)
+
src_prepare() {
sed -i -e '/network_avail/s:True:False:' \
tests/test_resolver.py || die
diff --git a/dev-python/dnspython/files/dnspython-1.16.0-py310.patch b/dev-python/dnspython/files/dnspython-1.16.0-py310.patch
new file mode 100644
index 000000000000..ad6fa929e5e2
--- /dev/null
+++ b/dev-python/dnspython/files/dnspython-1.16.0-py310.patch
@@ -0,0 +1,13 @@
+diff --git a/dns/namedict.py b/dns/namedict.py
+index 37a1310..7d52668 100644
+--- a/dns/namedict.py
++++ b/dns/namedict.py
+@@ -32,7 +32,7 @@ import dns.name
+ from ._compat import xrange
+
+
+-class NameDict(collections.MutableMapping):
++class NameDict(collections.abc.MutableMapping):
+ """A dictionary whose keys are dns.name.Name objects.
+
+ In addition to being like a regular Python dictionary, this