summaryrefslogtreecommitdiff
path: root/dev-python/dnspython
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2023-07-16 10:42:35 +0100
committerV3n3RiX <venerix@koprulu.sector>2023-07-16 10:42:35 +0100
commit4c16e0a214824f15f09396e359db4f1f5c086fec (patch)
treebfacafd52495915db60285b30438af8bc216d18a /dev-python/dnspython
parent668b36c015ae61191cf7d5007b0afdbdcedab441 (diff)
gentoo auto-resync : 16:07:2023 - 10:42:35
Diffstat (limited to 'dev-python/dnspython')
-rw-r--r--dev-python/dnspython/Manifest2
-rw-r--r--dev-python/dnspython/dnspython-2.4.0.ebuild57
2 files changed, 59 insertions, 0 deletions
diff --git a/dev-python/dnspython/Manifest b/dev-python/dnspython/Manifest
index 79ef8b7c69ec..c6ea1789d811 100644
--- a/dev-python/dnspython/Manifest
+++ b/dev-python/dnspython/Manifest
@@ -1,3 +1,5 @@
DIST dnspython-2.3.0.gh.tar.gz 339222 BLAKE2B 1e1bfd1d716f5afce1ccc2e0f1fbb8e575e91619bc32f2c5067f6da4e01ea927dd0a1ed4c35e6c88d34de320befd833c9c17d060ea71918775c1f5f0121b61a8 SHA512 0bb4b41262a1d97b724e48b4dfb70f1fb544c18824e7d2bc2dcb8ef6c943c6c827ce753ae4ccb2ab37e95c8f5ff5d2f4853f238509f21e6299a445760c41e10e
+DIST dnspython-2.4.0.gh.tar.gz 356155 BLAKE2B d77ac611a45bb6f19903752af480e03d25655e0c814768c67b9a605c7a41a8c17efa976a4ff55fcc7de811113415addb094f8edefb5ebaa29b25d5a5865ea9ab SHA512 61becb66d049f9a503a4e60195183cd7b2f6dfb67d28aac85e39d26d30abd1eb97b52f368796438d90a4ff9acb441d1e487d5699484c77ec58e3914885d66aca
EBUILD dnspython-2.3.0.ebuild 1145 BLAKE2B b0434fbbba3c5d1d52b7cd561305e98ca0adf0709459573caf7a318174b9180ecebd046a1775cb511a41a8a45d90b5351d9cee7e0f53c48038e6c321909713e1 SHA512 636c8cfcc0c915a90f7c493ad4ebab60a9e8c1d2d8eb5a64abeeadd088fc805fff6ece216f9adacc5af7ac193c1b740cb0925d8d9e6cb0249d4661776e2f5593
+EBUILD dnspython-2.4.0.ebuild 1153 BLAKE2B a5eaa877b610b206bd67ca48b21cfa1c3e3a06dcb0df095e5e84b22bb3d6d921af5ccfd845f48522615b5c7589014cc5c13ae446660d7da48e58e5fda5920531 SHA512 e48212950e6ee168d6da043876699a421ec93467260dc427eeac95a0afe6e52a697d160bfce7886b6f544f0a85cdeb1fcd41e3653ab321ebddd5ce70d7d43651
MISC metadata.xml 1709 BLAKE2B abd502753325fedca3f1ca94818258c9d1b82f88766f9e005b35b3e79aff71ca2efaf06188e73ea30830f80ec011cdf5c42df320130c9295e13d3c427a148f8c SHA512 8c25d579a4a2a7c5ff34c21643a1386a434545f6b9b465f4aa8e07f7da3aee203bbc0341e930ddb767af431f64e8024ddd6cc8513cfce862c5900da4637bb1c8
diff --git a/dev-python/dnspython/dnspython-2.4.0.ebuild b/dev-python/dnspython/dnspython-2.4.0.ebuild
new file mode 100644
index 000000000000..00c4ada172dc
--- /dev/null
+++ b/dev-python/dnspython/dnspython-2.4.0.ebuild
@@ -0,0 +1,57 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=poetry
+PYTHON_COMPAT=( python3_{10..12} pypy3 )
+
+inherit distutils-r1
+
+DESCRIPTION="DNS toolkit for Python"
+HOMEPAGE="
+ https://www.dnspython.org/
+ https://github.com/rthalley/dnspython/
+ https://pypi.org/project/dnspython/
+"
+SRC_URI="
+ https://github.com/rthalley/dnspython/archive/v${PV}.tar.gz
+ -> ${P}.gh.tar.gz
+"
+
+LICENSE="ISC"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~loong ~m68k ~mips ~ppc ~ppc64 ~riscv ~s390 ~sparc ~x86 ~amd64-linux ~x86-linux ~ppc-macos ~x64-macos"
+IUSE="dnssec examples"
+
+RDEPEND="
+ dnssec? (
+ dev-python/cryptography[${PYTHON_USEDEP}]
+ )
+ <dev-python/idna-4.0[${PYTHON_USEDEP}]
+"
+BDEPEND="
+ test? (
+ dev-python/cryptography[${PYTHON_USEDEP}]
+ )
+"
+
+distutils_enable_tests pytest
+
+src_prepare() {
+ sed -i -e '/network_avail/s:True:False:' \
+ tests/*.py || die
+ distutils-r1_src_prepare
+}
+
+python_test() {
+ epytest -s
+}
+
+python_install_all() {
+ distutils-r1_python_install_all
+ if use examples; then
+ dodoc -r examples
+ docompress -x /usr/share/doc/${PF}/examples
+ fi
+}