summaryrefslogtreecommitdiff
path: root/dev-python/dnspython
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2022-07-09 15:43:36 +0100
committerV3n3RiX <venerix@koprulu.sector>2022-07-09 15:43:36 +0100
commit2719f73b6813d11d13a9650cdd2ab8ec6e69385d (patch)
tree8c816148bcbd22757d892089c989ae614eae4f5a /dev-python/dnspython
parent0f558761aa2dee1017b4751e4017205e015a9560 (diff)
gentoo resync : 09.07.2022
Diffstat (limited to 'dev-python/dnspython')
-rw-r--r--dev-python/dnspython/Manifest5
-rw-r--r--dev-python/dnspython/dnspython-2.2.1-r1.ebuild52
-rw-r--r--dev-python/dnspython/dnspython-2.2.1.ebuild2
-rw-r--r--dev-python/dnspython/metadata.xml6
4 files changed, 62 insertions, 3 deletions
diff --git a/dev-python/dnspython/Manifest b/dev-python/dnspython/Manifest
index a4b1397bf1ce..b5f8e989c99d 100644
--- a/dev-python/dnspython/Manifest
+++ b/dev-python/dnspython/Manifest
@@ -1,3 +1,4 @@
DIST dnspython-2.2.1.tar.gz 304861 BLAKE2B e6446b91579c6ec0a7266a354ceb58e2f881b55b7376648770ebc2c6104fd815214497516d305b75802e9211703d47a70d66745d872a43afb72f41e55a617652 SHA512 ec545468f604d6131f07259ca154c4f71d445d12c336ac1da0d2f025d6478ada76320a7235119312fed85da071ef309d2531e541d3c2340a50deaf3f4dd7b4eb
-EBUILD dnspython-2.2.1.ebuild 1058 BLAKE2B d588876aeaa59ace6b50965e56d3c5444eef87ab3865893423b57c79ff388ed83a2d6b2b5fadb211cc3f9b21acbfe50baf32c551fcf5982806d6a902d908cf6d SHA512 d7c991962b410c3fcd564c825add2c26acc75288c9595cbd94ccd78109376d844b37510c77211ab488f4b80275c242f7db0f936668dfa38c25482f66be903942
-MISC metadata.xml 1483 BLAKE2B c8506d4cb41157307b98f6976d05f6a504a89c3c0924e5135e060018bcd401589b4fbd932b1c61eb34d2823168170281fcee75f8fedda4053207b3844fae336d SHA512 e2b0132864d9a338193e9eed11e85981e48825c194fc35d8e17f9a72b19e04368140556c37a37061059451aaf1c6143030a54f43fb65ab734d2e9636e7e641d3
+EBUILD dnspython-2.2.1-r1.ebuild 1087 BLAKE2B 37587cd64782afa03a19bafed824d1eb2d0c84507b9775e230a45f8a31eb316dd306daa4f4e7604f16a4504ac24f193505602756116d9146f8d0d4d4c8d7c35a SHA512 59bae28dfa94433e39a3da5e4e78e4cad8038b1d5d55e32feb8a0390773306fbb0a1fc0d09e865a8fafcfaac1a439e08ba8d897516a964c897ba87e6138261e8
+EBUILD dnspython-2.2.1.ebuild 1027 BLAKE2B 54fc604c4ad03ce4161c32e1c11368783baa3a938cbdc66641e57a80b06858c1f2ed1885fa015e61d85ece3d956dd92d2d806780913f5f79e705afaa671acdcb SHA512 19845273d317b81f7c98bb719cde9df51335fe7f48c2ad25dbbbe1efb179fe7e22d19f339949e545a6f911d3b85d872477d19fb33816e1c75b05bf02e9a307da
+MISC metadata.xml 1651 BLAKE2B ea1ce5f9d27de56010f40b2187ac0b5876c27f41163e966689cb8958304c466011ebea0e5979c73b2ce14e6ed406833d01251982e43af945f868ab57dfdc848f SHA512 3d66dff8a832f935110f27e0f397457940de38a09e158bafa275872f96f1c6c5bb7fd1fd558610a8db64e2a7b9fb91cc6c744d3a7dc2eab3a19b85d526c2975a
diff --git a/dev-python/dnspython/dnspython-2.2.1-r1.ebuild b/dev-python/dnspython/dnspython-2.2.1-r1.ebuild
new file mode 100644
index 000000000000..e22214d8d8ad
--- /dev/null
+++ b/dev-python/dnspython/dnspython-2.2.1-r1.ebuild
@@ -0,0 +1,52 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=poetry
+PYTHON_COMPAT=( python3_{8..11} pypy3 )
+
+inherit distutils-r1
+
+DESCRIPTION="DNS toolkit for Python"
+HOMEPAGE="
+ https://www.dnspython.org/
+ https://github.com/rthalley/dnspython/
+ https://pypi.org/project/dnspython/
+"
+SRC_URI="
+ https://github.com/rthalley/dnspython/archive/v${PV}.tar.gz
+ -> ${P}.tar.gz
+"
+
+LICENSE="ISC"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 hppa ~ia64 ~loong ~mips ~ppc ~ppc64 ~riscv ~s390 ~sparc ~x86 ~amd64-linux ~x86-linux ~ppc-macos ~x64-macos ~x86-solaris"
+IUSE="dnssec examples"
+
+RDEPEND="
+ dnssec? (
+ dev-python/cryptography[${PYTHON_USEDEP}]
+ )
+ <dev-python/idna-4.0[${PYTHON_USEDEP}]
+"
+
+distutils_enable_tests pytest
+
+src_prepare() {
+ sed -i -e '/network_avail/s:True:False:' \
+ tests/*.py || die
+ distutils-r1_src_prepare
+}
+
+python_test() {
+ epytest -s
+}
+
+python_install_all() {
+ distutils-r1_python_install_all
+ if use examples; then
+ dodoc -r examples
+ docompress -x /usr/share/doc/${PF}/examples
+ fi
+}
diff --git a/dev-python/dnspython/dnspython-2.2.1.ebuild b/dev-python/dnspython/dnspython-2.2.1.ebuild
index beb937eab99a..716f4a5c82ff 100644
--- a/dev-python/dnspython/dnspython-2.2.1.ebuild
+++ b/dev-python/dnspython/dnspython-2.2.1.ebuild
@@ -21,7 +21,7 @@ SRC_URI="
LICENSE="ISC"
SLOT="0"
-KEYWORDS="~alpha amd64 arm arm64 hppa ~ia64 ~loong ~mips ppc ppc64 ~riscv ~s390 sparc x86 ~amd64-linux ~x86-linux ~ppc-macos ~x64-macos ~x86-solaris"
+KEYWORDS="amd64 arm arm64 ppc ppc64 ~riscv ~s390 sparc x86 ~amd64-linux ~x86-linux ~ppc-macos ~x64-macos ~x86-solaris"
IUSE="examples"
RDEPEND="
diff --git a/dev-python/dnspython/metadata.xml b/dev-python/dnspython/metadata.xml
index c04c973f51d2..6ca507da9d34 100644
--- a/dev-python/dnspython/metadata.xml
+++ b/dev-python/dnspython/metadata.xml
@@ -21,6 +21,12 @@ DNSPythonはPython言語用のDNSツールキットです。ほとんどのレ
い、その戻り値を使います。低水準はゾーン、メッセージ、ネーム、レコードを直接操作
します。
</longdescription>
+ <use>
+ <flag name="dnssec">
+ Use <pkg>dev-python/cryptography</pkg> to enable low-level
+ DNSSEC RSA, DSA, ECDSA and EdDSA signature validation.
+ </flag>
+ </use>
<stabilize-allarches/>
<upstream>
<remote-id type="pypi">dnspython</remote-id>