summaryrefslogtreecommitdiff
path: root/dev-python/dnspython/dnspython-1.12.0-r200.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2017-10-09 18:53:29 +0100
committerV3n3RiX <venerix@redcorelinux.org>2017-10-09 18:53:29 +0100
commit4f2d7949f03e1c198bc888f2d05f421d35c57e21 (patch)
treeba5f07bf3f9d22d82e54a462313f5d244036c768 /dev-python/dnspython/dnspython-1.12.0-r200.ebuild
reinit the tree, so we can have metadata
Diffstat (limited to 'dev-python/dnspython/dnspython-1.12.0-r200.ebuild')
-rw-r--r--dev-python/dnspython/dnspython-1.12.0-r200.ebuild36
1 files changed, 36 insertions, 0 deletions
diff --git a/dev-python/dnspython/dnspython-1.12.0-r200.ebuild b/dev-python/dnspython/dnspython-1.12.0-r200.ebuild
new file mode 100644
index 000000000000..2e61d8d91ba7
--- /dev/null
+++ b/dev-python/dnspython/dnspython-1.12.0-r200.ebuild
@@ -0,0 +1,36 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=5
+
+PYTHON_COMPAT=( python2_7 )
+
+inherit distutils-r1
+
+DESCRIPTION="DNS toolkit for Python"
+HOMEPAGE="http://www.dnspython.org/ https://pypi.python.org/pypi/dnspython"
+SRC_URI="http://www.dnspython.org/kits/${PV}/${P}.tar.gz"
+
+LICENSE="ISC"
+SLOT="py2"
+KEYWORDS="alpha amd64 arm ~arm64 hppa ia64 ppc ppc64 ~s390 ~sh sparc x86 ~x86-fbsd ~amd64-linux ~x86-linux ~ppc-macos ~x64-macos ~x86-solaris"
+IUSE="examples test"
+
+RDEPEND="dev-python/pycrypto[${PYTHON_USEDEP}]
+ !dev-python/dnspython:0"
+DEPEND="${RDEPEND}
+ app-arch/unzip"
+
+# For testsuite
+DISTUTILS_IN_SOURCE_BUILD=1
+
+python_test() {
+ cd tests || die
+ "${PYTHON}" utest.py || die "tests failed under ${EPYTHON}"
+ einfo "Testsuite passed under ${EPYTHON}"
+}
+
+python_install_all() {
+ use examples && local EXAMPLES=( examples/. )
+ distutils-r1_python_install_all
+}