summaryrefslogtreecommitdiff
path: root/dev-python/djangorestframework
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2021-03-27 06:06:27 +0000
committerV3n3RiX <venerix@redcorelinux.org>2021-03-27 06:06:27 +0000
commit8d5dbd847cbc704a6a06405856e94b461011afe3 (patch)
tree4d26462d027b14926335894749d2e01d982234d0 /dev-python/djangorestframework
parent5bb9ff1ee56d2b5e75e01a7f066d8b0cec84ec02 (diff)
gentoo resync : 27.03.2021
Diffstat (limited to 'dev-python/djangorestframework')
-rw-r--r--dev-python/djangorestframework/Manifest6
-rw-r--r--dev-python/djangorestframework/djangorestframework-3.12.2.ebuild28
-rw-r--r--dev-python/djangorestframework/metadata.xml4
3 files changed, 30 insertions, 8 deletions
diff --git a/dev-python/djangorestframework/Manifest b/dev-python/djangorestframework/Manifest
index 1c3a4c9b9e40..83062cdd13fe 100644
--- a/dev-python/djangorestframework/Manifest
+++ b/dev-python/djangorestframework/Manifest
@@ -1,3 +1,3 @@
-DIST djangorestframework-3.12.2.tar.gz 842597 BLAKE2B f450d55ade3d9d2d21bedba50c8dd6437bde383f6b30a2987a1a4fd224b6a72a03fdaf878ce72f02c2791fe2ebee02f3d9e0915d979e4f70e2f0cb9615d4a299 SHA512 d3a43212a4fb2caec27f815af0c52f3c0d2c9933febfea246429b24640b3cf23668640a4c3ddb3e3453e74a904a2b439443bb01cf24b664d19e896c353f2cba3
-EBUILD djangorestframework-3.12.2.ebuild 480 BLAKE2B c32fbf2c196aa6957fb2bc45c1b2fa979adddc29b31e67c786d960175920c4829fba201dd1757b86730f3b466daa6f42945e65b80c4d131b5c29e31f25dcbcf5 SHA512 7074d87445929e827b46944855fa193daf81dea47b741af4dd71046a5f876c3aef022db1c6aa61e32a5ab6cb4401b008f9aa7a772080346ea80db228da77db7b
-MISC metadata.xml 330 BLAKE2B afda95e14e1db06af5da809e3466dcc99e4fabd85ef3b4b1c0ea9afad2e5d742eef67a46e89a915900d5d98569f5772c8977c391cc476924be51d021d0c0023c SHA512 1833829abd241267c19a2c94f54c56baac0bcb7fe478f56faea6690d8990acd35750439229f056ffe4a3059e159a732750623b317524a141d00c3cc40a52a8a0
+DIST django-rest-framework-3.12.2.gh.tar.gz 8856613 BLAKE2B 77d0b3bad38c7829387de752d913eb758935615213d8f8ada9422ecf25142383c1b11a1c95d5fc9f4cf7634e494119ddcb236c810e85429fa8cd4ecd1ef88132 SHA512 7c3e712897562eff14ddfa4ded6627d6b4263001e0c9a4047b92da43c0fd86e8ac9d09bb54bb87ce0d4e7743553c4733a60b18327f7e4d481cb9898593731467
+EBUILD djangorestframework-3.12.2.ebuild 897 BLAKE2B 5363888f5bb74b56a863bde2b9406b5976db952037ce7df5ec75db96bd75d46841d52eb278201ea817847497fdf7e76de0ea82fecdd9040d7e9df6aa9af6e394 SHA512 f1987c8a4122fc653ab8bf9b95730f58657dde1502887bbd78f6cd8a02d3ccdcb14350ebd602c3d7f2cd320929fa64cdb166adcfd24601f3ee2cccddb9502c2f
+MISC metadata.xml 431 BLAKE2B 4e9fd677093de3074b75e24f0d768494886befde22707fa528f9549739010c51d483887496723a7ec2e3dfafe1260278e4b31d1815798f0315128223043887cd SHA512 7cfa16ab9c37969620ac236ed11fc6a347091ffc861c6ee740d9dbca3717f5092e5a2b2bca7cafba24c1b527581210bbc0d1f1ab602960f5f8b71787346a9a77
diff --git a/dev-python/djangorestframework/djangorestframework-3.12.2.ebuild b/dev-python/djangorestframework/djangorestframework-3.12.2.ebuild
index b280f1c308d8..8530587f35df 100644
--- a/dev-python/djangorestframework/djangorestframework-3.12.2.ebuild
+++ b/dev-python/djangorestframework/djangorestframework-3.12.2.ebuild
@@ -7,16 +7,34 @@ PYTHON_COMPAT=( python3_{7..9} )
inherit distutils-r1
+MY_P=django-rest-framework-${PV}
DESCRIPTION="Web APIs with django made easy"
-HOMEPAGE="https://www.django-rest-framework.org"
-SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+HOMEPAGE="https://www.django-rest-framework.org/"
+SRC_URI="
+ https://github.com/encode/django-rest-framework/archive/${PV}.tar.gz
+ -> ${MY_P}.gh.tar.gz"
+S=${WORKDIR}/${MY_P}
LICENSE="BSD"
SLOT="0"
KEYWORDS="~amd64"
-RESTRICT="test"
RDEPEND=">=dev-python/django-1.11[${PYTHON_USEDEP}]"
-DEPEND="${RDEPEND}"
+BDEPEND="
+ test? (
+ dev-python/coreapi[${PYTHON_USEDEP}]
+ dev-python/coreschema[${PYTHON_USEDEP}]
+ dev-python/pytest-django[${PYTHON_USEDEP}]
+ dev-python/pyyaml[${PYTHON_USEDEP}]
+ )"
-distutils_enable_tests setup.py
+distutils_enable_tests pytest
+
+python_test() {
+ local deselect=(
+ # TODO
+ tests/test_description.py::TestViewNamesAndDescriptions::test_markdown
+ )
+
+ epytest ${deselect[@]/#/--deselect }
+}
diff --git a/dev-python/djangorestframework/metadata.xml b/dev-python/djangorestframework/metadata.xml
index 6650f6a06ae6..d50c8767ecd4 100644
--- a/dev-python/djangorestframework/metadata.xml
+++ b/dev-python/djangorestframework/metadata.xml
@@ -5,6 +5,10 @@
<email>williamh@gentoo.org</email>
<name>William Hubbs</name>
</maintainer>
+ <maintainer type="project">
+ <email>python@gentoo.org</email>
+ <name>Python</name>
+ </maintainer>
<upstream>
<remote-id type="pypi">djangorestframework</remote-id>
</upstream>