summaryrefslogtreecommitdiff
path: root/dev-python/djangorestframework
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2021-07-08 15:03:58 +0100
committerV3n3RiX <venerix@redcorelinux.org>2021-07-08 15:03:58 +0100
commit814f4cf860e299a046b649eaee5463427984c09c (patch)
tree74c45f097899310e599dad6b8df5b63e0f085bc0 /dev-python/djangorestframework
parent7f0ccc917c7abe6223784c703d86cd14755691fb (diff)
gentoo resync : 08.07.2021
Diffstat (limited to 'dev-python/djangorestframework')
-rw-r--r--dev-python/djangorestframework/Manifest4
-rw-r--r--dev-python/djangorestframework/djangorestframework-3.12.2.ebuild40
-rw-r--r--dev-python/djangorestframework/djangorestframework-3.12.4.ebuild7
3 files changed, 5 insertions, 46 deletions
diff --git a/dev-python/djangorestframework/Manifest b/dev-python/djangorestframework/Manifest
index 6aafb1dc8011..84627d818c5c 100644
--- a/dev-python/djangorestframework/Manifest
+++ b/dev-python/djangorestframework/Manifest
@@ -1,5 +1,3 @@
-DIST django-rest-framework-3.12.2.gh.tar.gz 8856613 BLAKE2B 77d0b3bad38c7829387de752d913eb758935615213d8f8ada9422ecf25142383c1b11a1c95d5fc9f4cf7634e494119ddcb236c810e85429fa8cd4ecd1ef88132 SHA512 7c3e712897562eff14ddfa4ded6627d6b4263001e0c9a4047b92da43c0fd86e8ac9d09bb54bb87ce0d4e7743553c4733a60b18327f7e4d481cb9898593731467
DIST django-rest-framework-3.12.4.gh.tar.gz 8856507 BLAKE2B 48150e8d966ddd169a2b58d90656efa8f9f549c9d2fdee6025254fba2a6221704fe6bcb246567c8acb963f76ea56046935d3190c7c391daf4773b100a641ba02 SHA512 406b5354809b94e371a2c7d4b62ce66c18a1f60bd02574cba603ad4c44faa4297bdbbd6ee50de63fe21d2aae18386e05d46983a506bddd17f06ce610d5b727c9
-EBUILD djangorestframework-3.12.2.ebuild 897 BLAKE2B 5363888f5bb74b56a863bde2b9406b5976db952037ce7df5ec75db96bd75d46841d52eb278201ea817847497fdf7e76de0ea82fecdd9040d7e9df6aa9af6e394 SHA512 f1987c8a4122fc653ab8bf9b95730f58657dde1502887bbd78f6cd8a02d3ccdcb14350ebd602c3d7f2cd320929fa64cdb166adcfd24601f3ee2cccddb9502c2f
-EBUILD djangorestframework-3.12.4.ebuild 897 BLAKE2B 5363888f5bb74b56a863bde2b9406b5976db952037ce7df5ec75db96bd75d46841d52eb278201ea817847497fdf7e76de0ea82fecdd9040d7e9df6aa9af6e394 SHA512 f1987c8a4122fc653ab8bf9b95730f58657dde1502887bbd78f6cd8a02d3ccdcb14350ebd602c3d7f2cd320929fa64cdb166adcfd24601f3ee2cccddb9502c2f
+EBUILD djangorestframework-3.12.4.ebuild 1027 BLAKE2B e6debb796823873ef111093e755925a66361dc665eedfe7b5b77a08694cdca9f7d3f91e8fe2ec2df103360d1819b2728d63af0cf2daf22a1b3774bf9b103c8de SHA512 ea50d726eb11ad1e90022ab2fc4e931a99252d8ff0a6b2069595c4dbe590b3b12bc29d8d8a25947552d912b13e76ca4134dd8f4c6e9cb613b867b05c894c3740
MISC metadata.xml 322 BLAKE2B 59f5fa6d07d7a817847f2d0a5e4d6ab5af8b687fab67b3cf646a2345157d85356d663226013255d7d5d70dff6970ad456a34a74771d8e3bfa4096d8d3ca302fd SHA512 bccd84ffc3245536c3cb21f75e56cb6a02e1ae4f565b8dcc741b5cfea37b1712e3099d6c43b6bd2d4b23e0c2cac3694a170d227984a847068f963419327bddc8
diff --git a/dev-python/djangorestframework/djangorestframework-3.12.2.ebuild b/dev-python/djangorestframework/djangorestframework-3.12.2.ebuild
deleted file mode 100644
index 8530587f35df..000000000000
--- a/dev-python/djangorestframework/djangorestframework-3.12.2.ebuild
+++ /dev/null
@@ -1,40 +0,0 @@
-# Copyright 1999-2021 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=7
-
-PYTHON_COMPAT=( python3_{7..9} )
-
-inherit distutils-r1
-
-MY_P=django-rest-framework-${PV}
-DESCRIPTION="Web APIs with django made easy"
-HOMEPAGE="https://www.django-rest-framework.org/"
-SRC_URI="
- https://github.com/encode/django-rest-framework/archive/${PV}.tar.gz
- -> ${MY_P}.gh.tar.gz"
-S=${WORKDIR}/${MY_P}
-
-LICENSE="BSD"
-SLOT="0"
-KEYWORDS="~amd64"
-
-RDEPEND=">=dev-python/django-1.11[${PYTHON_USEDEP}]"
-BDEPEND="
- test? (
- dev-python/coreapi[${PYTHON_USEDEP}]
- dev-python/coreschema[${PYTHON_USEDEP}]
- dev-python/pytest-django[${PYTHON_USEDEP}]
- dev-python/pyyaml[${PYTHON_USEDEP}]
- )"
-
-distutils_enable_tests pytest
-
-python_test() {
- local deselect=(
- # TODO
- tests/test_description.py::TestViewNamesAndDescriptions::test_markdown
- )
-
- epytest ${deselect[@]/#/--deselect }
-}
diff --git a/dev-python/djangorestframework/djangorestframework-3.12.4.ebuild b/dev-python/djangorestframework/djangorestframework-3.12.4.ebuild
index 8530587f35df..8b6cfef95bea 100644
--- a/dev-python/djangorestframework/djangorestframework-3.12.4.ebuild
+++ b/dev-python/djangorestframework/djangorestframework-3.12.4.ebuild
@@ -1,10 +1,9 @@
# Copyright 1999-2021 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
-EAPI=7
-
-PYTHON_COMPAT=( python3_{7..9} )
+EAPI=8
+PYTHON_COMPAT=( python3_{8..10} )
inherit distutils-r1
MY_P=django-rest-framework-${PV}
@@ -34,6 +33,8 @@ python_test() {
local deselect=(
# TODO
tests/test_description.py::TestViewNamesAndDescriptions::test_markdown
+ # django version incompatibility?
+ tests/test_fields.py::TestNaiveDayLightSavingTimeTimeZoneDateTimeField::test_invalid_inputs
)
epytest ${deselect[@]/#/--deselect }