summaryrefslogtreecommitdiff
path: root/dev-python/django-registration/django-registration-3.4.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2023-10-13 00:16:09 +0100
committerV3n3RiX <venerix@koprulu.sector>2023-10-13 00:16:09 +0100
commit395f02db08a3f738bacbe8fbaa9fba11084f4e73 (patch)
treeb0ae09385e419830243aa68696919747e97fd1ba /dev-python/django-registration/django-registration-3.4.ebuild
parent36c436b12f9ef2523e5fd963381b78d2dc5cc53d (diff)
gentoo auto-resync : 13:10:2023 - 00:16:09
Diffstat (limited to 'dev-python/django-registration/django-registration-3.4.ebuild')
-rw-r--r--dev-python/django-registration/django-registration-3.4.ebuild32
1 files changed, 32 insertions, 0 deletions
diff --git a/dev-python/django-registration/django-registration-3.4.ebuild b/dev-python/django-registration/django-registration-3.4.ebuild
new file mode 100644
index 000000000000..36c13a4671a0
--- /dev/null
+++ b/dev-python/django-registration/django-registration-3.4.ebuild
@@ -0,0 +1,32 @@
+# Copyright 2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=setuptools
+PYTHON_COMPAT=( python3_{9..11} )
+inherit distutils-r1
+
+DESCRIPTION="user-registration application for Django"
+HOMEPAGE="
+ https://pypi.org/project/django-registration/
+ https://github.com/ubernostrum/django-registration/
+"
+SRC_URI="
+ https://github.com/ubernostrum/${PN}/archive/refs/tags/${PV}.tar.gz
+ -> ${P}.gh.tar.gz
+"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~amd64"
+
+RDEPEND="
+ dev-python/django[${PYTHON_USEDEP}]
+ dev-python/confusable_homoglyphs[${PYTHON_USEDEP}]
+"
+
+python_test() {
+ local -x DJANGO_SETTINGS_MODULE=tests.settings
+ PYTHONPATH=. "${EPYTHON}" runtests.py || die "Tests failed with ${EPYTHON}"
+}