summaryrefslogtreecommitdiff
path: root/dev-python/django-otp
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2022-11-11 15:30:13 +0000
committerV3n3RiX <venerix@koprulu.sector>2022-11-11 15:30:13 +0000
commit469b5d8f31adfd054c5c493fc3df2f9c89c9fa00 (patch)
treef51c77713647680335a341aeb6c5a7fa019a000b /dev-python/django-otp
parent7d6f532c36268a2a8f53fa33c8e547c59702faa6 (diff)
gentoo auto-resync : 11:11:2022 - 15:30:13
Diffstat (limited to 'dev-python/django-otp')
-rw-r--r--dev-python/django-otp/Manifest2
-rw-r--r--dev-python/django-otp/django-otp-1.1.4.ebuild44
2 files changed, 46 insertions, 0 deletions
diff --git a/dev-python/django-otp/Manifest b/dev-python/django-otp/Manifest
index 74c790ad99a5..d51830ef327b 100644
--- a/dev-python/django-otp/Manifest
+++ b/dev-python/django-otp/Manifest
@@ -1,3 +1,5 @@
DIST django-otp-1.1.3.gh.tar.gz 72736 BLAKE2B 1dc0570d65f0ac8de417260ce2fb895dbae7f5f2cd106b0dd969bc04df207cd4aa9ccf8be2bfc74475bb3ec6abcd451b7fa1c32fd0f7f0d3b27afca212f3b8ed SHA512 4e8b38c393fe29b2fa91e3f1f70abd2cc671dcf760e2e2bf8f738e04fc43a6e7f54229f298f7f2611988dffc40b4450ed1ab910ce9e9995b205dff1b3c90a977
+DIST django-otp-1.1.4.gh.tar.gz 75551 BLAKE2B 95f1e181542f595c5ce4059e037d47720899eac566af5d93414a64829bccbd054096bcbe1b5624e975483e45fccc88f62888c21fbb630e533be1eed9be1c0d84 SHA512 6bf6fbb6fe274bb8cd5de1ae31fad2bcb019332d3b10faffcffcd1f68a1160dffc2093eaadfd684c91372522e0132198df00da9e8cd0249124fd7020d63b91c3
EBUILD django-otp-1.1.3-r1.ebuild 927 BLAKE2B 4fc3ccfcc8b31eb1f6fa435895cda36e8aeeafa1d0de0442ea8832d81aed9d70bc8384243f4ffdf1e37254784be4d71ca85f29f8f2a55cab06067a516c7f7675 SHA512 f6d9aa031b4c11ce82d0403a59037f466850ce6011f22f3f0112da30752c4f857266889926e35ec8f3399e8751f9e4600c1ed351ae35a6adda812e75d799a949
+EBUILD django-otp-1.1.4.ebuild 968 BLAKE2B 3c1813c1955ece59b79c2f92601c6d0f448de63869c0bee35c5261ca4131f53bc1b195750087f354959cda870b025c93aef41c39e6ddebdf5b5eca3ffbfcc48d SHA512 8fa71d3acc00fa137e6852ba37d018f861a119041728595936d1169971fa8bce718813beb65cf645185196b0c16a032583b04ab261e3cad745686f8dd58621c2
MISC metadata.xml 387 BLAKE2B f1be13d8af9a4926d7c82442cb939f1030a8234d4f18917cf8b2b8b204d763974b5f08f8597334238733d6446fc1165ba19d454e13105dc16afacf1fa3a98ea0 SHA512 d85060b9982c55057128a0c7b7fd1537e3eb613f9d44e6c40438283d76f6d65c92db78815005ce44b4096d57c62584659d5997491f003ca1ed8c36f88db8623c
diff --git a/dev-python/django-otp/django-otp-1.1.4.ebuild b/dev-python/django-otp/django-otp-1.1.4.ebuild
new file mode 100644
index 000000000000..a53be9c88ec0
--- /dev/null
+++ b/dev-python/django-otp/django-otp-1.1.4.ebuild
@@ -0,0 +1,44 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=setuptools
+PYTHON_COMPAT=( python3_{8..11} )
+
+inherit distutils-r1
+
+DESCRIPTION="Django framework adding two-factor authentication using one-time passwords"
+HOMEPAGE="
+ https://github.com/django-otp/django-otp/
+ https://pypi.org/project/django-otp/
+"
+SRC_URI="
+ https://github.com/django-otp/django-otp/archive/v${PV}.tar.gz
+ -> ${P}.gh.tar.gz
+"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="test"
+RESTRICT="!test? ( test )"
+
+RDEPEND="
+ >=dev-python/django-2.2[${PYTHON_USEDEP}]
+"
+BDEPEND="
+ test? (
+ $(python_gen_impl_dep sqlite)
+ dev-python/freezegun[${PYTHON_USEDEP}]
+ dev-python/qrcode[${PYTHON_USEDEP}]
+ ${RDEPEND}
+ )
+"
+
+python_test() {
+ local -x PYTHONPATH=test:${PYTHONPATH}
+ local -x DJANGO_SETTINGS_MODULE=test_project.settings
+ "${EPYTHON}" -m django test -v 2 django_otp ||
+ die "Tests fail with ${EPYTHON}"
+}