summaryrefslogtreecommitdiff
path: root/dev-python/django-otp
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2023-09-18 11:05:42 +0100
committerV3n3RiX <venerix@koprulu.sector>2023-09-18 11:05:42 +0100
commit1426dfeb15e4d49cb4238c6cf37455a6130cd83f (patch)
tree9f9734bcdc280108e52d753b3c57234371772c3c /dev-python/django-otp
parent836586553c510ee2dd91e2ecd7676fe432c1f1a4 (diff)
gentoo auto-resync : 18:09:2023 - 11:05:42
Diffstat (limited to 'dev-python/django-otp')
-rw-r--r--dev-python/django-otp/Manifest2
-rw-r--r--dev-python/django-otp/django-otp-1.2.3.ebuild43
2 files changed, 45 insertions, 0 deletions
diff --git a/dev-python/django-otp/Manifest b/dev-python/django-otp/Manifest
index c4ba95adca44..fc1337a0591e 100644
--- a/dev-python/django-otp/Manifest
+++ b/dev-python/django-otp/Manifest
@@ -1,3 +1,5 @@
DIST django_otp-1.2.2.tar.gz 66391 BLAKE2B f66472ec2e3842ebc634edd8f689d1de51738381fd86c4af0859dee2f1bcf407b1c952c795203f9c742a95633ee14ce9253dcc1ffd7988c960e26b23a1ec5dfe SHA512 e8608f0a3b0aeaa82e509f034f69131eb1015124ecf84b734a5be58f62c309eee506b12fffe2aeb4b707e70c612413d1458bc64533102508c55255035432eb1f
+DIST django_otp-1.2.3.tar.gz 66417 BLAKE2B 30fa8efe11b061fc6332de18f4e86181c180123c7c46ae4f9102e59a587ec39f9922db7e8c7f1c3b7a19817a336969b4aa82e2dca64447736ec244ec0098f505 SHA512 fd881cc7b44350bcfa95d243dab08465b0251b5d45fde0766532b281fce676d0afbfb35b671c1a787579374049d43e44091af77bfbb7ac6da29713dcc3cfc98f
EBUILD django-otp-1.2.2.ebuild 955 BLAKE2B df0c1b4d78c0377b6062bb8a72ea0173d583dcdae11890ccbf776fb2ed38dd1795074d3b66b7a67601e508f7e8dd4ad90799402fc3ea4349ab7d4a20ba1bc6e3 SHA512 29a16deec317c7808f619ed7b4d9799dd008f806bf26d63f7232fcb6cad9347f58fe8b1217fac34795d3cd549b1964d688f86156742a381f4ec1cef039495d13
+EBUILD django-otp-1.2.3.ebuild 955 BLAKE2B df0c1b4d78c0377b6062bb8a72ea0173d583dcdae11890ccbf776fb2ed38dd1795074d3b66b7a67601e508f7e8dd4ad90799402fc3ea4349ab7d4a20ba1bc6e3 SHA512 29a16deec317c7808f619ed7b4d9799dd008f806bf26d63f7232fcb6cad9347f58fe8b1217fac34795d3cd549b1964d688f86156742a381f4ec1cef039495d13
MISC metadata.xml 387 BLAKE2B f1be13d8af9a4926d7c82442cb939f1030a8234d4f18917cf8b2b8b204d763974b5f08f8597334238733d6446fc1165ba19d454e13105dc16afacf1fa3a98ea0 SHA512 d85060b9982c55057128a0c7b7fd1537e3eb613f9d44e6c40438283d76f6d65c92db78815005ce44b4096d57c62584659d5997491f003ca1ed8c36f88db8623c
diff --git a/dev-python/django-otp/django-otp-1.2.3.ebuild b/dev-python/django-otp/django-otp-1.2.3.ebuild
new file mode 100644
index 000000000000..a7fd6fe4a416
--- /dev/null
+++ b/dev-python/django-otp/django-otp-1.2.3.ebuild
@@ -0,0 +1,43 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=hatchling
+PYTHON_COMPAT=( python3_{10..12} )
+
+inherit distutils-r1 pypi
+
+DESCRIPTION="Django framework adding two-factor authentication using one-time passwords"
+HOMEPAGE="
+ https://github.com/django-otp/django-otp/
+ https://pypi.org/project/django-otp/
+"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="test"
+RESTRICT="!test? ( test )"
+
+RDEPEND="
+ >=dev-python/django-3.2[${PYTHON_USEDEP}]
+"
+BDEPEND="
+ test? (
+ $(python_gen_impl_dep sqlite)
+ dev-python/freezegun[${PYTHON_USEDEP}]
+ dev-python/qrcode[${PYTHON_USEDEP}]
+ $(python_gen_cond_dep '
+ dev-python/tomli[${PYTHON_USEDEP}]
+ ' 3.9 3.10)
+ ${RDEPEND}
+ )
+"
+
+python_test() {
+ local -x PYTHONPATH=test:${PYTHONPATH}
+ local -x DJANGO_SETTINGS_MODULE=test_project.settings
+ "${EPYTHON}" -m django test -v 2 django_otp ||
+ die "Tests fail with ${EPYTHON}"
+}