summaryrefslogtreecommitdiff
path: root/dev-python/django-otp/django-otp-1.2.2.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2023-06-17 07:43:56 +0100
committerV3n3RiX <venerix@koprulu.sector>2023-06-17 07:43:56 +0100
commitb978efa000250668b2befa4e2cc96e0afa137611 (patch)
tree0c561efed9b15c17a9d3ef926443f35c58dfb48c /dev-python/django-otp/django-otp-1.2.2.ebuild
parentfa5e8e92d94ea9de5d49a1f5ad19abf7272503d0 (diff)
gentoo auto-resync : 17:06:2023 - 07:43:56
Diffstat (limited to 'dev-python/django-otp/django-otp-1.2.2.ebuild')
-rw-r--r--dev-python/django-otp/django-otp-1.2.2.ebuild43
1 files changed, 43 insertions, 0 deletions
diff --git a/dev-python/django-otp/django-otp-1.2.2.ebuild b/dev-python/django-otp/django-otp-1.2.2.ebuild
new file mode 100644
index 000000000000..fae3a5117ea5
--- /dev/null
+++ b/dev-python/django-otp/django-otp-1.2.2.ebuild
@@ -0,0 +1,43 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=hatchling
+PYTHON_COMPAT=( python3_{10..11} )
+
+inherit distutils-r1 pypi
+
+DESCRIPTION="Django framework adding two-factor authentication using one-time passwords"
+HOMEPAGE="
+ https://github.com/django-otp/django-otp/
+ https://pypi.org/project/django-otp/
+"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="test"
+RESTRICT="!test? ( test )"
+
+RDEPEND="
+ >=dev-python/django-3.2[${PYTHON_USEDEP}]
+"
+BDEPEND="
+ test? (
+ $(python_gen_impl_dep sqlite)
+ dev-python/freezegun[${PYTHON_USEDEP}]
+ dev-python/qrcode[${PYTHON_USEDEP}]
+ $(python_gen_cond_dep '
+ dev-python/tomli[${PYTHON_USEDEP}]
+ ' 3.9 3.10)
+ ${RDEPEND}
+ )
+"
+
+python_test() {
+ local -x PYTHONPATH=test:${PYTHONPATH}
+ local -x DJANGO_SETTINGS_MODULE=test_project.settings
+ "${EPYTHON}" -m django test -v 2 django_otp ||
+ die "Tests fail with ${EPYTHON}"
+}