summaryrefslogtreecommitdiff
path: root/dev-python/django-mptt
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2023-02-15 20:02:26 +0000
committerV3n3RiX <venerix@koprulu.sector>2023-02-15 20:02:26 +0000
commit0da5c40f264673f79a9d8c95d465d1cab718d282 (patch)
treecf498476cd0085b71f73a02d2570c770c9023337 /dev-python/django-mptt
parentdfa2037f41649c9775d690a3d01cfd5cabf4db71 (diff)
gentoo auto-resync : 15:02:2023 - 20:02:26
Diffstat (limited to 'dev-python/django-mptt')
-rw-r--r--dev-python/django-mptt/Manifest1
-rw-r--r--dev-python/django-mptt/django-mptt-0.13.4-r1.ebuild33
2 files changed, 34 insertions, 0 deletions
diff --git a/dev-python/django-mptt/Manifest b/dev-python/django-mptt/Manifest
index 32420823d922..e10789d4c5ec 100644
--- a/dev-python/django-mptt/Manifest
+++ b/dev-python/django-mptt/Manifest
@@ -1,3 +1,4 @@
DIST django-mptt-0.13.4.gh.tar.gz 303688 BLAKE2B 66ae7a0e15a7ff281af2154f216970a6a9b249a713b3ae987f0fbdb60b95129fdfc96c05924c0285da33f11c59baf6e069830c3079c64164d838d9d34231a4a9 SHA512 86786763db060227b41e2e340df5d52062fb6e8c54f832611bc90d01102411d45dc217e8d84eece84ebbe4fc9727d06e7c368ae15c253aaf02117705dbae8c47
+EBUILD django-mptt-0.13.4-r1.ebuild 735 BLAKE2B 566298683421c98aeff39c10079ae87e008ae30e623326f477b44b7e09a3dddf19f7a2d9a82aec6f949cba957622fdb53d66d4da1d591feef7a3320c0b55eed9 SHA512 f60f145ca74000c6c661069ee6e09be026bddc12a11c5e0b6b9e5bd2756ffeb44d0f6488f3107f6515b4cb0520d29d586eb668891d35d6f8bb8ed25d28f58069
EBUILD django-mptt-0.13.4.ebuild 658 BLAKE2B 8908ba3dc08c952e53e5edeb12f9d7202dddbbd6c685e288062ec47f1e475d545fdc2706d7871865398c95e469809bf469ee474cafc6501e42db58889a477c74 SHA512 3a8fb215f815a3243c177bfcd231fb5f7912434180093b84bffc086fd1acbecb1aae6e418d83d6d4d70dd9e0efd51412c2cd8d67c7901c7c178e9d548fed60b3
MISC metadata.xml 402 BLAKE2B 72c5dc1e76719489fd013527bdd115e06b501cd8553d4235581cbd3b76a6f4249dbfd83108eb48ee3e376690f42d952a7a5b0fc4707d9717c1f7ed05bb49d785 SHA512 455d5799930883238de0b64552fdbcaa233e9ceea31fb459e9eee382ef142ab7785bb6029287c8a2eb0ed288f60faa6bec7dc3015de6f52399c2c6e5e4b8cab7
diff --git a/dev-python/django-mptt/django-mptt-0.13.4-r1.ebuild b/dev-python/django-mptt/django-mptt-0.13.4-r1.ebuild
new file mode 100644
index 000000000000..c0dcf44e825b
--- /dev/null
+++ b/dev-python/django-mptt/django-mptt-0.13.4-r1.ebuild
@@ -0,0 +1,33 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=setuptools
+PYTHON_COMPAT=( python3_{9..11} )
+
+inherit distutils-r1
+
+DESCRIPTION="Utilities for modified preorder tree traversal and trees of Model instances"
+HOMEPAGE="
+ https://github.com/django-mptt/django-mptt/
+ https://pypi.org/project/django-mptt/
+"
+SRC_URI="
+ https://github.com/django-mptt/django-mptt/archive/${PV}.tar.gz
+ -> ${P}.gh.tar.gz
+"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64"
+
+RDEPEND="
+ >=dev-python/django-1.11[${PYTHON_USEDEP}]
+ dev-python/django-js-asset[${PYTHON_USEDEP}]
+"
+
+python_test() {
+ "${EPYTHON}" tests/manage.py test -v2 myapp ||
+ die "Tests failed with ${EPYTHON}"
+}