summaryrefslogtreecommitdiff
path: root/dev-python/django-haystack
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2020-09-23 10:22:15 +0100
committerV3n3RiX <venerix@redcorelinux.org>2020-09-23 10:22:15 +0100
commit8b4ace9c50842c5b83401ea7b179dcab940387e1 (patch)
tree230f3135ceaace633cf93e9838b185c4a6664c2e /dev-python/django-haystack
parent9ee6d97c2883d42f204a533a8bc1f4562df778fb (diff)
gentoo resync : 23.09.2020
Diffstat (limited to 'dev-python/django-haystack')
-rw-r--r--dev-python/django-haystack/Manifest3
-rw-r--r--dev-python/django-haystack/django-haystack-3.0.ebuild35
-rw-r--r--dev-python/django-haystack/metadata.xml10
3 files changed, 48 insertions, 0 deletions
diff --git a/dev-python/django-haystack/Manifest b/dev-python/django-haystack/Manifest
new file mode 100644
index 000000000000..7f281ecbab8c
--- /dev/null
+++ b/dev-python/django-haystack/Manifest
@@ -0,0 +1,3 @@
+DIST django-haystack-3.0.tar.gz 450713 BLAKE2B 0766711b127dfa1515583998058f588bea1619a792d6eef353da569a212b94c36683c0a743bdabee563c473f19f3197800bd585faf0b4eb39663b5ffbac6d6b8 SHA512 466ac18bbb6d6add1482d9debdffd195a2049c6c287cc4620e4db2ce4a702c97ca8ffb3ce048dc6c278dc50be701daab4f32b05a71c94ac67645890afb9f49bf
+EBUILD django-haystack-3.0.ebuild 745 BLAKE2B 1e317d4b0ae7acf8d1d97ecae92c2dfb039c9475ea2dbcd357cae08fab267d34153968ece7e0f5c643bb1bbf43051d4c8f51abe07713a4f52e5f7cc2b4ae36ae SHA512 f5179ec952306ef03793481488384d243a5695f3eb33145f3c992f7a0e1243596860a0247d96c3729d0d418351b203ee2c563da47d23bd06cf820daf08c65949
+MISC metadata.xml 302 BLAKE2B 024fc47acfffa8ae1e3203976ff78d02aeec308ea6695b49db0d0de507f350ff41e05243e4ae6a854dd1a9304ed111ab8d528bbcc1d24279e2f7d1a6afd6b45a SHA512 43db07b6707975a91542c1c24241e851f138bc3eb504db13102677c792abce21409fa8a374924cd5bdb255ca0e712542e87deb916c31647f48dd4d19e4e760f1
diff --git a/dev-python/django-haystack/django-haystack-3.0.ebuild b/dev-python/django-haystack/django-haystack-3.0.ebuild
new file mode 100644
index 000000000000..a6ed68f159e5
--- /dev/null
+++ b/dev-python/django-haystack/django-haystack-3.0.ebuild
@@ -0,0 +1,35 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+PYTHON_COMPAT=( python3_{6,7,8,9} )
+
+inherit distutils-r1
+
+DESCRIPTION="Pluggable search for Django"
+HOMEPAGE="https://haystacksearch.org/"
+SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~amd64"
+IUSE="doc"
+
+RDEPEND=">=dev-python/django-2.2[${PYTHON_USEDEP}]"
+DEPEND="${RDEPEND}
+ dev-python/setuptools[${PYTHON_USEDEP}]
+ doc? ( dev-python/sphinx[${PYTHON_USEDEP}] )
+ "
+
+# tests have too many dependencies to maintain
+RESTRICT="test"
+
+python_compile_all() {
+ use doc && emake -C docs html
+}
+
+python_install_all() {
+ use doc && HTML_DOCS=( docs/_build/html/. )
+ distutils-r1_python_install_all
+}
diff --git a/dev-python/django-haystack/metadata.xml b/dev-python/django-haystack/metadata.xml
new file mode 100644
index 000000000000..0bab279c909b
--- /dev/null
+++ b/dev-python/django-haystack/metadata.xml
@@ -0,0 +1,10 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <maintainer type="person">
+ <email>hanno@gentoo.org</email>
+ </maintainer>
+ <upstream>
+ <remote-id type="pypi">django-haystack</remote-id>
+ </upstream>
+</pkgmetadata>