summaryrefslogtreecommitdiff
path: root/dev-python/django-debug-toolbar
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2023-12-30 23:46:05 +0000
committerV3n3RiX <venerix@koprulu.sector>2023-12-30 23:46:05 +0000
commitbb262580ec0b56a32797f121e627928d103e6bb1 (patch)
treeb3b80cb753a087635c972352ce99fed1d01f286b /dev-python/django-debug-toolbar
parent35e3ee5faf74dc69409f957f81a6848d4d24c49f (diff)
gentoo auto-resync : 30:12:2023 - 23:46:05
Diffstat (limited to 'dev-python/django-debug-toolbar')
-rw-r--r--dev-python/django-debug-toolbar/Manifest5
-rw-r--r--dev-python/django-debug-toolbar/django-debug-toolbar-4.1.ebuild41
-rw-r--r--dev-python/django-debug-toolbar/django-debug-toolbar-4.2.0-r1.ebuild (renamed from dev-python/django-debug-toolbar/django-debug-toolbar-4.2.0.ebuild)4
-rw-r--r--dev-python/django-debug-toolbar/files/django-debug-toolbar-4.2.0-py312.patch20
4 files changed, 25 insertions, 45 deletions
diff --git a/dev-python/django-debug-toolbar/Manifest b/dev-python/django-debug-toolbar/Manifest
index 0e024626c092..3c83f8393434 100644
--- a/dev-python/django-debug-toolbar/Manifest
+++ b/dev-python/django-debug-toolbar/Manifest
@@ -1,5 +1,4 @@
-DIST django-debug-toolbar-4.1.gh.tar.gz 267550 BLAKE2B 80ebec1ee6f09d44089e119107a3696b8db82263976b4d191aaeea89658b0fbfb7ca1e2975aa73ad5c9240ac3010816710b5f7386165b1d7bdf335f8ef82b896 SHA512 8e9cc1ffcd8be7e345fff78e60cde8c4b44ef751dbf6a6bc061d452ccb60c68eda9f7e7a17efc32be3a62601921dff87f52ba2fe0e47a17fb820bf025cac0035
+AUX django-debug-toolbar-4.2.0-py312.patch 750 BLAKE2B 0cad44cbdc2e0ede481e8e6b3f1e08e91b0c4e50a3bf67ab16b03255bf40dfd4ba8b9d0a12db0f1cd4b0e3ece91f6c41e1b134f7e370c94262af0d307dcd91fe SHA512 0c0ee4a99f93fb2f49569bef791cd92e45aa8c0e975366694823c0889037435e692b8f464fcd5e99eb9985acc5cde71f7679cb4bb15358d20d9da43c7b937a89
DIST django_debug_toolbar-4.2.0.tar.gz 259709 BLAKE2B 81172bca569f6080710db2180650b0620670a4b4d2919d8b1694bf9f15425d9378f6cd0cbb852544fca0809388bb13867500a38c9046e1feaa241cde973936d9 SHA512 ff36d92132fd9338e88a2f078747c1e54e7633aecc6babea28ccb0c080b0beb99feccf1d1c00960ba109e3e6e4805562c36c6571842ea3baeda860c71ffcbd50
-EBUILD django-debug-toolbar-4.1.ebuild 844 BLAKE2B 853e3057efe00c7fb93c8cbd61ec011a0423f2ca21ecfef1a37bf8a21c2e372c0327e2b074d72240e876f53004dc469863d59eebfb7189c1ba145d3ce60c314c SHA512 8284de5fdc1b26bdd5996a5019bb2833dd32afed8b1d61edbe828b7f32e0df39c99117a8ba17dc96840d967f8f0c49d0587f0728cef55a30e2ea4838dc967d14
-EBUILD django-debug-toolbar-4.2.0.ebuild 713 BLAKE2B 27e9f06ddb91459cdc112e5c9cfd787c429788a359040672b109a3c8045b0adf86d51c0466dad00c4597964be6d7250cd2c14ec28683cfa50a9a9d154af01134 SHA512 5fca397f59d009b88d69da7eebd44542a06012ae4f6c2e1e0a1e4d07730ee5db97193543640874591ae499b7a403ac972a746df68b5ba00af118ef6c1cc5b725
+EBUILD django-debug-toolbar-4.2.0-r1.ebuild 757 BLAKE2B 691c7ebc7276ac956ef60293fe9e0a9d5889858da4ece4278e4b4d91e23c978aa2d0c319d591f7b74774201e93430220112355fee0baeb0e7a974174b55ab811 SHA512 b547e815a09e832442b163870ea758f1ff88fa81c118c81cddf794df36d0df29df844718198e7196d30656fc9a645a62061e53a368c7ed2603111e3ec3fa7152
MISC metadata.xml 400 BLAKE2B 5e173b9872626f2eb14b25d4b0271f339576fefc19a28f3ad8a8358bd0cd07ef6af0a268f7aa0f403ffb6ffd9527415bc173f7c5fb516bdb2e201883a8ec7390 SHA512 64e2fd8932cc6795a7d72aa37d8634f17556f1141c1bef1abddca2d56fa67f8500861b53a2698a96bf8adf66e7a991108b59fce55c710cd6cc3963ee3a35241e
diff --git a/dev-python/django-debug-toolbar/django-debug-toolbar-4.1.ebuild b/dev-python/django-debug-toolbar/django-debug-toolbar-4.1.ebuild
deleted file mode 100644
index 2fbcb24e5a3a..000000000000
--- a/dev-python/django-debug-toolbar/django-debug-toolbar-4.1.ebuild
+++ /dev/null
@@ -1,41 +0,0 @@
-# Copyright 2023 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=8
-
-DISTUTILS_USE_PEP517=hatchling
-PYTHON_COMPAT=( python3_{10..11} )
-
-inherit distutils-r1
-
-DESCRIPTION="A configurable set of panels that display various debug information"
-HOMEPAGE="
- https://github.com/jazzband/django-debug-toolbar/
- https://pypi.org/project/django-debug-toolbar/
-"
-# no tests in sdist, as of 4.0.0
-SRC_URI="
- https://github.com/jazzband/django-debug-toolbar/archive/${PV}.tar.gz
- -> ${P}.gh.tar.gz
-"
-IUSE="test"
-RESTRICT="!test? ( test )"
-
-LICENSE="BSD"
-SLOT="0"
-KEYWORDS="~amd64"
-
-RDEPEND="
- dev-python/django[${PYTHON_USEDEP}]
-"
-
-BDEPEND="
- test? (
- dev-python/html5lib[${PYTHON_USEDEP}]
- )
-"
-
-python_test() {
- "${EPYTHON}" -m django test -v 2 --settings tests.settings \
- || die "Tests failed with ${EPYTHON}"
-}
diff --git a/dev-python/django-debug-toolbar/django-debug-toolbar-4.2.0.ebuild b/dev-python/django-debug-toolbar/django-debug-toolbar-4.2.0-r1.ebuild
index 570f8b5e767c..31ff14e414eb 100644
--- a/dev-python/django-debug-toolbar/django-debug-toolbar-4.2.0.ebuild
+++ b/dev-python/django-debug-toolbar/django-debug-toolbar-4.2.0-r1.ebuild
@@ -4,7 +4,7 @@
EAPI=8
DISTUTILS_USE_PEP517=hatchling
-PYTHON_COMPAT=( python3_{10..11} )
+PYTHON_COMPAT=( python3_{10..12} )
inherit distutils-r1 pypi
@@ -30,6 +30,8 @@ BDEPEND="
)
"
+PATCHES=( "${FILESDIR}"/${P}-py312.patch )
+
python_test() {
"${EPYTHON}" -m django test -v 2 --settings tests.settings \
|| die "Tests failed with ${EPYTHON}"
diff --git a/dev-python/django-debug-toolbar/files/django-debug-toolbar-4.2.0-py312.patch b/dev-python/django-debug-toolbar/files/django-debug-toolbar-4.2.0-py312.patch
new file mode 100644
index 000000000000..69a5558da31b
--- /dev/null
+++ b/dev-python/django-debug-toolbar/files/django-debug-toolbar-4.2.0-py312.patch
@@ -0,0 +1,20 @@
+--- a/tests/panels/test_profiling.py 2023-12-30 20:02:22.263807899 +0100
++++ b/tests/panels/test_profiling.py 2023-12-30 20:03:44.655458186 +0100
+@@ -1,3 +1,6 @@
++import sys
++import unittest
++
+ from django.contrib.auth.models import User
+ from django.db import IntegrityError, transaction
+ from django.http import HttpResponse
+@@ -50,6 +53,10 @@
+ self.assertNotIn("render", content)
+ self.assertValidHTML(content)
+
++ @unittest.skipUnless(
++ sys.version_info < (3, 12, 0),
++ "Python 3.12 no longer contains a frame for list comprehensions.",
++ )
+ def test_listcomp_escaped(self):
+ self._get_response = lambda request: listcomp_view(request)
+ response = self.panel.process_request(self.request)