summaryrefslogtreecommitdiff
path: root/dev-python/django-debug-toolbar
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2021-12-22 14:08:05 +0000
committerV3n3RiX <venerix@koprulu.sector>2021-12-22 14:08:05 +0000
commit93a93e9a3b53c1a73142a305ea1f8136846942ee (patch)
treeb9791a06ab3284e27b568412c59316c66240c682 /dev-python/django-debug-toolbar
parent2771f79232c273bc2a57d23bf335dd81ccf6af28 (diff)
gentoo resync : 22.12.2021
Diffstat (limited to 'dev-python/django-debug-toolbar')
-rw-r--r--dev-python/django-debug-toolbar/Manifest4
-rw-r--r--dev-python/django-debug-toolbar/django-debug-toolbar-3.2.3.ebuild48
-rw-r--r--dev-python/django-debug-toolbar/django-debug-toolbar-3.2.4.ebuild48
3 files changed, 100 insertions, 0 deletions
diff --git a/dev-python/django-debug-toolbar/Manifest b/dev-python/django-debug-toolbar/Manifest
index 1553ecad9f5a..d7f3ab26a77e 100644
--- a/dev-python/django-debug-toolbar/Manifest
+++ b/dev-python/django-debug-toolbar/Manifest
@@ -1,3 +1,7 @@
DIST django-debug-toolbar-3.2.2.tar.gz 239313 BLAKE2B 0e53709a3857cefc0ff7a7176ca248891122b2d758264c32171198a22b0c105af414eaba0095b1435b4f071120038f4665bd84438d77a8f65156c056d523f60f SHA512 df1956d63e88d3cf9f831609b6191446a162afbf396cb6d20e5a42aab4276ab385943cc305cad58a9f388382b0dffabc8baedf2150182a4302e7da58ab3d6a5c
+DIST django-debug-toolbar-3.2.3.tar.gz 255447 BLAKE2B 82265a855588d1a809ace7fe36c93f0b5d779acc66aa922b39c61c5e860b25e983ccf230b166f1654a41ce7e5ca32eb5f9e998c8621b14af0e3cabed2c094a40 SHA512 877df07a757525ea8b36ccb59e20bd7c928425dbb8520b7de065f5a9be29681ee68417ee1f7cdd7dee269556f2fcf3a7e2635005fbe578dd7f1237f0a450ee29
+DIST django-debug-toolbar-3.2.4.tar.gz 255283 BLAKE2B 8be7f569c7f1eab06c4a60fca19bce6c348594406cdfe6de7e6be50849272714e9f3b51db4803e7cd58e97fe44a7422b07b05b2208f4447a4d69e0b77c856cb4 SHA512 19d3ba91b8738ade108f7eaded2859ad3e4bcae7cd0115e2cf63698d1fef01773f09a05f6bc0af53f9c3d4a2a288635a5cb2d215a2eb9f8acd6c65175a1ccaef
EBUILD django-debug-toolbar-3.2.2.ebuild 981 BLAKE2B 2f1284025104260aab12628d4c4439d5af244effd4ea4e8103535e99e5900ea90c23c0a369f98ae83e427259800568f4710f614ca43c93a2492460a44a49f7a4 SHA512 6866794d7e23eabd6222b8b262e0a562229a6ebe228aeb02da0fdcb8b3ca83dbda0f95eaae5658c4a8eaf54a0ede6f4d1f2c4f723272dcb1cc17875f39f513a0
+EBUILD django-debug-toolbar-3.2.3.ebuild 981 BLAKE2B 2f1284025104260aab12628d4c4439d5af244effd4ea4e8103535e99e5900ea90c23c0a369f98ae83e427259800568f4710f614ca43c93a2492460a44a49f7a4 SHA512 6866794d7e23eabd6222b8b262e0a562229a6ebe228aeb02da0fdcb8b3ca83dbda0f95eaae5658c4a8eaf54a0ede6f4d1f2c4f723272dcb1cc17875f39f513a0
+EBUILD django-debug-toolbar-3.2.4.ebuild 981 BLAKE2B 2f1284025104260aab12628d4c4439d5af244effd4ea4e8103535e99e5900ea90c23c0a369f98ae83e427259800568f4710f614ca43c93a2492460a44a49f7a4 SHA512 6866794d7e23eabd6222b8b262e0a562229a6ebe228aeb02da0fdcb8b3ca83dbda0f95eaae5658c4a8eaf54a0ede6f4d1f2c4f723272dcb1cc17875f39f513a0
MISC metadata.xml 393 BLAKE2B b903eca6ed23f64829c0f7ada77c2cff44aad9031b311dc4a4d085327ff7f894a27144dcb6f8ffc1a60c16a4915871717acb090d5829abc2c030044037c1bb92 SHA512 730834a56e939efd02dcad6edb69ca62f7e9497ef33e9410b007fee00c2f9a61f44221aef97c40b60ffe1e7d462c1cdf6805ae638a58318822f054ebe7befd6b
diff --git a/dev-python/django-debug-toolbar/django-debug-toolbar-3.2.3.ebuild b/dev-python/django-debug-toolbar/django-debug-toolbar-3.2.3.ebuild
new file mode 100644
index 000000000000..f64d97c58419
--- /dev/null
+++ b/dev-python/django-debug-toolbar/django-debug-toolbar-3.2.3.ebuild
@@ -0,0 +1,48 @@
+# Copyright 1999-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+PYTHON_COMPAT=( python3_{8..10} )
+inherit distutils-r1
+
+DESCRIPTION="A configurable set of panels that display debug information"
+HOMEPAGE="
+ https://pypi.org/project/django-debug-toolbar/
+ https://github.com/jazzband/django-debug-toolbar/"
+SRC_URI="
+ https://github.com/jazzband/django-debug-toolbar/archive/${PV}.tar.gz
+ -> ${P}.tar.gz"
+
+SLOT="0"
+LICENSE="BSD"
+KEYWORDS="~amd64 ~x86"
+IUSE="doc examples test"
+RESTRICT="!test? ( test )"
+
+RDEPEND="
+ >=dev-python/django-1.11[${PYTHON_USEDEP}]
+ >=dev-python/sqlparse-0.2.0[${PYTHON_USEDEP}]
+"
+DEPEND="
+ test? (
+ $(python_gen_impl_dep sqlite)
+ ${RDEPEND}
+ )
+"
+
+distutils_enable_sphinx docs
+
+python_test() {
+ emake TEST_ARGS='-v 2 tests' test
+}
+
+python_install_all() {
+ if use examples; then
+ docinto examples
+ dodoc -r example/.
+ docompress -x /usr/share/doc/${PF}/examples
+ fi
+
+ distutils-r1_python_install_all
+}
diff --git a/dev-python/django-debug-toolbar/django-debug-toolbar-3.2.4.ebuild b/dev-python/django-debug-toolbar/django-debug-toolbar-3.2.4.ebuild
new file mode 100644
index 000000000000..f64d97c58419
--- /dev/null
+++ b/dev-python/django-debug-toolbar/django-debug-toolbar-3.2.4.ebuild
@@ -0,0 +1,48 @@
+# Copyright 1999-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+PYTHON_COMPAT=( python3_{8..10} )
+inherit distutils-r1
+
+DESCRIPTION="A configurable set of panels that display debug information"
+HOMEPAGE="
+ https://pypi.org/project/django-debug-toolbar/
+ https://github.com/jazzband/django-debug-toolbar/"
+SRC_URI="
+ https://github.com/jazzband/django-debug-toolbar/archive/${PV}.tar.gz
+ -> ${P}.tar.gz"
+
+SLOT="0"
+LICENSE="BSD"
+KEYWORDS="~amd64 ~x86"
+IUSE="doc examples test"
+RESTRICT="!test? ( test )"
+
+RDEPEND="
+ >=dev-python/django-1.11[${PYTHON_USEDEP}]
+ >=dev-python/sqlparse-0.2.0[${PYTHON_USEDEP}]
+"
+DEPEND="
+ test? (
+ $(python_gen_impl_dep sqlite)
+ ${RDEPEND}
+ )
+"
+
+distutils_enable_sphinx docs
+
+python_test() {
+ emake TEST_ARGS='-v 2 tests' test
+}
+
+python_install_all() {
+ if use examples; then
+ docinto examples
+ dodoc -r example/.
+ docompress -x /usr/share/doc/${PF}/examples
+ fi
+
+ distutils-r1_python_install_all
+}