summaryrefslogtreecommitdiff
path: root/dev-python/django-debug-toolbar
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2023-08-11 09:34:39 +0100
committerV3n3RiX <venerix@koprulu.sector>2023-08-11 09:34:39 +0100
commit7e2b5bc2c2e2e045de6095d46c24ee857453adf2 (patch)
tree4387abc7e6be6debdd362738e7976e0d053163a1 /dev-python/django-debug-toolbar
parent9b97cf60d2411c33c1b2170b730b345ea9995002 (diff)
gentoo auto-resync : 11:08:2023 - 09:34:39
Diffstat (limited to 'dev-python/django-debug-toolbar')
-rw-r--r--dev-python/django-debug-toolbar/Manifest2
-rw-r--r--dev-python/django-debug-toolbar/django-debug-toolbar-4.2.0.ebuild36
2 files changed, 38 insertions, 0 deletions
diff --git a/dev-python/django-debug-toolbar/Manifest b/dev-python/django-debug-toolbar/Manifest
index bca149d4a001..0e024626c092 100644
--- a/dev-python/django-debug-toolbar/Manifest
+++ b/dev-python/django-debug-toolbar/Manifest
@@ -1,3 +1,5 @@
DIST django-debug-toolbar-4.1.gh.tar.gz 267550 BLAKE2B 80ebec1ee6f09d44089e119107a3696b8db82263976b4d191aaeea89658b0fbfb7ca1e2975aa73ad5c9240ac3010816710b5f7386165b1d7bdf335f8ef82b896 SHA512 8e9cc1ffcd8be7e345fff78e60cde8c4b44ef751dbf6a6bc061d452ccb60c68eda9f7e7a17efc32be3a62601921dff87f52ba2fe0e47a17fb820bf025cac0035
+DIST django_debug_toolbar-4.2.0.tar.gz 259709 BLAKE2B 81172bca569f6080710db2180650b0620670a4b4d2919d8b1694bf9f15425d9378f6cd0cbb852544fca0809388bb13867500a38c9046e1feaa241cde973936d9 SHA512 ff36d92132fd9338e88a2f078747c1e54e7633aecc6babea28ccb0c080b0beb99feccf1d1c00960ba109e3e6e4805562c36c6571842ea3baeda860c71ffcbd50
EBUILD django-debug-toolbar-4.1.ebuild 844 BLAKE2B 853e3057efe00c7fb93c8cbd61ec011a0423f2ca21ecfef1a37bf8a21c2e372c0327e2b074d72240e876f53004dc469863d59eebfb7189c1ba145d3ce60c314c SHA512 8284de5fdc1b26bdd5996a5019bb2833dd32afed8b1d61edbe828b7f32e0df39c99117a8ba17dc96840d967f8f0c49d0587f0728cef55a30e2ea4838dc967d14
+EBUILD django-debug-toolbar-4.2.0.ebuild 713 BLAKE2B 27e9f06ddb91459cdc112e5c9cfd787c429788a359040672b109a3c8045b0adf86d51c0466dad00c4597964be6d7250cd2c14ec28683cfa50a9a9d154af01134 SHA512 5fca397f59d009b88d69da7eebd44542a06012ae4f6c2e1e0a1e4d07730ee5db97193543640874591ae499b7a403ac972a746df68b5ba00af118ef6c1cc5b725
MISC metadata.xml 400 BLAKE2B 5e173b9872626f2eb14b25d4b0271f339576fefc19a28f3ad8a8358bd0cd07ef6af0a268f7aa0f403ffb6ffd9527415bc173f7c5fb516bdb2e201883a8ec7390 SHA512 64e2fd8932cc6795a7d72aa37d8634f17556f1141c1bef1abddca2d56fa67f8500861b53a2698a96bf8adf66e7a991108b59fce55c710cd6cc3963ee3a35241e
diff --git a/dev-python/django-debug-toolbar/django-debug-toolbar-4.2.0.ebuild b/dev-python/django-debug-toolbar/django-debug-toolbar-4.2.0.ebuild
new file mode 100644
index 000000000000..570f8b5e767c
--- /dev/null
+++ b/dev-python/django-debug-toolbar/django-debug-toolbar-4.2.0.ebuild
@@ -0,0 +1,36 @@
+# Copyright 2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=hatchling
+PYTHON_COMPAT=( python3_{10..11} )
+
+inherit distutils-r1 pypi
+
+DESCRIPTION="A configurable set of panels that display various debug information"
+HOMEPAGE="
+ https://github.com/jazzband/django-debug-toolbar/
+ https://pypi.org/project/django-debug-toolbar/
+"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~amd64"
+IUSE="test"
+RESTRICT="!test? ( test )"
+
+RDEPEND="
+ dev-python/django[${PYTHON_USEDEP}]
+"
+
+BDEPEND="
+ test? (
+ dev-python/html5lib[${PYTHON_USEDEP}]
+ )
+"
+
+python_test() {
+ "${EPYTHON}" -m django test -v 2 --settings tests.settings \
+ || die "Tests failed with ${EPYTHON}"
+}