summaryrefslogtreecommitdiff
path: root/dev-python/django-debug-toolbar
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2024-05-29 00:07:15 +0100
committerV3n3RiX <venerix@koprulu.sector>2024-05-29 00:07:15 +0100
commit5c4786a868bad6e3f46aecf32ad6c6dc5de98408 (patch)
tree1a1792815761a5b6f645c8d55b6b698e102dca48 /dev-python/django-debug-toolbar
parent3c1648a0749c1d66b300d857e6b417c1162890da (diff)
gentoo auto-resync : 29:05:2024 - 00:07:15
Diffstat (limited to 'dev-python/django-debug-toolbar')
-rw-r--r--dev-python/django-debug-toolbar/Manifest4
-rw-r--r--dev-python/django-debug-toolbar/django-debug-toolbar-4.4.1.ebuild36
-rw-r--r--dev-python/django-debug-toolbar/django-debug-toolbar-4.4.2.ebuild36
3 files changed, 76 insertions, 0 deletions
diff --git a/dev-python/django-debug-toolbar/Manifest b/dev-python/django-debug-toolbar/Manifest
index eec7d8642081..a954ba423049 100644
--- a/dev-python/django-debug-toolbar/Manifest
+++ b/dev-python/django-debug-toolbar/Manifest
@@ -1,3 +1,7 @@
DIST django_debug_toolbar-4.3.0.tar.gz 261173 BLAKE2B d5332d205be3a08826ac8b1bf1cb1ed8cd06b66cd5efb203a4290c9e75aab96c822d46c93830182cf6bd6fe2b867e14d5a82d52f6f72aebeaa9aa8ff1bc4e558 SHA512 48e06187289fc92216e5d7c0a77f88ce2fd105eef5ae2bc8dd0d398929c86a9fe021ea1f88f03083174f846f7e43cd07353e1175694733bfa0d55e4aa612c7f3
+DIST django_debug_toolbar-4.4.1.tar.gz 267118 BLAKE2B bd30b9f37dae7e9010ccfc779c7248b18f2477dcf807b0fcd5798c1ef7bea3d44ccb8bd3f0563c13d7a35735a0a19994854c78f58c496d2cb70fc6569c83a2f8 SHA512 46dfb42066d067d83092021ee38919b66bc60858a9ec607ee2f744e837ae83846d4f935d5b56df33e3028714cade7aaf2fbf119be0e404e32c15c64213ca1f35
+DIST django_debug_toolbar-4.4.2.tar.gz 267356 BLAKE2B f9a84d686cdd785fc6bf9072049e72322bcb8328d3ba5975469cd01861df238e71e108118bcbe427a4b8162ee695afbb64a26102d156d21945655e4c1d2f43d6 SHA512 24e3365758c9666afeda8ecf9db6b1813a657a0cebf0a84e76b3e712700527a232bbabe34b5d42b913de9ff68cadbabbae4173fe38d48d484f74383284b2dbbe
EBUILD django-debug-toolbar-4.3.0.ebuild 718 BLAKE2B 7b1533c599d9cc3417fe03a4a399704dd2baead8863b98196c2873e7edf2a62d02a5233ac97a53b174aeed2579a658e85f77eab033451076734acbbcac840df5 SHA512 c3776e4893b148f3b73ebb8f42e7034c4f4ac82f798e1245c5b2bcbfed0d5c9c12a875b2cfe90c9f05c78c304e3a6e8de898247f622b94d73416b83c2f129032
+EBUILD django-debug-toolbar-4.4.1.ebuild 732 BLAKE2B fcea1314fb903c4c6a7c98ea074c2fd0deec83ff1921b37a7d83c60600d98592d96c8dcf826b26784efef0c99f107adaf370b66a1a6ea8d3e9bfcb574be61ce0 SHA512 d06b95138dc2d1488899e703a4c3967d998425bbf82e183029957d763bceec16c5504c801603663d6d38076449cfff8c686f44d98050810a9ec0eadbc8c84fea
+EBUILD django-debug-toolbar-4.4.2.ebuild 732 BLAKE2B fcea1314fb903c4c6a7c98ea074c2fd0deec83ff1921b37a7d83c60600d98592d96c8dcf826b26784efef0c99f107adaf370b66a1a6ea8d3e9bfcb574be61ce0 SHA512 d06b95138dc2d1488899e703a4c3967d998425bbf82e183029957d763bceec16c5504c801603663d6d38076449cfff8c686f44d98050810a9ec0eadbc8c84fea
MISC metadata.xml 400 BLAKE2B 5e173b9872626f2eb14b25d4b0271f339576fefc19a28f3ad8a8358bd0cd07ef6af0a268f7aa0f403ffb6ffd9527415bc173f7c5fb516bdb2e201883a8ec7390 SHA512 64e2fd8932cc6795a7d72aa37d8634f17556f1141c1bef1abddca2d56fa67f8500861b53a2698a96bf8adf66e7a991108b59fce55c710cd6cc3963ee3a35241e
diff --git a/dev-python/django-debug-toolbar/django-debug-toolbar-4.4.1.ebuild b/dev-python/django-debug-toolbar/django-debug-toolbar-4.4.1.ebuild
new file mode 100644
index 000000000000..5b2d91965915
--- /dev/null
+++ b/dev-python/django-debug-toolbar/django-debug-toolbar-4.4.1.ebuild
@@ -0,0 +1,36 @@
+# Copyright 2023-2024 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=hatchling
+PYTHON_COMPAT=( python3_{10..12} )
+
+inherit distutils-r1 pypi
+
+DESCRIPTION="A configurable set of panels that display various debug information"
+HOMEPAGE="
+ https://github.com/jazzband/django-debug-toolbar/
+ https://pypi.org/project/django-debug-toolbar/
+"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~amd64"
+IUSE="test"
+RESTRICT="!test? ( test )"
+
+RDEPEND="
+ >=dev-python/django-4.2.9[${PYTHON_USEDEP}]
+"
+
+BDEPEND="
+ test? (
+ dev-python/html5lib[${PYTHON_USEDEP}]
+ )
+"
+
+python_test() {
+ "${EPYTHON}" -m django test -v 2 --settings tests.settings tests \
+ || die "Tests failed with ${EPYTHON}"
+}
diff --git a/dev-python/django-debug-toolbar/django-debug-toolbar-4.4.2.ebuild b/dev-python/django-debug-toolbar/django-debug-toolbar-4.4.2.ebuild
new file mode 100644
index 000000000000..5b2d91965915
--- /dev/null
+++ b/dev-python/django-debug-toolbar/django-debug-toolbar-4.4.2.ebuild
@@ -0,0 +1,36 @@
+# Copyright 2023-2024 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=hatchling
+PYTHON_COMPAT=( python3_{10..12} )
+
+inherit distutils-r1 pypi
+
+DESCRIPTION="A configurable set of panels that display various debug information"
+HOMEPAGE="
+ https://github.com/jazzband/django-debug-toolbar/
+ https://pypi.org/project/django-debug-toolbar/
+"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~amd64"
+IUSE="test"
+RESTRICT="!test? ( test )"
+
+RDEPEND="
+ >=dev-python/django-4.2.9[${PYTHON_USEDEP}]
+"
+
+BDEPEND="
+ test? (
+ dev-python/html5lib[${PYTHON_USEDEP}]
+ )
+"
+
+python_test() {
+ "${EPYTHON}" -m django test -v 2 --settings tests.settings tests \
+ || die "Tests failed with ${EPYTHON}"
+}