summaryrefslogtreecommitdiff
path: root/dev-python/django-debug-toolbar
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2021-04-28 20:21:43 +0100
committerV3n3RiX <venerix@redcorelinux.org>2021-04-28 20:21:43 +0100
commit40aaaa64e86ba6710bbeb31c4615a6ce80e75e11 (patch)
tree758c221bad35c9288d0bd6df9c7dfc226728e52c /dev-python/django-debug-toolbar
parent8d5dbd847cbc704a6a06405856e94b461011afe3 (diff)
gentoo resync : 28.04.2021
Diffstat (limited to 'dev-python/django-debug-toolbar')
-rw-r--r--dev-python/django-debug-toolbar/Manifest2
-rw-r--r--dev-python/django-debug-toolbar/django-debug-toolbar-3.2.1.ebuild47
2 files changed, 49 insertions, 0 deletions
diff --git a/dev-python/django-debug-toolbar/Manifest b/dev-python/django-debug-toolbar/Manifest
index 915013928d8b..95041debabbf 100644
--- a/dev-python/django-debug-toolbar/Manifest
+++ b/dev-python/django-debug-toolbar/Manifest
@@ -1,3 +1,5 @@
DIST django-debug-toolbar-3.1.tar.gz 228867 BLAKE2B af3d8011136ba30e690e03548d757405e9cd89fb5473b277720a3151149e92be212e50a6ec3d95903382716c9594405a1e93a7a1bf231f220f4b5c8ae1e38480 SHA512 c4cfa3cd98adfba7362e259e18a0240b886f294ba10f5c64e12887b00d4dc952e9b80cac0f78e7193a15566585f43d988f6d287e4d0dcc84c4f8395c7006e2b0
+DIST django-debug-toolbar-3.2.1.tar.gz 231177 BLAKE2B b07ed03a92b5799dafd1b15b41335c5da6994be1001b579c85e0923ccc092e617ce04c9a2f4344716213cdd62425737838a8539ca5b566928bf8b4c133e8451e SHA512 d28e13cc2e3bbb27e9c728037229adac444180e3831b88c9ac1aa0e139bd1e85f9190c7a324afe3292bde4ad0c919bd17fbde4998be266f81314b9b22c4a28e6
EBUILD django-debug-toolbar-3.1.ebuild 1159 BLAKE2B e774e5614699490a181d41a8a9efdbb3e34e0581d5f34e47237c43264db794b73652ed1c6dfd69706aeaa82764c4d55727222d3461963eeaae86314e48bdce1e SHA512 c57dbdfcc8a72283d446eb8246e206169a1e43070e5663cc533e72101a68c219f48649569bfa447d5e056329d28aca33cc054e03641ebe5f706b8bf5cb214ea8
+EBUILD django-debug-toolbar-3.2.1.ebuild 962 BLAKE2B 4c19b67f4401317503f3aa38eb4362b04c66be04a3706d5a9f3ba08c2905dbfc6b63e8a324118a4d2762f96e859eb77deaedb6e9cab56157e2d5434469dbda14 SHA512 190e91eac002f1dbbfc195e968642c1b26637038350c54d144f6079708a611b498feccc65dfa69f9d48e2590cc4963b9b122992a02e698f43c5eb8e0fbc9b8e5
MISC metadata.xml 392 BLAKE2B 69de466f8b461389463725f2ac42881a0e0b17b2242d6dccfc045593b9feb03a0650c7e9961845298c410ac81dfbc30b9387bec3e0574765c59acb8d3256e737 SHA512 f85001a94daa2890ea28e87ecf6b6233f905141ebbb9af29087bf42a91f72f0cc7458474e84ae1ea80fd854252cfb2bb305576ad2a25ce5e36cf823caddaafd6
diff --git a/dev-python/django-debug-toolbar/django-debug-toolbar-3.2.1.ebuild b/dev-python/django-debug-toolbar/django-debug-toolbar-3.2.1.ebuild
new file mode 100644
index 000000000000..06f03d13eb93
--- /dev/null
+++ b/dev-python/django-debug-toolbar/django-debug-toolbar-3.2.1.ebuild
@@ -0,0 +1,47 @@
+# Copyright 1999-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+PYTHON_COMPAT=( python3_{7..9} )
+
+inherit distutils-r1
+
+DESCRIPTION="A configurable set of panels that display debug information"
+HOMEPAGE="
+ https://pypi.org/project/django-debug-toolbar/
+ https://github.com/jazzband/django-debug-toolbar/"
+SRC_URI="https://github.com/jazzband/${PN}/archive/${PV}.tar.gz -> ${P}.tar.gz"
+
+SLOT="0"
+LICENSE="BSD"
+KEYWORDS="~amd64 ~x86"
+IUSE="doc examples test"
+RESTRICT="!test? ( test )"
+
+RDEPEND="
+ >=dev-python/django-1.11[${PYTHON_USEDEP}]
+ >=dev-python/sqlparse-0.2.0[${PYTHON_USEDEP}]
+"
+DEPEND="
+ test? (
+ $(python_gen_impl_dep sqlite)
+ ${RDEPEND}
+ )
+"
+
+distutils_enable_sphinx docs
+
+python_test() {
+ emake TEST_ARGS='-v 2 tests' test
+}
+
+python_install_all() {
+ if use examples; then
+ docinto examples
+ dodoc -r example/.
+ docompress -x /usr/share/doc/${PF}/examples
+ fi
+
+ distutils-r1_python_install_all
+}