summaryrefslogtreecommitdiff
path: root/dev-python/django-crispy-forms
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2023-02-28 22:05:06 +0000
committerV3n3RiX <venerix@koprulu.sector>2023-02-28 22:05:06 +0000
commit5df0c8ba4bb09f65c6cfb7d67dead00d6b2a1bf9 (patch)
treead139c5164214ddcb3471af11b3bbba70e031e24 /dev-python/django-crispy-forms
parent158e7d0067767d034ef3a86a07afbf5bb9bf579f (diff)
gentoo auto-resync : 28:02:2023 - 22:05:06
Diffstat (limited to 'dev-python/django-crispy-forms')
-rw-r--r--dev-python/django-crispy-forms/Manifest4
-rw-r--r--dev-python/django-crispy-forms/django-crispy-forms-1.14.0.ebuild8
-rw-r--r--dev-python/django-crispy-forms/django-crispy-forms-2.0.ebuild27
3 files changed, 37 insertions, 2 deletions
diff --git a/dev-python/django-crispy-forms/Manifest b/dev-python/django-crispy-forms/Manifest
index af0e6110f8af..a8135545c787 100644
--- a/dev-python/django-crispy-forms/Manifest
+++ b/dev-python/django-crispy-forms/Manifest
@@ -1,3 +1,5 @@
DIST django-crispy-forms-1.14.0.gh.tar.gz 295826 BLAKE2B 4be78ba2eb8b7dfd6d9813d2a94b26ca571f3c8767f22e37e64deca517b0044d1684343f82790860f024b6eaf6759acfdb6975e4497e40bb75cc64ace3ce9745 SHA512 964ebcd74dd284d11cd0a820238468cce415a61b9ac83afe401b1414da0e27b3e9e0a9aa4fec411a8ff9fa08aa6fb56550c6262e0a9d821b17e12590fc06970c
-EBUILD django-crispy-forms-1.14.0.ebuild 521 BLAKE2B 5c32c2edf4496ff0c4a96372f4f70492a6660cc314e5489a30aed24f5b77c4ae1482be8b339cfab935da10e595788546605967cecbc9f5c7a954b93f69aafcaa SHA512 e6d17e79d99b62b4aa860518aee053766b412bdd2e9d3bb2a6422bd9f60f34facd9a87e1b3be5c80cafe028c855baacc8b554e7b95c57a614044da57d2a4b086
+DIST django-crispy-forms-2.0.gh.tar.gz 273743 BLAKE2B 4169c4f77ddd0dd9f8786abd71ad762f645283555f250861f32b874fb9e189d4ca174285ee39b51bc5f0c0e8c2e83c2e00c34398c51ede65438a1c6b8a17c3ee SHA512 8b6f5b35cb90837b7cd6a64ed74afe6a19a80f287f66d0a139811990524e1a48d4d7c01e61fb7d303958522c47458d0aa0008a3d6c147f7d03dc790e53a80592
+EBUILD django-crispy-forms-1.14.0.ebuild 639 BLAKE2B a21e1623ba700cc87f72a79473da49b296cb8122cb96dce8fc88eb7470a0f92478291a8bb00b1424ff773ab3d818d82642d06ab1e36955a897fb6b94801d0955 SHA512 150c572bcb03aaf39b656e221444b65a856884bd2961c753a8f07182690a6b440536c9c116862b59d4875b28b77722c8209313cb5491c25925e9cee4e42a0e32
+EBUILD django-crispy-forms-2.0.ebuild 642 BLAKE2B 55cda626b6e2582238c4bb76da1ff388da18cc871b11ce2f0ea27c5f0f25e7980454bcf359d72a4d609a6db10d48ecc13388bb68477c7018ba487f77c43aaeb1 SHA512 4f528d6fb9f76bd4432e4806e4f7372264cc732ab62bac40cb6c8d2ee63a451405895cfe65151aafa3a1fb25e3fb36d357b84e54bdd2e3d72b4a2559bffc93a0
MISC metadata.xml 409 BLAKE2B d9663843245601ca8675fd522ca3b4150c36611874fb852f3c0c7bf68ec9595cb45ef66c293d658c13670f18bca6949a2747cffbbf819b55cd9b30ca6340bfba SHA512 2b1091cac748a00099f3a1685150bc8dfdf252b18b7e5c2fc17a8ca5054ec7ac0e72286dba872ead0354b4bae02cc3c410a5d05828f9dc257919526077bffc8d
diff --git a/dev-python/django-crispy-forms/django-crispy-forms-1.14.0.ebuild b/dev-python/django-crispy-forms/django-crispy-forms-1.14.0.ebuild
index 790ba770fa73..0463cb56afea 100644
--- a/dev-python/django-crispy-forms/django-crispy-forms-1.14.0.ebuild
+++ b/dev-python/django-crispy-forms/django-crispy-forms-1.14.0.ebuild
@@ -16,6 +16,12 @@ SRC_URI="https://github.com/django-crispy-forms/${PN}/archive/${PV}.tar.gz
LICENSE="MIT"
SLOT="0"
KEYWORDS="~amd64 ~x86"
-RESTRICT="test" #Not working
+IUSE="test"
+RESTRICT="test" #Some tests are failing
RDEPEND="dev-python/django[${PYTHON_USEDEP}]"
+BDEPEND="test? (
+ dev-python/pytest-django[${PYTHON_USEDEP}]
+)"
+
+distutils_enable_tests pytest
diff --git a/dev-python/django-crispy-forms/django-crispy-forms-2.0.ebuild b/dev-python/django-crispy-forms/django-crispy-forms-2.0.ebuild
new file mode 100644
index 000000000000..914ce0712232
--- /dev/null
+++ b/dev-python/django-crispy-forms/django-crispy-forms-2.0.ebuild
@@ -0,0 +1,27 @@
+# Copyright 2022-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=setuptools
+PYTHON_COMPAT=( python3_{9..11} )
+
+inherit distutils-r1
+
+DESCRIPTION="DRY Django forms"
+HOMEPAGE="https://github.com/django-crispy-forms/django-crispy-forms"
+SRC_URI="https://github.com/django-crispy-forms/${PN}/archive/${PV}.tar.gz
+ -> ${P}.gh.tar.gz"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="test"
+RESTRICT="test" #Missing crispy_bootstrap3
+
+RDEPEND="dev-python/django[${PYTHON_USEDEP}]"
+BDEPEND="test? (
+ dev-python/pytest-django[${PYTHON_USEDEP}]
+)"
+
+distutils_enable_tests pytest