summaryrefslogtreecommitdiff
path: root/dev-python/django-crispy-forms
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2017-10-09 18:53:29 +0100
committerV3n3RiX <venerix@redcorelinux.org>2017-10-09 18:53:29 +0100
commit4f2d7949f03e1c198bc888f2d05f421d35c57e21 (patch)
treeba5f07bf3f9d22d82e54a462313f5d244036c768 /dev-python/django-crispy-forms
reinit the tree, so we can have metadata
Diffstat (limited to 'dev-python/django-crispy-forms')
-rw-r--r--dev-python/django-crispy-forms/Manifest5
-rw-r--r--dev-python/django-crispy-forms/django-crispy-forms-1.6.0.ebuild32
-rw-r--r--dev-python/django-crispy-forms/metadata.xml12
3 files changed, 49 insertions, 0 deletions
diff --git a/dev-python/django-crispy-forms/Manifest b/dev-python/django-crispy-forms/Manifest
new file mode 100644
index 000000000000..6df554c58b14
--- /dev/null
+++ b/dev-python/django-crispy-forms/Manifest
@@ -0,0 +1,5 @@
+DIST django-crispy-forms-1.6.0.tar.gz 118917 SHA256 67fbb7194bd9887d663161405c623f5f5cd3f9ee627515c4de7a50e16fa44ed1 SHA512 8fa46366d2f3376f4190c219a624eaf983c19243db25d6c1723917ab5f8c2d9087e2228f3208df8bd35ba26abe00f6cef46e1e3ca0c0097282d292a217f977f8 WHIRLPOOL 4b1ab48f49edf019151b8ca42e5d0ea34ad310690e929b6c8579773a7adadeffec685285f8310c20cbac4d71edcfebdd9f2ddd709ebcfef57a75f8f139e7aff6
+EBUILD django-crispy-forms-1.6.0.ebuild 768 SHA256 97f689dc81939464e7153fae306fb7bcec90de90a82ceab7a5183ecc96625420 SHA512 de8fa0615adc38ae5585ca2ab40f58d01e18187ff43cd58fa93a24c52a4e61a881390bcdbad3f3233bd02487666a329b620a4c6eed6426ab272e7b88199430a1 WHIRLPOOL e184b96c9c0176a1fa491893f0f0cd7ae57050135942a686a645df4c13c81dadf4770a198183dee54f4598faa682ef80cc72a09f66620be0bf96f5666a5bd30a
+MISC ChangeLog 4024 SHA256 1643a44d07b6a692a2ba910fb2e414e81d6cab83d66bdcc58d2d32fe2ee8b11e SHA512 179e7ce8ff641962423e9d6c6e0b2b900f665ff92324aecd708bf9bba62d3bd3643de71546390b03a242a3442ba37ac8ef05636adbc98310d7a5b093e809e137 WHIRLPOOL 9fb18f1f3b6f33d0690d6a8b861c37b38abd6b77569d9859c19eca0b31a0bf20af9a17d1f94b18628f37758caea8ff9a0473ff5863da0fbac0fbf54cdb3dcae1
+MISC ChangeLog-2015 606 SHA256 f2da353e22f5b0669f8f748e325a1f0137b6d148e3b52292af0ca242882b9ab1 SHA512 aab564719952e410e70111b5d61808957648c3c795ab3674eb918ac7fedf74032d089f3bd099880cdab080b45e3dd8a3fc030391ea96b68974acfbfb334e71b0 WHIRLPOOL 6d34e6b75d04d9c1bcb7a8324c74b521096ddb6ac8b923f8b3359b5766dc1af8133568748707a5c636b71a214addf7ccb43cbcd4f77401eb0dbcdb47b56f51f4
+MISC metadata.xml 402 SHA256 9f1eb0b1344bba1d017a850dd527484680fc0872d61b93d2826ef3da826868d9 SHA512 131cfc83f2e89f8bd0928d7663cb6272f20532b2a431a7a33171a9af76c6ab4edf02d2c81a4644ef132bc46cf7c0d997935bf34a665de8267120c11e09683ce9 WHIRLPOOL bb973a2b216934c59131f280bb09afd44dd8e53526714f8e6084f1ae42cd5e8e6d8188c4f2e1691559bf2567a10db6018466a33f63393b5c0f3b9b007d5f915d
diff --git a/dev-python/django-crispy-forms/django-crispy-forms-1.6.0.ebuild b/dev-python/django-crispy-forms/django-crispy-forms-1.6.0.ebuild
new file mode 100644
index 000000000000..083636da4530
--- /dev/null
+++ b/dev-python/django-crispy-forms/django-crispy-forms-1.6.0.ebuild
@@ -0,0 +1,32 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=5
+
+PYTHON_COMPAT=( python2_7 python3_{4,5,6} pypy )
+
+inherit distutils-r1
+
+DESCRIPTION="Best way to have Django DRY forms"
+HOMEPAGE="
+ https://pypi.python.org/pypi/django-crispy-forms/
+ https://github.com/maraujop/django-crispy-forms
+ https://django-crispy-forms.readthedocs.org/en/latest/"
+SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+
+SLOT="0"
+LICENSE="MIT"
+KEYWORDS="~amd64 ~x86 ~amd64-linux ~x86-linux"
+IUSE=""
+
+RDEPEND=""
+DEPEND="${RDEPEND}
+ dev-python/setuptools[${PYTHON_USEDEP}]
+"
+
+# Seems to be incompletely packed
+RESTRICT=test
+
+python_test() {
+ DJANGO_SETTINGS_MODULE=crispy_forms.tests.test_settings py.test crispy_forms/tests || die
+}
diff --git a/dev-python/django-crispy-forms/metadata.xml b/dev-python/django-crispy-forms/metadata.xml
new file mode 100644
index 000000000000..9bff2ed0abef
--- /dev/null
+++ b/dev-python/django-crispy-forms/metadata.xml
@@ -0,0 +1,12 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <maintainer type="project">
+ <email>python@gentoo.org</email>
+ <name>Python</name>
+ </maintainer>
+ <upstream>
+ <remote-id type="pypi">django-crispy-forms</remote-id>
+ <remote-id type="github">maraujop/django-crispy-forms</remote-id>
+ </upstream>
+</pkgmetadata>