summaryrefslogtreecommitdiff
path: root/dev-python/django-crispy-forms/django-crispy-forms-2.0-r1.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2023-04-01 23:15:56 +0100
committerV3n3RiX <venerix@koprulu.sector>2023-04-01 23:15:56 +0100
commit85a2a2153ef8027c2ba1be45143cd91914be0ad0 (patch)
treead0163abb9755ef7f76a919d9225f26559a27076 /dev-python/django-crispy-forms/django-crispy-forms-2.0-r1.ebuild
parent4de024ca2423b3aa77a91dd34ef0b70aff64f768 (diff)
gentoo auto-resync : 01:04:2023 - 23:15:55
Diffstat (limited to 'dev-python/django-crispy-forms/django-crispy-forms-2.0-r1.ebuild')
-rw-r--r--dev-python/django-crispy-forms/django-crispy-forms-2.0-r1.ebuild28
1 files changed, 28 insertions, 0 deletions
diff --git a/dev-python/django-crispy-forms/django-crispy-forms-2.0-r1.ebuild b/dev-python/django-crispy-forms/django-crispy-forms-2.0-r1.ebuild
new file mode 100644
index 000000000000..c25924666e64
--- /dev/null
+++ b/dev-python/django-crispy-forms/django-crispy-forms-2.0-r1.ebuild
@@ -0,0 +1,28 @@
+# Copyright 2022-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=setuptools
+PYTHON_COMPAT=( python3_{9..11} )
+
+inherit distutils-r1
+
+DESCRIPTION="DRY Django forms"
+HOMEPAGE="https://github.com/django-crispy-forms/django-crispy-forms"
+SRC_URI="https://github.com/django-crispy-forms/${PN}/archive/${PV}.tar.gz
+ -> ${P}.gh.tar.gz"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="test"
+
+RDEPEND="dev-python/django[${PYTHON_USEDEP}]"
+BDEPEND="test? (
+ dev-python/pytest-django[${PYTHON_USEDEP}]
+ dev-python/crispy-bootstrap3[${PYTHON_USEDEP}]
+ dev-python/crispy-bootstrap4[${PYTHON_USEDEP}]
+)"
+
+distutils_enable_tests pytest