summaryrefslogtreecommitdiff
path: root/dev-python/django-configurations
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2022-06-29 12:04:12 +0100
committerV3n3RiX <venerix@koprulu.sector>2022-06-29 12:04:12 +0100
commit0f558761aa2dee1017b4751e4017205e015a9560 (patch)
tree037df795519468a25d9362b4e95cdaeb84eb1cf9 /dev-python/django-configurations
parent752d6256e5204b958b0ef7905675a940b5e9172f (diff)
gentoo resync : 29.12.2022
Diffstat (limited to 'dev-python/django-configurations')
-rw-r--r--dev-python/django-configurations/Manifest3
-rw-r--r--dev-python/django-configurations/django-configurations-2.3.2.ebuild18
-rw-r--r--dev-python/django-configurations/files/django-configurations-2.3.2-test.patch45
3 files changed, 60 insertions, 6 deletions
diff --git a/dev-python/django-configurations/Manifest b/dev-python/django-configurations/Manifest
index dfe89bc9e570..787cbd29aa18 100644
--- a/dev-python/django-configurations/Manifest
+++ b/dev-python/django-configurations/Manifest
@@ -1,3 +1,4 @@
+AUX django-configurations-2.3.2-test.patch 1858 BLAKE2B 20c6095f59747fa7e37759e39411877a88ac0b71b148f40c9e48f14c053d64203f342524469b63670fd6c6c90c79c6906cf4386717407a99de723166d0f37d79 SHA512 4b9eee16d0b0626b867ce3032165f63270dd56bf8ceb0f70008a136e7d45469a18dd7bba8c1b39fc57d4b03dbf0ab528659100b9be81bc203aac1c4d6c8a9ec8
DIST django-configurations-2.3.2.gh.tar.gz 38475 BLAKE2B 2b3c583e665a08a46bc0ca0c52ae4326fbdfb794d102deecbd13f953e8b6f3fd39b3b747c591fc9717c6a0792258cdb9041de53e71db2034de1a31ddf5bfc0ea SHA512 4cb5a7b284a0025ba93b32e158fb65b57e66230938181b921a1b1264848113b697eb45ac6ad2fc4f26f3bc29ea5f77acbfd5307b20ef2d385e29c2c1746295b3
-EBUILD django-configurations-2.3.2.ebuild 1168 BLAKE2B c9710c2ad0cf1c28acc41e78cbbab8fc1960936ab8223e454c390e1fb969e2c5d3cb64ec2bc69ae64d4d8ac2b74f8819df8f7232196a988ddd0f2b0ee275a862 SHA512 bf09fac48715b15e0e4d5194ebae968cc430fd96d5eb3f0967fa00ac2447e4a87e1569683160d483938b125d9e3c5f64b1513219f9fca3b2b0c9787369e4d244
+EBUILD django-configurations-2.3.2.ebuild 1216 BLAKE2B ea041b72c26f414156463a3d383aa70acda08675277a1bd6d427cfa108f82bc80666a7a8984957c2a802ade83ff6ae3c5debbc23895d29d215a3120bd334b2d4 SHA512 e084e34301535a97a797cc22cb8bf80fb1be554e47daa8fe6d453162530cf3e29413db2611577469a3fd3c31739da6838c9ac456442aa51ba5a954d1840d5338
MISC metadata.xml 397 BLAKE2B 704a6d38af3df4b99f24a394dce870ce4f3e1e16c2a30b87ab25ab4b3603451651db062d2aca6669b410bf5350b0edc7b4848ef55bc60c69edc3aedeb8a7c0fc SHA512 a37389a326e763452c7ea138da3eb33dad53bbce24fbd9229e58020063d4e726e68e482500c87238bc0c53b9ee335f93f2d89f39e7ce3e2a087175a2393c66e4
diff --git a/dev-python/django-configurations/django-configurations-2.3.2.ebuild b/dev-python/django-configurations/django-configurations-2.3.2.ebuild
index b8bbfbdabaea..65cfca8e9dc9 100644
--- a/dev-python/django-configurations/django-configurations-2.3.2.ebuild
+++ b/dev-python/django-configurations/django-configurations-2.3.2.ebuild
@@ -4,7 +4,7 @@
EAPI=8
DISTUTILS_USE_PEP517=setuptools
-PYTHON_COMPAT=( python3_{8..10} )
+PYTHON_COMPAT=( python3_{8..11} )
inherit distutils-r1
@@ -12,10 +12,12 @@ DESCRIPTION="A helper for organizing Django settings"
HOMEPAGE="
https://pypi.org/project/django-configurations/
https://github.com/jazzband/django-configurations/
- https://django-configurations.readthedocs.io/"
+ https://django-configurations.readthedocs.io/
+"
SRC_URI="
https://github.com/jazzband/django-configurations/archive/${PV}.tar.gz
- -> ${P}.gh.tar.gz"
+ -> ${P}.gh.tar.gz
+"
LICENSE="BSD"
SLOT="0"
@@ -24,7 +26,8 @@ IUSE="test"
RESTRICT="!test? ( test )"
RDEPEND="
- dev-python/django[${PYTHON_USEDEP}]"
+ dev-python/django[${PYTHON_USEDEP}]
+"
BDEPEND="
dev-python/setuptools_scm[${PYTHON_USEDEP}]
test? (
@@ -32,10 +35,15 @@ BDEPEND="
dev-python/dj-database-url[${PYTHON_USEDEP}]
dev-python/dj-email-url[${PYTHON_USEDEP}]
dev-python/dj-search-url[${PYTHON_USEDEP}]
- )"
+ )
+"
export SETUPTOOLS_SCM_PRETEND_VERSION=${PV}
+PATCHES=(
+ "${FILESDIR}"/${P}-test.patch
+)
+
python_test() {
local -x DJANGO_SETTINGS_MODULE=tests.settings.main
local -x DJANGO_CONFIGURATION=Test
diff --git a/dev-python/django-configurations/files/django-configurations-2.3.2-test.patch b/dev-python/django-configurations/files/django-configurations-2.3.2-test.patch
new file mode 100644
index 000000000000..19787102920a
--- /dev/null
+++ b/dev-python/django-configurations/files/django-configurations-2.3.2-test.patch
@@ -0,0 +1,45 @@
+diff --git a/tests/test_values.py b/tests/test_values.py
+index 2547e50..2f1170b 100644
+--- a/tests/test_values.py
++++ b/tests/test_values.py
+@@ -2,6 +2,7 @@ import decimal
+ import os
+ from contextlib import contextmanager
+
++from django import VERSION as DJANGO_VERSION
+ from django.test import TestCase
+ from django.core.exceptions import ImproperlyConfigured
+
+@@ -411,6 +412,7 @@ class ValueTests(TestCase):
+ 'EMAIL_HOST_PASSWORD': 'password',
+ 'EMAIL_HOST_USER': 'user@domain.com',
+ 'EMAIL_PORT': 587,
++ 'EMAIL_TIMEOUT': None,
+ 'EMAIL_USE_SSL': False,
+ 'EMAIL_USE_TLS': True})
+ with env(EMAIL_URL='console://'):
+@@ -421,6 +423,7 @@ class ValueTests(TestCase):
+ 'EMAIL_HOST_PASSWORD': None,
+ 'EMAIL_HOST_USER': None,
+ 'EMAIL_PORT': None,
++ 'EMAIL_TIMEOUT': None,
+ 'EMAIL_USE_SSL': False,
+ 'EMAIL_USE_TLS': False})
+ with env(EMAIL_URL='smtps://user@domain.com:password@smtp.example.com:wrong'): # noqa: E501
+@@ -429,7 +432,7 @@ class ValueTests(TestCase):
+ def test_cache_url_value(self):
+ cache_setting = {
+ 'default': {
+- 'BACKEND': 'django_redis.cache.RedisCache',
++ 'BACKEND': 'django_redis.cache.RedisCache' if DJANGO_VERSION[0] < 4 else 'django.core.cache.backends.redis.RedisCache',
+ 'LOCATION': 'redis://host:6379/1',
+ }
+ }
+@@ -503,6 +506,7 @@ class ValueTests(TestCase):
+ 'EMAIL_HOST_PASSWORD': 'password',
+ 'EMAIL_HOST_USER': 'user@domain.com',
+ 'EMAIL_PORT': 587,
++ 'EMAIL_TIMEOUT': None,
+ 'EMAIL_USE_SSL': False,
+ 'EMAIL_USE_TLS': True
+ })