summaryrefslogtreecommitdiff
path: root/dev-python/django-configurations
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2024-06-20 00:10:57 +0100
committerV3n3RiX <venerix@koprulu.sector>2024-06-20 00:10:57 +0100
commitd6ca4e4f90cb75c323b5988eefa96a04c0d36908 (patch)
tree8197fc88451976470c871e991b75a9d40c240270 /dev-python/django-configurations
parente8df704cf9b5e9e517317b8912377c0a8ca0d11e (diff)
gentoo auto-resync : 20:06:2024 - 00:10:56
Diffstat (limited to 'dev-python/django-configurations')
-rw-r--r--dev-python/django-configurations/Manifest3
-rw-r--r--dev-python/django-configurations/django-configurations-2.5.1.ebuild8
-rw-r--r--dev-python/django-configurations/files/django-configurations-2.5.1-test.patch12
3 files changed, 21 insertions, 2 deletions
diff --git a/dev-python/django-configurations/Manifest b/dev-python/django-configurations/Manifest
index c82dbea551bb..1c595603bbca 100644
--- a/dev-python/django-configurations/Manifest
+++ b/dev-python/django-configurations/Manifest
@@ -1,3 +1,4 @@
+AUX django-configurations-2.5.1-test.patch 503 BLAKE2B dc4cd0f5bb5b31006ba3ef59043733361ccf861988ae3a66e3eab16e7e6a65648868ca21208fa100fabe1d52afcb207e107a1ac7cf814122420a1c00e71dd215 SHA512 0054795af026a7b0e3047d880540a7c2431c56f65222594efb97ac30e7522bec4d2f9cd3d48006f698ce2c4481f323ca9ee5160c153fe866d2bbe567798cc73e
DIST django-configurations-2.5.1.tar.gz 43225 BLAKE2B 1b9cd14ea50d03500cc05790e831832f6e4e3a917903eb48aa40c2d2dd46a59684ce82b484229fd912a18bcdef4d1887989489b4ab461740f981a87c3a7914f5 SHA512 5584446a1b48a0c080401b377786864a905a28337e2912c71ba586ad438df6efeb74c2de1058b77d79f3ba7db85dd443f05dc81013576d301a43bad6736e72e2
-EBUILD django-configurations-2.5.1.ebuild 1120 BLAKE2B ce7d4a4d6434cc3374a15a72215da3662ad813a74bef698e34cda63b4e3f0ba420cabad19a2a39cdbc5a5b53a7af6d6d08a8c490db714e034d1f40c53aef71a1 SHA512 610445992f5e949a2a3bcc18005a8627878cce15b52c1fe10ca1d596e86253097b86f873430c1c5cd51d4a03e78bd75288519e6618981d4e3cf86a6f6249999f
+EBUILD django-configurations-2.5.1.ebuild 1267 BLAKE2B 8cc554f8eec4611214b0c320034de87f0d47a72d3e4acd8db6379cb2d904a83c39dd04013e96c21335aa689d8e2aad937a8cca069d393c348166340b38172cbe SHA512 3bba8945a371d47efb6fbedfd079501086a8ae3647ab463f5e85d2902aeb2bd7e6be815be478098840340fd861b1ae44e530942d716fa6840eff2324f85c392e
MISC metadata.xml 397 BLAKE2B 704a6d38af3df4b99f24a394dce870ce4f3e1e16c2a30b87ab25ab4b3603451651db062d2aca6669b410bf5350b0edc7b4848ef55bc60c69edc3aedeb8a7c0fc SHA512 a37389a326e763452c7ea138da3eb33dad53bbce24fbd9229e58020063d4e726e68e482500c87238bc0c53b9ee335f93f2d89f39e7ce3e2a087175a2393c66e4
diff --git a/dev-python/django-configurations/django-configurations-2.5.1.ebuild b/dev-python/django-configurations/django-configurations-2.5.1.ebuild
index 86eac772cff2..f68cf68518bb 100644
--- a/dev-python/django-configurations/django-configurations-2.5.1.ebuild
+++ b/dev-python/django-configurations/django-configurations-2.5.1.ebuild
@@ -5,7 +5,7 @@ EAPI=8
DISTUTILS_USE_PEP517=setuptools
PYPI_NO_NORMALIZE=1
-PYTHON_COMPAT=( pypy3 python3_{10..12} )
+PYTHON_COMPAT=( pypy3 python3_{10..13} )
inherit distutils-r1 pypi
@@ -37,6 +37,12 @@ BDEPEND="
export SETUPTOOLS_SCM_PRETEND_VERSION=${PV}
+PATCHES=(
+ # Update for dj-database-url == 2.2.0
+ # https://github.com/jazzband/django-configurations/issues/387
+ "${FILESDIR}/${P}-test.patch"
+)
+
python_test() {
local -x DJANGO_SETTINGS_MODULE=tests.settings.main
local -x DJANGO_CONFIGURATION=Test
diff --git a/dev-python/django-configurations/files/django-configurations-2.5.1-test.patch b/dev-python/django-configurations/files/django-configurations-2.5.1-test.patch
new file mode 100644
index 000000000000..c32586f7c3e8
--- /dev/null
+++ b/dev-python/django-configurations/files/django-configurations-2.5.1-test.patch
@@ -0,0 +1,12 @@
+diff --git a/tests/test_values.py b/tests/test_values.py
+index 55478e6..0b37907 100644
+--- a/tests/test_values.py
++++ b/tests/test_values.py
+@@ -377,6 +377,7 @@ class ValueTests(TestCase):
+ 'default': {
+ 'CONN_HEALTH_CHECKS': False,
+ 'CONN_MAX_AGE': 0,
++ 'DISABLE_SERVER_SIDE_CURSORS': False,
+ 'ENGINE': 'django.db.backends.sqlite3',
+ 'HOST': '',
+ 'NAME': ':memory:',