summaryrefslogtreecommitdiff
path: root/dev-python/django-configurations
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2021-06-15 14:57:03 +0100
committerV3n3RiX <venerix@redcorelinux.org>2021-06-15 14:57:03 +0100
commitd18bf1e01b65ee4bf0c804e2843b282d3d4e5d7c (patch)
tree4a95cbc6ffdf13bad6ecbc7f8d5af99631984123 /dev-python/django-configurations
parente748ba9741f6540f4675c23e3e37b73e822c13a4 (diff)
gentoo resync : 15.06.2021
Diffstat (limited to 'dev-python/django-configurations')
-rw-r--r--dev-python/django-configurations/Manifest3
-rw-r--r--dev-python/django-configurations/django-configurations-2.2.ebuild52
-rw-r--r--dev-python/django-configurations/metadata.xml7
3 files changed, 62 insertions, 0 deletions
diff --git a/dev-python/django-configurations/Manifest b/dev-python/django-configurations/Manifest
new file mode 100644
index 000000000000..25717f4d3ec2
--- /dev/null
+++ b/dev-python/django-configurations/Manifest
@@ -0,0 +1,3 @@
+DIST django-configurations-2.2.gh.tar.gz 41909 BLAKE2B 4107e37a694d4c9670f855886d870c7aea30e9b95788a6c09f6fb3c913d3ffc4d17ed250264ce9ff0408856787b4768cda67eecf26c135ccb338ffda7530fd41 SHA512 9c53811016c20ae4dedbb9e1951b45440b656fad2fb9544e94bbbabb65a5883846ee063647f107ac57c08e54db71206b89903ee1d02cbfc0c8d3dafe7520e5a2
+EBUILD django-configurations-2.2.ebuild 1432 BLAKE2B a9e7d284e9bc101551d10f6afc5679b46ecb0fe954d68e7d4b873e1f9f60a220cd76cd88670f718e53fa366972845cfebf00fb9d50bada43a720ff1effa939b2 SHA512 3df44e8359edab64563f79efcbdde4c057f0c13f6bd74e6a821595e00981c7daac262f812df025bc2d9159307b5244ef1f250d9a9de7599b371775494978ef48
+MISC metadata.xml 218 BLAKE2B 086fdcf7b63ca7bd6c58e861d717bb375e1cd372eff26d5d2eeeb176d8c5e6f10e653562abafb50eae7d7508f8e3d421b87e6a749acd0490308672828d0da697 SHA512 4558fee4c51117e21b1f42ca3edbdf1195ed297db798d6bfa0e5fbb7019654a187422b0abde7af5d800caffed66d1e55e4280e8be602bad591424d9776c46781
diff --git a/dev-python/django-configurations/django-configurations-2.2.ebuild b/dev-python/django-configurations/django-configurations-2.2.ebuild
new file mode 100644
index 000000000000..0667a343a3e6
--- /dev/null
+++ b/dev-python/django-configurations/django-configurations-2.2.ebuild
@@ -0,0 +1,52 @@
+# Copyright 2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+PYTHON_COMPAT=( python3_{8..10} )
+inherit distutils-r1
+
+DESCRIPTION="A helper for organizing Django settings"
+HOMEPAGE="
+ https://pypi.org/project/django-configurations/
+ https://github.com/jazzband/django-configurations/
+ https://django-configurations.readthedocs.io/"
+SRC_URI="
+ https://github.com/jazzband/django-configurations/archive/${PV}.tar.gz
+ -> ${P}.gh.tar.gz"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~amd64 ~ppc ~ppc64 ~sparc ~x86"
+IUSE="test"
+RESTRICT="!test? ( test )"
+
+# pkg_resources, https://github.com/jazzband/django-configurations/pull/282
+RDEPEND="
+ dev-python/django[${PYTHON_USEDEP}]
+ dev-python/setuptools[${PYTHON_USEDEP}]
+ dev-python/six[${PYTHON_USEDEP}]"
+BDEPEND="
+ dev-python/setuptools_scm[${PYTHON_USEDEP}]
+ test? (
+ dev-python/mock[${PYTHON_USEDEP}]
+ dev-python/django-cache-url[${PYTHON_USEDEP}]
+ dev-python/dj-database-url[${PYTHON_USEDEP}]
+ dev-python/dj-email-url[${PYTHON_USEDEP}]
+ dev-python/dj-search-url[${PYTHON_USEDEP}]
+ )"
+
+export SETUPTOOLS_SCM_PRETEND_VERSION=${PV}
+
+src_prepare() {
+ distutils-r1_src_prepare
+ # sphinx can't find tests package
+ rm tests/test_sphinx.py || die
+}
+
+python_test() {
+ local -x DJANGO_SETTINGS_MODULE=tests.settings.main
+ local -x DJANGO_CONFIGURATION=Test
+ distutils_install_for_testing
+ django-cadmin test -v2 || die "Tests failed with ${EPYTHON}"
+}
diff --git a/dev-python/django-configurations/metadata.xml b/dev-python/django-configurations/metadata.xml
new file mode 100644
index 000000000000..266e3f19ca59
--- /dev/null
+++ b/dev-python/django-configurations/metadata.xml
@@ -0,0 +1,7 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <maintainer type="project">
+ <email>python@gentoo.org</email>
+ </maintainer>
+</pkgmetadata>