summaryrefslogtreecommitdiff
path: root/dev-python/django-configurations/django-configurations-2.2.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2021-12-22 14:08:05 +0000
committerV3n3RiX <venerix@koprulu.sector>2021-12-22 14:08:05 +0000
commit93a93e9a3b53c1a73142a305ea1f8136846942ee (patch)
treeb9791a06ab3284e27b568412c59316c66240c682 /dev-python/django-configurations/django-configurations-2.2.ebuild
parent2771f79232c273bc2a57d23bf335dd81ccf6af28 (diff)
gentoo resync : 22.12.2021
Diffstat (limited to 'dev-python/django-configurations/django-configurations-2.2.ebuild')
-rw-r--r--dev-python/django-configurations/django-configurations-2.2.ebuild52
1 files changed, 0 insertions, 52 deletions
diff --git a/dev-python/django-configurations/django-configurations-2.2.ebuild b/dev-python/django-configurations/django-configurations-2.2.ebuild
deleted file mode 100644
index 54d504b631ce..000000000000
--- a/dev-python/django-configurations/django-configurations-2.2.ebuild
+++ /dev/null
@@ -1,52 +0,0 @@
-# Copyright 2021 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=7
-
-PYTHON_COMPAT=( python3_{8..10} )
-inherit distutils-r1
-
-DESCRIPTION="A helper for organizing Django settings"
-HOMEPAGE="
- https://pypi.org/project/django-configurations/
- https://github.com/jazzband/django-configurations/
- https://django-configurations.readthedocs.io/"
-SRC_URI="
- https://github.com/jazzband/django-configurations/archive/${PV}.tar.gz
- -> ${P}.gh.tar.gz"
-
-LICENSE="BSD"
-SLOT="0"
-KEYWORDS="amd64 arm arm64 ~ppc ~ppc64 ~riscv ~sparc x86"
-IUSE="test"
-RESTRICT="!test? ( test )"
-
-# pkg_resources, https://github.com/jazzband/django-configurations/pull/282
-RDEPEND="
- dev-python/django[${PYTHON_USEDEP}]
- dev-python/setuptools[${PYTHON_USEDEP}]
- dev-python/six[${PYTHON_USEDEP}]"
-BDEPEND="
- dev-python/setuptools_scm[${PYTHON_USEDEP}]
- test? (
- dev-python/mock[${PYTHON_USEDEP}]
- dev-python/django-cache-url[${PYTHON_USEDEP}]
- dev-python/dj-database-url[${PYTHON_USEDEP}]
- dev-python/dj-email-url[${PYTHON_USEDEP}]
- dev-python/dj-search-url[${PYTHON_USEDEP}]
- )"
-
-export SETUPTOOLS_SCM_PRETEND_VERSION=${PV}
-
-src_prepare() {
- distutils-r1_src_prepare
- # sphinx can't find tests package
- rm tests/test_sphinx.py || die
-}
-
-python_test() {
- local -x DJANGO_SETTINGS_MODULE=tests.settings.main
- local -x DJANGO_CONFIGURATION=Test
- distutils_install_for_testing
- django-cadmin test -v2 || die "Tests failed with ${EPYTHON}"
-}