summaryrefslogtreecommitdiff
path: root/dev-python/django-cache-url/django-cache-url-3.2.3.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2021-05-31 20:59:14 +0100
committerV3n3RiX <venerix@redcorelinux.org>2021-05-31 20:59:14 +0100
commite748ba9741f6540f4675c23e3e37b73e822c13a4 (patch)
tree23dece8beabb3a3d7c6c0273b0eb40b21c62a889 /dev-python/django-cache-url/django-cache-url-3.2.3.ebuild
parent908778078736bd36f7a60a2d576d415cb8e000fa (diff)
gentoo resync : 31.05.2021
Diffstat (limited to 'dev-python/django-cache-url/django-cache-url-3.2.3.ebuild')
-rw-r--r--dev-python/django-cache-url/django-cache-url-3.2.3.ebuild17
1 files changed, 11 insertions, 6 deletions
diff --git a/dev-python/django-cache-url/django-cache-url-3.2.3.ebuild b/dev-python/django-cache-url/django-cache-url-3.2.3.ebuild
index 1116937c9657..88aea34048d0 100644
--- a/dev-python/django-cache-url/django-cache-url-3.2.3.ebuild
+++ b/dev-python/django-cache-url/django-cache-url-3.2.3.ebuild
@@ -1,22 +1,27 @@
# Copyright 2021 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
-EAPI="7"
+EAPI=7
-PYTHON_COMPAT=( python3_{7..9} )
-DISTUTILS_USE_SETUPTOOLS=bdepend
+PYTHON_COMPAT=( python3_{7..10} )
-inherit distutils-r1 python-utils-r1
+inherit distutils-r1
EGIT_COMMIT="3480e70bb19eef22f4e1beeddd236f44414ac5ac"
DESCRIPTION="Use Cache URLs in your Django application"
HOMEPAGE="https://github.com/epicserve/django-cache-url"
SRC_URI="https://github.com/epicserve/django-cache-url/archive/${EGIT_COMMIT}.tar.gz -> ${P}.tar.gz"
+S="${WORKDIR}/${PN}-${EGIT_COMMIT}"
LICENSE="MIT"
SLOT="0"
KEYWORDS="~amd64"
-IUSE=""
-S="${WORKDIR}/${PN}-${EGIT_COMMIT}"
+
DOCS=( AUTHORS.rst CHANGELOG.rst README.rst )
+
distutils_enable_tests pytest
+
+python_prepare_all() {
+ sed -e '/--cov/d' -i setup.cfg || die
+ distutils-r1_python_prepare_all
+}