summaryrefslogtreecommitdiff
path: root/dev-python/django-auth-ldap
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2021-01-29 18:03:51 +0000
committerV3n3RiX <venerix@redcorelinux.org>2021-01-29 18:03:51 +0000
commitd7ed2b01311f15ba54fe8ea872aab7d59ab2b193 (patch)
tree1814dd2b5bbf2e7639fdafbeef48d228cfaf5e9b /dev-python/django-auth-ldap
parentabaa75b10f899ada8dd05b23cc03205064394bc6 (diff)
gentoo resync : 29.01.2021
Diffstat (limited to 'dev-python/django-auth-ldap')
-rw-r--r--dev-python/django-auth-ldap/Manifest4
-rw-r--r--dev-python/django-auth-ldap/django-auth-ldap-2.2.0.ebuild38
-rw-r--r--dev-python/django-auth-ldap/metadata.xml2
3 files changed, 42 insertions, 2 deletions
diff --git a/dev-python/django-auth-ldap/Manifest b/dev-python/django-auth-ldap/Manifest
index adeac7243653..5c1a3a936407 100644
--- a/dev-python/django-auth-ldap/Manifest
+++ b/dev-python/django-auth-ldap/Manifest
@@ -1,3 +1,5 @@
DIST django-auth-ldap-2.1.0.tar.gz 51027 BLAKE2B 1229d184746cf05f9c7ddb9e6674b2c529a0fc6d051f78ba01de6a80b0e5e408a8da10e35087efad60f1fef90be708e8a0c05b04c4408500329d9dfb567c0f8b SHA512 4c204eee856e33fae80a22a80bd0f3a21d1f2ee33b1ad56087832f89e91d7e1441579cf77541c1c35e8e0532d4da937b736fe3b4708d7c2d7bbccacbb0b24061
+DIST django-auth-ldap-2.2.0.tar.gz 53148 BLAKE2B 1f83a2f174d9fcbd264ce7e298c0dfebc720482b058e55833416440627c9e1fc02f2ad4e585e6fe01102f100337df5835020b8ff48a5dccb850cfff28ef902a0 SHA512 2ed1913e81a4801d683280586018df57067ec84b44299da4c6415452c978c8f1d2ca1d36eaced40efa0737180d7e35971e4570753f60d946b32d846b455ab744
EBUILD django-auth-ldap-2.1.0.ebuild 815 BLAKE2B 910123666df462c14ff541c68a6acc5cdd7a14d591c49dfcdd0e1f49f10af2e17731c5740c74789893efb6ac884e5991514a5d61adfc40c829861a1231f0643c SHA512 8c84ad3dce69989e4241b1201409c99dca497ade0df83f98aefdadcf342e41c446b8682f40296cb0b9b500260df6ac6986cee7c8f44f09d9222f0e02bccbb528
-MISC metadata.xml 398 BLAKE2B 89e1948a1d118a27477e02fc01d630aaf7c9199cd913a08efc5510fec05996e1aef84fbac359d09ef73a5de083b1920747928c3626afe7aa9c1c9dfa720f16c1 SHA512 e3350f6ab3d2c07965eb2c6ba1d82a929bea8e9974d8a2cdc12acde88aab50f2c20105e90e847a23e5dea5f97a7ab6a7a0c9eb75e193eb90ea5453c53eb36d41
+EBUILD django-auth-ldap-2.2.0.ebuild 889 BLAKE2B a4ad917b62807db3f0a895fcbe3049ca0207b42cf4c31dd424684e918c0711a6c6d353c0a06bb891d7495a4904d3727eef44c1a5d38bf4803e856e0ffd424b74 SHA512 9c992070ebd70d95f78adb5aa6a9214d44a0be0722fe910abcc941ee3c6b74e2f72970be8f9ec8435ce985c66ce4706ac4baa5d58200539dd03dea25523a0b95
+MISC metadata.xml 404 BLAKE2B 5f203773409d544e168b6be9303ff7ad455977584df34b302fec6c84993362bb3b5058984e3e7b4c413081c47f2b0ba7301e1e866fc88297f524e3920afef353 SHA512 dee72beea7aeec5097d015e83ba95cd256005545294312d9dfa80ebe52489d6d5a1ef132177d6dbcfe77ef4fa306b532c86a5de86cbb84c8f1e0a02c86617c6e
diff --git a/dev-python/django-auth-ldap/django-auth-ldap-2.2.0.ebuild b/dev-python/django-auth-ldap/django-auth-ldap-2.2.0.ebuild
new file mode 100644
index 000000000000..02b2c25aefb4
--- /dev/null
+++ b/dev-python/django-auth-ldap/django-auth-ldap-2.2.0.ebuild
@@ -0,0 +1,38 @@
+# Copyright 1999-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+PYTHON_COMPAT=( python3_{7,8,9} )
+
+inherit distutils-r1
+
+DESCRIPTION="Django LDAP authentication backend"
+HOMEPAGE="https://github.com/django-auth-ldap/django-auth-ldap
+ https://pypi.org/project/django-auth-ldap/"
+SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+
+KEYWORDS="~amd64 ~x86"
+IUSE="test"
+RESTRICT="!test? ( test )"
+
+LICENSE="BSD-2"
+SLOT="0"
+
+RDEPEND="
+ >=dev-python/django-2.2[${PYTHON_USEDEP}]
+ >=dev-python/python-ldap-3.1[${PYTHON_USEDEP}]"
+BDEPEND="
+ test? (
+ $(python_gen_impl_dep sqlite)
+ net-nds/openldap[-minimal]
+ )"
+
+distutils_enable_sphinx docs --no-autodoc
+
+python_test() {
+ # for slapd and slapdtest
+ local -x SBIN=/usr/sbin:/usr/$(get_libdir)/openldap
+ django-admin test -v 2 --settings tests.settings \
+ || die "Tests failed with ${EPYTHON}"
+}
diff --git a/dev-python/django-auth-ldap/metadata.xml b/dev-python/django-auth-ldap/metadata.xml
index cff59c60de52..ed12380cd990 100644
--- a/dev-python/django-auth-ldap/metadata.xml
+++ b/dev-python/django-auth-ldap/metadata.xml
@@ -7,6 +7,6 @@
</maintainer>
<upstream>
<remote-id type="pypi">django-auth-ldap</remote-id>
- <remote-id type="bitbucket">psagers/django-auth-ldap</remote-id>
+ <remote-id type="github">django-auth-ldap/django-auth-ldap</remote-id>
</upstream>
</pkgmetadata>