summaryrefslogtreecommitdiff
path: root/dev-python/django-auth-ldap/django-auth-ldap-4.2.0.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2023-03-28 15:50:58 +0100
committerV3n3RiX <venerix@koprulu.sector>2023-03-28 15:50:58 +0100
commitd41bd0acd3d0cd850cdd815b12e69ee2c89c5697 (patch)
tree0ea617df50a6f9fb89fc7e509e3d4ddf0d244b64 /dev-python/django-auth-ldap/django-auth-ldap-4.2.0.ebuild
parent115dcc7054f5934a2c8e26fd8a8eed5f3e29e9ce (diff)
gentoo auto-resync : 28:03:2023 - 15:50:57
Diffstat (limited to 'dev-python/django-auth-ldap/django-auth-ldap-4.2.0.ebuild')
-rw-r--r--dev-python/django-auth-ldap/django-auth-ldap-4.2.0.ebuild49
1 files changed, 49 insertions, 0 deletions
diff --git a/dev-python/django-auth-ldap/django-auth-ldap-4.2.0.ebuild b/dev-python/django-auth-ldap/django-auth-ldap-4.2.0.ebuild
new file mode 100644
index 000000000000..6b295cdc596b
--- /dev/null
+++ b/dev-python/django-auth-ldap/django-auth-ldap-4.2.0.ebuild
@@ -0,0 +1,49 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=setuptools
+PYTHON_COMPAT=( python3_{9..11} )
+
+inherit distutils-r1
+
+DESCRIPTION="Django LDAP authentication backend"
+HOMEPAGE="
+ https://github.com/django-auth-ldap/django-auth-ldap/
+ https://pypi.org/project/django-auth-ldap/
+"
+SRC_URI="
+ https://github.com/django-auth-ldap/django-auth-ldap/archive/${PV}.tar.gz
+ -> ${P}.gh.tar.gz
+"
+
+KEYWORDS="~amd64 ~x86"
+IUSE="test"
+RESTRICT="!test? ( test )"
+
+LICENSE="BSD-2"
+SLOT="0"
+
+RDEPEND="
+ >=dev-python/django-2.2[${PYTHON_USEDEP}]
+ >=dev-python/python-ldap-3.1[${PYTHON_USEDEP}]
+"
+BDEPEND="
+ dev-python/setuptools-scm[${PYTHON_USEDEP}]
+ test? (
+ $(python_gen_impl_dep sqlite)
+ net-nds/openldap[-minimal]
+ )
+"
+
+distutils_enable_sphinx docs --no-autodoc
+
+export SETUPTOOLS_SCM_PRETEND_VERSION=${PV}
+
+python_test() {
+ # for slapd and slapdtest
+ local -x SBIN=/usr/sbin:/usr/$(get_libdir)/openldap
+ "${EPYTHON}" -m django test -v 2 --settings tests.settings ||
+ die "Tests failed with ${EPYTHON}"
+}