summaryrefslogtreecommitdiff
path: root/dev-python/django-appconf
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2018-07-14 21:03:06 +0100
committerV3n3RiX <venerix@redcorelinux.org>2018-07-14 21:03:06 +0100
commit8376ef56580626e9c0f796d5b85b53a0a1c7d5f5 (patch)
tree7681bbd4e8b05407772df40a4bf04cbbc8afc3fa /dev-python/django-appconf
parent30a9caf154332f12ca60756e1b75d2f0e3e1822d (diff)
gentoo resync : 14.07.2018
Diffstat (limited to 'dev-python/django-appconf')
-rw-r--r--dev-python/django-appconf/Manifest4
-rw-r--r--dev-python/django-appconf/django-appconf-1.0.1.ebuild39
-rw-r--r--dev-python/django-appconf/files/docs.patch16
-rw-r--r--dev-python/django-appconf/metadata.xml12
4 files changed, 71 insertions, 0 deletions
diff --git a/dev-python/django-appconf/Manifest b/dev-python/django-appconf/Manifest
new file mode 100644
index 000000000000..ccba49ea71fc
--- /dev/null
+++ b/dev-python/django-appconf/Manifest
@@ -0,0 +1,4 @@
+AUX docs.patch 713 BLAKE2B dabe5ab114ea18911e9f7de38040348405116486bcb0cb0eeca8d2dcfd4becbdc99ce3a306338b03987064a53adec5fa7acc310f81de8e76d68582d91148d335 SHA512 af930dfca53b0353c7d0af3671a924174b5c2d6dbf3da299a77dfd603e2a510724024e2d6b1d51cb2ad6d7edff3f1bef0813b7f12af1d7628f022e3ee4667996
+DIST django-appconf-1.0.1.tar.gz 16743 BLAKE2B 0f40d2bac6ca596c83dd67b1109c0a298d845a8091565aceb57230132004f634e9227aeaf07766a3e690feae9833ec1395bc6f409f4412648d8e7df4c2533ba1 SHA512 b6075bed0372f7f9da7c7af49124a08a2d119533ea15b284529166bcc09e61a541ce179a696dd426a9323ea1874c219880869ef7934345f4d40b1b3201eb2c6d
+EBUILD django-appconf-1.0.1.ebuild 927 BLAKE2B e28de5f936a22c2b55d070613b17218def42cd80e2665bdbeba953846c1923107d6f030ba46d8a7e2b987c6255e47a3a3cb769a1699b2dcbec24aa596f62df68 SHA512 32c85165cdc8d20454ca11f241fcc7199085f6ec59060b33d01cd8cb5a0a4ffad9a88cf65278d5a824c936cb452c30a80036f26ceb08b832e85258c6822a72d7
+MISC metadata.xml 390 BLAKE2B 86804c4033e0cc6649e2d0734283205ec8390f6d2067b51945944c0bcc30744ce45d8ce9ec229e007901ad9e01ba874cdac2ac7c62d176cc10850c243bb694db SHA512 2fe634938c78aa61b5d8f2bbe6e5ef4144a5d15c3e7c91691048427fa604cfe7229b924a0196d5d95488ffaea568a4a4c218056ebd010a36ee2f6b339785c66f
diff --git a/dev-python/django-appconf/django-appconf-1.0.1.ebuild b/dev-python/django-appconf/django-appconf-1.0.1.ebuild
new file mode 100644
index 000000000000..4ef1eab5fa23
--- /dev/null
+++ b/dev-python/django-appconf/django-appconf-1.0.1.ebuild
@@ -0,0 +1,39 @@
+# Copyright 1999-2018 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=5
+
+PYTHON_COMPAT=( python{2_7,3_4,3_5,3_6} )
+
+inherit distutils-r1
+
+DESCRIPTION="A helper class for handling configuration defaults of packaged apps gracefully"
+HOMEPAGE="
+ https://github.com/jezdez/django-appconf
+ https://django-appconf.readthedocs.io/en/latest/
+ https://pypi.org/project/django-appconf/"
+SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="amd64 x86"
+IUSE="doc"
+
+RDEPEND="
+ >=dev-python/django-1.4.1[${PYTHON_USEDEP}]
+ dev-python/six[${PYTHON_USEDEP}]"
+DEPEND="${RDEPEND}
+ dev-python/setuptools[${PYTHON_USEDEP}]
+ doc? ( dev-python/sphinx[${PYTHON_USEDEP}] )
+ "
+
+PATCHES=( "${FILESDIR}"/docs.patch )
+
+python_compile_all() {
+ use doc && emake -C docs html
+}
+
+python_install_all() {
+ use doc && HTML_DOCS=( docs/_build/html/. )
+ distutils-r1_python_install_all
+}
diff --git a/dev-python/django-appconf/files/docs.patch b/dev-python/django-appconf/files/docs.patch
new file mode 100644
index 000000000000..4b5d4861adfd
--- /dev/null
+++ b/dev-python/django-appconf/files/docs.patch
@@ -0,0 +1,16 @@
+Prevent unwanted d'loading of un-needed oject.inv files in doc build
+diff -ur django-appconf-0.6.orig/docs/conf.py django-appconf-0.6/docs/conf.py
+--- docs/conf.py 2013-01-29 01:45:50.000000000 +0800
++++ docs/conf.py 2013-05-18 21:40:38.737985957 +0800
+@@ -218,11 +218,3 @@
+ ('index', 'django-appconf', u'django-appconf Documentation',
+ [u'Jannis Leidel and individual contributors'], 1)
+ ]
+-
+-
+-# Example configuration for intersphinx: refer to the Python standard library.
+-intersphinx_mapping = {
+- 'python': ('http://python.readthedocs.org/en/v2.7.2/', None),
+- 'django': ('http://django.readthedocs.org/en/latest/', None),
+- 'celery': ('http://celery.readthedocs.org/en/latest/', None),
+-}
diff --git a/dev-python/django-appconf/metadata.xml b/dev-python/django-appconf/metadata.xml
new file mode 100644
index 000000000000..67f844e48386
--- /dev/null
+++ b/dev-python/django-appconf/metadata.xml
@@ -0,0 +1,12 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <maintainer type="project">
+ <email>python@gentoo.org</email>
+ <name>Python</name>
+ </maintainer>
+ <upstream>
+ <remote-id type="github">jezdez/django-appconf</remote-id>
+ <remote-id type="pypi">django-appconf</remote-id>
+ </upstream>
+</pkgmetadata>