summaryrefslogtreecommitdiff
path: root/dev-python/dj-database-url
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2022-07-30 15:10:23 +0100
committerV3n3RiX <venerix@koprulu.sector>2022-07-30 15:10:23 +0100
commit27b0740bf48a0a181090a49d20f368ac8474e90b (patch)
treed715e035ea5c7dfe4a21b510e898913c33289cfa /dev-python/dj-database-url
parentad0412d0cafb8c04ce98024155cf99a4cc27db44 (diff)
gentoo auto-resync : 30:07:2022 - 15:10:23
Diffstat (limited to 'dev-python/dj-database-url')
-rw-r--r--dev-python/dj-database-url/Manifest2
-rw-r--r--dev-python/dj-database-url/dj-database-url-1.0.0.ebuild29
2 files changed, 31 insertions, 0 deletions
diff --git a/dev-python/dj-database-url/Manifest b/dev-python/dj-database-url/Manifest
index 62050de3d598..a3bc678537f7 100644
--- a/dev-python/dj-database-url/Manifest
+++ b/dev-python/dj-database-url/Manifest
@@ -1,3 +1,5 @@
DIST dj-database-url-0.5.0.gh.tar.gz 6309 BLAKE2B 72647f8651d595b4020161b15364836b8483bf8a12ec72e434bc9d0583878ee9f4e4c76110581f285adddac3e7c2d7bc071f720a7fde91c84c3ea53b6c979300 SHA512 541d5177bff0fcc21372d2d9dc699ba11de1b1cabf10d61fb9f1e844a6dd4d46df5c7fdb6ccb4505cf984e41d7a2ae4e3af5e7d05072b0ed6982499eac5aac66
+DIST dj-database-url-1.0.0.gh.tar.gz 11355 BLAKE2B 9ea50eb2646367333556133020a59f332cb69e05fb392f328558f77cb03ffa968cf62241f3823e28600799a1399ac1335b90477a26a4931b0df7b695b502e9be SHA512 35ca0c05910812e10bf63b061afb434ac7c562e3d994b6e452250fe4ec95983fe8353aec0df9c7638a990684e612863ddada5be48485a1db3120e110f6d0fa94
EBUILD dj-database-url-0.5.0-r1.ebuild 600 BLAKE2B c646cba05e301646b5caeb739ff0303a798aebc74a7138b4169fa486d30ef6cf2cb5931f8cb307330aeb80a83b2e1895cf296a5ee09684006c8a7f1024c605f2 SHA512 81b8af28ca78737c0b190566a9f113b5c7450fa900d5492a879f0755d45d7be7f674590a7c33572ecf1e3a6e28b2f847f85150d1a1e182aa4f778f57b518c7d7
+EBUILD dj-database-url-1.0.0.ebuild 654 BLAKE2B 0da0bb086aa0c39499f59d81e270b903ad6f997621c30f827a2724fc048726dd4184c1ca57939e1552c92cb740d8e60267920e383d83cd0e3a9de7a9fd268131 SHA512 00757c36e3d74cb94fb98a68867550530da8827a27e0dccec9fa10c3a8e692d7da3838181f7989d9928519a56a5e364eb6344469efa09105c4b082c7a9da3540
MISC metadata.xml 407 BLAKE2B 0a3736cc0034297f64b77b9b795e8cd339ed58c5b213e730f1d3dccabe7cde10570222626b2b520bc0e51a0195cd99baf4ebf7028cc73b7e507603874b1f4143 SHA512 ec842e583cd4e0b632731e395f6e70e519077bfeaeb58bb88b9ad297368443fc06a182c120635eeb1dedb76b166829c6f414925d3061e55d49d7053a72c739eb
diff --git a/dev-python/dj-database-url/dj-database-url-1.0.0.ebuild b/dev-python/dj-database-url/dj-database-url-1.0.0.ebuild
new file mode 100644
index 000000000000..c30f6849ca02
--- /dev/null
+++ b/dev-python/dj-database-url/dj-database-url-1.0.0.ebuild
@@ -0,0 +1,29 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=setuptools
+PYTHON_COMPAT=( python3_{8..11} )
+
+inherit distutils-r1
+
+DESCRIPTION="Use Database URLs in your Django Application"
+HOMEPAGE="
+ https://github.com/jazzband/dj-database-url/
+ https://pypi.org/project/dj-database-url/
+"
+SRC_URI="
+ https://github.com/jazzband/dj-database-url/archive/v${PV}.tar.gz
+ -> ${P}.gh.tar.gz
+"
+
+SLOT="0"
+LICENSE="BSD"
+KEYWORDS="~amd64 ~arm ~arm64 ~ppc ~ppc64 ~riscv ~sparc ~x86 ~amd64-linux ~x86-linux"
+
+RDEPEND="
+ dev-python/django[${PYTHON_USEDEP}]
+"
+
+distutils_enable_tests unittest