summaryrefslogtreecommitdiff
path: root/dev-python/dj-database-url/dj-database-url-2.1.0.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2023-08-15 21:27:56 +0100
committerV3n3RiX <venerix@koprulu.sector>2023-08-15 21:27:56 +0100
commit3648761f2708fcf5662ea1b9585f594c36eefc30 (patch)
tree7b8af3caaff06cdddb5c39ec135ecc908b62a139 /dev-python/dj-database-url/dj-database-url-2.1.0.ebuild
parent4214d835b45f0047c644e43c7fa70f1bbdb2e8b3 (diff)
gentoo auto-resync : 15:08:2023 - 21:27:55
Diffstat (limited to 'dev-python/dj-database-url/dj-database-url-2.1.0.ebuild')
-rw-r--r--dev-python/dj-database-url/dj-database-url-2.1.0.ebuild31
1 files changed, 31 insertions, 0 deletions
diff --git a/dev-python/dj-database-url/dj-database-url-2.1.0.ebuild b/dev-python/dj-database-url/dj-database-url-2.1.0.ebuild
new file mode 100644
index 000000000000..59d5c6379615
--- /dev/null
+++ b/dev-python/dj-database-url/dj-database-url-2.1.0.ebuild
@@ -0,0 +1,31 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=setuptools
+PYPI_NO_NORMALIZE=1
+PYTHON_COMPAT=( python3_{10..11} )
+
+inherit distutils-r1 pypi
+
+DESCRIPTION="Use Database URLs in your Django Application"
+HOMEPAGE="
+ https://github.com/jazzband/dj-database-url/
+ https://pypi.org/project/dj-database-url/
+"
+
+SLOT="0"
+LICENSE="BSD"
+KEYWORDS="~amd64 ~arm ~arm64 ~ppc ~ppc64 ~riscv ~sparc ~x86 ~amd64-linux ~x86-linux"
+
+RDEPEND="
+ dev-python/django[${PYTHON_USEDEP}]
+ >=dev-python/typing-extensions-3.10.0.0[${PYTHON_USEDEP}]
+"
+
+distutils_enable_tests unittest
+
+python_test() {
+ eunittest -s tests
+}